Console Output

Started by upstream project "sprotty-theia/master" build number 17
originally caused by:
 Branch indexing
Running in Durability level: PERFORMANCE_OPTIMIZED
[Pipeline] Start of Pipeline
[Pipeline] podTemplate
[Pipeline] {
[Pipeline] node
Still waiting to schedule task
Waiting for next available executor
Created Pod: sprotty/sprotty-agent-pod-k8xqv-lv14w
[Normal][sprotty/sprotty-agent-pod-k8xqv-lv14w][Scheduled] Successfully assigned sprotty-agent-pod-k8xqv-lv14w to osnode-22.eclipse.org
[Normal][sprotty/sprotty-agent-pod-k8xqv-lv14w][SuccessfulMountVolume] MountVolume.SetUp succeeded for volume "jenkins-home" 
[Normal][sprotty/sprotty-agent-pod-k8xqv-lv14w][SuccessfulMountVolume] MountVolume.SetUp succeeded for volume "yarn-global" 
[Normal][sprotty/sprotty-agent-pod-k8xqv-lv14w][SuccessfulMountVolume] MountVolume.SetUp succeeded for volume "workspace-volume" 
[Normal][sprotty/sprotty-agent-pod-k8xqv-lv14w][SuccessfulMountVolume] MountVolume.SetUp succeeded for volume "default-token-l45kh" 
[Normal][sprotty/sprotty-agent-pod-k8xqv-lv14w][Pulled] Container image "node:12.14.1" already present on machine
[Normal][sprotty/sprotty-agent-pod-k8xqv-lv14w][Created] Created container
[Normal][sprotty/sprotty-agent-pod-k8xqv-lv14w][Started] Started container
[Normal][sprotty/sprotty-agent-pod-k8xqv-lv14w][Pulled] Container image "docker.io/eclipsecbi/jiro-agent-basic:remoting-4.5" already present on machine
[Normal][sprotty/sprotty-agent-pod-k8xqv-lv14w][Created] Created container
[Normal][sprotty/sprotty-agent-pod-k8xqv-lv14w][Started] Started container
Agent sprotty-agent-pod-k8xqv-lv14w is provisioned from template sprotty-agent-pod-k8xqv
---
apiVersion: "v1"
kind: "Pod"
metadata:
  annotations:
    buildUrl: "http://jenkins-ui.sprotty.svc.cluster.local/sprotty/job/deploy-sprotty-theia/7/"
    runUrl: "job/deploy-sprotty-theia/7/"
  labels:
    jenkins: "slave"
    jenkins/label: "sprotty-agent-pod"
  name: "sprotty-agent-pod-k8xqv-lv14w"
spec:
  containers:
  - command:
    - "cat"
    image: "node:12.14.1"
    name: "node"
    resources:
      limits:
        memory: "2Gi"
        cpu: "1"
      requests:
        memory: "2Gi"
        cpu: "1"
    tty: true
    volumeMounts:
    - mountPath: "/home/jenkins"
      name: "jenkins-home"
      readOnly: false
    - mountPath: "/.yarn"
      name: "yarn-global"
      readOnly: false
    - mountPath: "/home/jenkins/agent"
      name: "workspace-volume"
      readOnly: false
  - env:
    - name: "JENKINS_SECRET"
      value: "********"
    - name: "JENKINS_TUNNEL"
      value: "jenkins-discovery.sprotty.svc.cluster.local:50000"
    - name: "JENKINS_AGENT_NAME"
      value: "sprotty-agent-pod-k8xqv-lv14w"
    - name: "JENKINS_NAME"
      value: "sprotty-agent-pod-k8xqv-lv14w"
    - name: "JENKINS_AGENT_WORKDIR"
      value: "/home/jenkins/agent"
    - name: "JENKINS_URL"
      value: "http://jenkins-ui.sprotty.svc.cluster.local/sprotty/"
    image: "docker.io/eclipsecbi/jiro-agent-basic:remoting-4.5"
    name: "jnlp"
    resources:
      requests:
        cpu: "100m"
        memory: "256Mi"
    volumeMounts:
    - mountPath: "/home/jenkins/agent"
      name: "workspace-volume"
      readOnly: false
  nodeSelector:
    beta.kubernetes.io/os: "linux"
  restartPolicy: "Never"
  securityContext: {}
  volumes:
  - emptyDir: {}
    name: "yarn-global"
  - emptyDir: {}
    name: "jenkins-home"
  - emptyDir:
      medium: ""
    name: "workspace-volume"

Running on sprotty-agent-pod-k8xqv-lv14w in /home/jenkins/agent/workspace/deploy-sprotty-theia
[Pipeline] {
[Pipeline] withEnv
[Pipeline] {
[Pipeline] stage
[Pipeline] { (Checkout master)
[Pipeline] git
Selected Git installation does not exist. Using Default
The recommended git tool is: NONE
using credential github-bot
Cloning the remote Git repository
Cloning repository https://github.com/eclipse/sprotty-theia.git
 > git init /home/jenkins/agent/workspace/deploy-sprotty-theia # timeout=10
Fetching upstream changes from https://github.com/eclipse/sprotty-theia.git
 > git --version # timeout=10
 > git --version # 'git version 2.26.2'
using GIT_ASKPASS to set credentials GitHub bot (username/token)
 > git fetch --tags --force --progress -- https://github.com/eclipse/sprotty-theia.git +refs/heads/*:refs/remotes/origin/* # timeout=10
Avoid second fetch
Checking out Revision 9a5dfd1cc2ebba5a2ce9e0dcba84bcd11020b184 (refs/remotes/origin/master)
 > git config remote.origin.url https://github.com/eclipse/sprotty-theia.git # timeout=10
 > git config --add remote.origin.fetch +refs/heads/*:refs/remotes/origin/* # timeout=10
 > git rev-parse refs/remotes/origin/master^{commit} # timeout=10
 > git config core.sparsecheckout # timeout=10
 > git checkout -f 9a5dfd1cc2ebba5a2ce9e0dcba84bcd11020b184 # timeout=10
 > git branch -a -v --no-abbrev # timeout=10
 > git checkout -b master 9a5dfd1cc2ebba5a2ce9e0dcba84bcd11020b184 # timeout=10
Commit message: "Switch sprotty dependency back to next"
 > git rev-list --no-walk fede751da4eeca701da5ba3612cdc86f0019458c # timeout=10
[Pipeline] }
[Pipeline] // stage
[Pipeline] stage
[Pipeline] { (Build & Deploy)
[Pipeline] container
[Pipeline] {
[Pipeline] withCredentials
Masking supported pattern matches of $NPM_AUTH_TOKEN
[Pipeline] {
[Pipeline] sh
+ printf //registry.npmjs.org/:_authToken=****

[Pipeline] }
[Pipeline] // withCredentials
[Pipeline] sh
+ git config user.email eclipse-sprotty-bot@eclipse.org
[Pipeline] sh
+ git config user.name eclipse-sprotty-bot
[Pipeline] sh
+ yarn install
yarn install v1.21.1
[1/4] Resolving packages...
[2/4] Fetching packages...
info fsevents@2.1.3: The platform "linux" is incompatible with this module.
info "fsevents@2.1.3" is an optional dependency and failed compatibility check. Excluding it from installation.
[3/4] Linking dependencies...
warning "sprotty > snabbdom-virtualize@0.7.0" has incorrect peer dependency "snabbdom@~0.6.6".
[4/4] Building fresh packages...
$ yarn run clean && yarn run build
yarn run v1.21.1
$ rimraf lib artifacts
Done in 0.09s.
yarn run v1.21.1
$ tsc -p ./tsconfig.json && yarn run lint
$ tslint -c ./configs/tslint.json --project ./tsconfig.json
Done in 8.71s.
Done in 50.65s.
[Pipeline] sh
+ yarn publish:next
yarn run v1.21.1
$ yarn publish --new-version "$(semver $npm_package_version -i minor)-next.$(git rev-parse --short HEAD)" --tag next
[1/4] Bumping version...
info Current version: 0.9.0
info New version: 0.10.0-next.9a5dfd1
[2/4] Logging in...
[3/4] Publishing...
$ yarn run clean && yarn run build
$ rimraf lib artifacts
$ tsc -p ./tsconfig.json && yarn run lint
$ tslint -c ./configs/tslint.json --project ./tsconfig.json
$ yarn run test
$ jenkins-mocha --opts ./configs/mocha.opts "./src/**/*.spec.?(ts|tsx)"


  inversify
    ✓ error


  1 passing (27ms)


=============================== Coverage summary ===============================
Statements   : Unknown% ( 0/0 )
Branches     : Unknown% ( 0/0 )
Functions    : Unknown% ( 0/0 )
Lines        : Unknown% ( 0/0 )
================================================================================
success Published.
[4/4] Revoking token...
info Not revoking login token, specified via config file.
Done in 15.88s.
[Pipeline] }
[Pipeline] // container
[Pipeline] }
[Pipeline] // stage
[Pipeline] }
[Pipeline] // withEnv
[Pipeline] }
[Pipeline] // node
[Pipeline] }
[Pipeline] // podTemplate
[Pipeline] End of Pipeline
Finished: SUCCESS