Console Output

Started by upstream project "sprotty-theia/master" build number 25
originally caused by:
 Branch indexing
[Pipeline] Start of Pipeline
[Pipeline] echo
[WARNING] label option is deprecated. To use a static pod template, use the 'inheritFrom' option.
[Pipeline] podTemplate
[Pipeline] {
[Pipeline] node
Created Pod: kubernetes sprotty/sprotty-agent-pod-hl6q4-341sx
[Normal][sprotty/sprotty-agent-pod-hl6q4-341sx][Scheduled] Successfully assigned sprotty/sprotty-agent-pod-hl6q4-341sx to okdnode-26
[Normal][sprotty/sprotty-agent-pod-hl6q4-341sx][AddedInterface] Add eth0 [10.40.53.102/23]
[Normal][sprotty/sprotty-agent-pod-hl6q4-341sx][Pulling] Pulling image "eclipsetheia/theia-blueprint"
[Normal][sprotty/sprotty-agent-pod-hl6q4-341sx][Pulled] Successfully pulled image "eclipsetheia/theia-blueprint" in 2.631084782s
[Normal][sprotty/sprotty-agent-pod-hl6q4-341sx][Created] Created container node
[Normal][sprotty/sprotty-agent-pod-hl6q4-341sx][Started] Started container node
[Normal][sprotty/sprotty-agent-pod-hl6q4-341sx][Pulled] Container image "docker.io/eclipsecbi/jiro-agent-basic:remoting-4.10" already present on machine
[Normal][sprotty/sprotty-agent-pod-hl6q4-341sx][Created] Created container jnlp
[Normal][sprotty/sprotty-agent-pod-hl6q4-341sx][Started] Started container jnlp
Still waiting to schedule task
‘sprotty-agent-pod-hl6q4-341sx’ is offline
Agent sprotty-agent-pod-hl6q4-341sx is provisioned from template sprotty-agent-pod-hl6q4
---
apiVersion: "v1"
kind: "Pod"
metadata:
  annotations:
    buildUrl: "http://jenkins-ui.sprotty.svc.cluster.local/sprotty/job/deploy-sprotty-theia/15/"
    runUrl: "job/deploy-sprotty-theia/15/"
  labels:
    jenkins: "slave"
    jenkins/label-digest: "94c9ac7d111dbbd882706642673985e1e8e78a4d"
    jenkins/label: "sprotty-agent-pod"
  name: "sprotty-agent-pod-hl6q4-341sx"
spec:
  containers:
  - command:
    - "cat"
    image: "eclipsetheia/theia-blueprint"
    name: "node"
    resources:
      limits:
        memory: "2Gi"
        cpu: "1"
      requests:
        memory: "2Gi"
        cpu: "1"
    tty: true
    volumeMounts:
    - mountPath: "/home/jenkins"
      name: "jenkins-home"
      readOnly: false
    - mountPath: "/.yarn"
      name: "yarn-global"
      readOnly: false
    - mountPath: "/.cache"
      name: "global-cache"
    - mountPath: "/.npm"
      name: "global-npm"
    - mountPath: "/home/jenkins/agent"
      name: "workspace-volume"
      readOnly: false
  - env:
    - name: "JENKINS_SECRET"
      value: "********"
    - name: "JENKINS_TUNNEL"
      value: "jenkins-discovery.sprotty.svc.cluster.local:50000"
    - name: "JENKINS_AGENT_NAME"
      value: "sprotty-agent-pod-hl6q4-341sx"
    - name: "JENKINS_NAME"
      value: "sprotty-agent-pod-hl6q4-341sx"
    - name: "JENKINS_AGENT_WORKDIR"
      value: "/home/jenkins/agent"
    - name: "JENKINS_URL"
      value: "http://jenkins-ui.sprotty.svc.cluster.local/sprotty/"
    image: "docker.io/eclipsecbi/jiro-agent-basic:remoting-4.10"
    name: "jnlp"
    resources:
      limits: {}
      requests:
        memory: "256Mi"
        cpu: "100m"
    volumeMounts:
    - mountPath: "/home/jenkins/agent"
      name: "workspace-volume"
      readOnly: false
  nodeSelector:
    kubernetes.io/os: "linux"
  restartPolicy: "Never"
  volumes:
  - emptyDir: {}
    name: "yarn-global"
  - emptyDir: {}
    name: "jenkins-home"
  - emptyDir: {}
    name: "global-cache"
  - emptyDir:
      medium: ""
    name: "workspace-volume"
  - emptyDir: {}
    name: "global-npm"

Running on sprotty-agent-pod-hl6q4-341sx in /home/jenkins/agent/workspace/deploy-sprotty-theia
[Pipeline] {
[Pipeline] withEnv
[Pipeline] {
[Pipeline] stage
[Pipeline] { (Checkout master)
[Pipeline] git
Selected Git installation does not exist. Using Default
The recommended git tool is: NONE
using credential github-bot
Cloning the remote Git repository
Avoid second fetch
Cloning repository https://github.com/eclipse/sprotty-theia.git
 > git init /home/jenkins/agent/workspace/deploy-sprotty-theia # timeout=10
Fetching upstream changes from https://github.com/eclipse/sprotty-theia.git
 > git --version # timeout=10
 > git --version # 'git version 2.20.1'
using GIT_ASKPASS to set credentials GitHub bot (username/token)
 > git fetch --tags --force --progress -- https://github.com/eclipse/sprotty-theia.git +refs/heads/*:refs/remotes/origin/* # timeout=10
 > git config remote.origin.url https://github.com/eclipse/sprotty-theia.git # timeout=10
 > git config --add remote.origin.fetch +refs/heads/*:refs/remotes/origin/* # timeout=10
Checking out Revision 78e9c2f0b367d2e91eba68d96ba8e5678a0853ed (refs/remotes/origin/master)
 > git rev-parse refs/remotes/origin/master^{commit} # timeout=10
 > git config core.sparsecheckout # timeout=10
 > git checkout -f 78e9c2f0b367d2e91eba68d96ba8e5678a0853ed # timeout=10
 > git branch -a -v --no-abbrev # timeout=10
 > git checkout -b master 78e9c2f0b367d2e91eba68d96ba8e5678a0853ed # timeout=10
Commit message: "v0.10.0"
 > git rev-list --no-walk fb0f9eb07dc7c2d5b1b251c24fe60c787bc95601 # timeout=10
[Pipeline] }
[Pipeline] // stage
[Pipeline] stage
[Pipeline] { (Build & Deploy)
[Pipeline] container
[Pipeline] {
[Pipeline] withCredentials
Masking supported pattern matches of $NPM_AUTH_TOKEN
[Pipeline] {
[Pipeline] sh
+ printf //registry.npmjs.org/:_authToken=****

[Pipeline] }
[Pipeline] // withCredentials
[Pipeline] sh
+ git config user.email eclipse-sprotty-bot@eclipse.org
[Pipeline] sh
+ git config user.name eclipse-sprotty-bot
[Pipeline] sh
+ yarn install
yarn install v1.22.5
[1/4] Resolving packages...
[2/4] Fetching packages...
info fsevents@2.3.2: The platform "linux" is incompatible with this module.
info "fsevents@2.3.2" is an optional dependency and failed compatibility check. Excluding it from installation.
[3/4] Linking dependencies...
[4/4] Building fresh packages...
$ yarn run clean && yarn run build
yarn run v1.22.5
$ rimraf lib artifacts
Done in 0.10s.
yarn run v1.22.5
$ tsc -p ./tsconfig.json && yarn run lint
$ tslint -c ./configs/tslint.json --project ./tsconfig.json
Done in 10.26s.
Done in 49.72s.
[Pipeline] sh
+ yarn publish:next
yarn run v1.22.5
$ yarn publish --new-version "$(semver $npm_package_version -i minor)-next.$(git rev-parse --short HEAD)" --tag next
[1/4] Bumping version...
info Current version: 0.10.0
info New version: 0.11.0-next.78e9c2f
[2/4] Logging in...
[3/4] Publishing...
$ yarn run clean && yarn run build
$ rimraf lib artifacts
$ tsc -p ./tsconfig.json && yarn run lint
$ tslint -c ./configs/tslint.json --project ./tsconfig.json
$ yarn run test
$ jenkins-mocha --opts ./configs/mocha.opts "./src/**/*.spec.?(ts|tsx)"


  inversify
    ✓ error


  1 passing (6ms)


=============================== Coverage summary ===============================
Statements   : Unknown% ( 0/0 )
Branches     : Unknown% ( 0/0 )
Functions    : Unknown% ( 0/0 )
Lines        : Unknown% ( 0/0 )
================================================================================
success Published.
[4/4] Revoking token...
info Not revoking login token, specified via config file.
Done in 15.55s.
[Pipeline] }
[Pipeline] // container
[Pipeline] }
[Pipeline] // stage
[Pipeline] }
[Pipeline] // withEnv
[Pipeline] }
[Pipeline] // node
[Pipeline] }
[Pipeline] // podTemplate
[Pipeline] End of Pipeline
Finished: SUCCESS