Changes

Summary

  1. #83 Update to Theia 1.18.0 and support Codicons (#85) (details)
Commit fb0f9eb07dc7c2d5b1b251c24fe60c787bc95601 by noreply
#83 Update to Theia 1.18.0 and support Codicons (#85)

* #83 Update to Theia 1.18.0 and support Codicons

- Update Theia to 1.18.0
- Update Jenkinsfile to use eclipsetheia/theia-blueprint docker image to be able to build Theia >=1.15.0 (which requires libsecret-1-dev)
- Update sprotty to latest version
- Use Codicons instead of FontAwesome icons


Co-authored-by: Nina Doschek <ndoschek@eclipsesource.com>
The file was modifiedpackage.json (diff)
The file was modifiedcss/theia-sprotty.css (diff)
The file was modifiedyarn.lock (diff)
The file was modifiedCHANGELOG.md (diff)
The file was modifiedJenkinsfile (diff)
The file was modifiedsrc/theia/diagram-widget.ts (diff)