SuccessConsole Output

Started calculate disk usage of build
Finished Calculation of disk usage of build in 0 seconds
Started calculate disk usage of workspace
Finished Calculation of disk usage of workspace in 0 seconds
[INFO] 
[INFO] ----------< org.eclipse.sensinact.gateway:sensinact-generic >-----------
[INFO] Building sensiNact IoT Gateway - Generic implementation 2.0-SNAPSHOT [21/99]
[INFO] -------------------------------[ bundle ]-------------------------------
[INFO] 
[INFO] --- groovy-maven-plugin:2.0:execute (search-root-clean) @ sensinact-generic ---
[INFO] PATH: /home/hudson/genie.sensinact/.jenkins/jobs/Gateway master Sonar/workspace
[INFO] 
[INFO] --- maven-clean-plugin:2.5:clean (default-clean) @ sensinact-generic ---
[INFO] 
[INFO] --- groovy-maven-plugin:2.0:execute (search-root-validate) @ sensinact-generic ---
[INFO] PATH: /home/hudson/genie.sensinact/.jenkins/jobs/Gateway master Sonar/workspace
[INFO] 
[INFO] --- maven-resources-plugin:3.1.0:resources (default-resources) @ sensinact-generic ---
[INFO] Using 'UTF-8' encoding to copy filtered resources.
[INFO] Copying 1 resource
[INFO] 
[INFO] --- maven-compiler-plugin:3.0:compile (default-compile) @ sensinact-generic ---
[INFO] Changes detected - recompiling the module!
[INFO] Compiling 123 source files to /home/hudson/genie.sensinact/.jenkins/jobs/Gateway master Sonar/workspace/platform/sensinact-generic/target/classes
[WARNING] /home/hudson/genie.sensinact/.jenkins/jobs/Gateway master Sonar/workspace/platform/sensinact-generic/src/main/java/org/eclipse/sensinact/gateway/generic/parser/ResourceClassDefinition.java: Some input files use unchecked or unsafe operations.
[WARNING] /home/hudson/genie.sensinact/.jenkins/jobs/Gateway master Sonar/workspace/platform/sensinact-generic/src/main/java/org/eclipse/sensinact/gateway/generic/parser/ResourceClassDefinition.java: Recompile with -Xlint:unchecked for details.
[INFO] 
[INFO] --- maven-antrun-plugin:1.8:run (default) @ sensinact-generic ---
[WARNING] Parameter tasks is deprecated, use target instead
[INFO] Executing tasks

main:
     [echo] Copying keystore.jks
     [copy] Copying 1 file to /home/hudson/genie.sensinact/.jenkins/jobs/Gateway master Sonar/workspace/platform/sensinact-generic/target/felix/bundle
[INFO] Executed tasks
[INFO] 
[INFO] --- maven-dependency-plugin:2.8:copy (default) @ sensinact-generic ---
[INFO] Configured Artifact: org.apache.felix:org.apache.felix.fileinstall:3.4.0:jar
[INFO] Configured Artifact: org.apache.felix:org.apache.felix.framework.security:2.4.0:jar
[INFO] Configured Artifact: org.eclipse.sensinact.gateway:sensinact-utils:2.0-SNAPSHOT:jar
[INFO] Configured Artifact: org.eclipse.sensinact.gateway:sensinact-datastore-api:2.0-SNAPSHOT:jar
[INFO] Configured Artifact: org.eclipse.sensinact.gateway:sensinact-common:2.0-SNAPSHOT:jar
[INFO] Configured Artifact: org.eclipse.sensinact.gateway:sensinact-framework-extension:2.0-SNAPSHOT:jar
[INFO] Configured Artifact: org.eclipse.sensinact.gateway:sensinact-security-none:2.0-SNAPSHOT:jar
[INFO] Configured Artifact: org.eclipse.sensinact.gateway.tools:sensinact-test-configuration:2.0-SNAPSHOT:jar
[INFO] Configured Artifact: org.eclipse.sensinact.gateway:sensinact-core:2.0-SNAPSHOT:jar
[INFO] Configured Artifact: org.eclipse.sensinact.gateway:sensinact-signature-validator:2.0-SNAPSHOT:jar
[INFO] Configured Artifact: org.eclipse.sensinact.gateway.nthbnd:sensinact-northbound-access:2.0-SNAPSHOT:jar
[INFO] Configured Artifact: org.eclipse.sensinact.gateway.protocol:http:2.0-SNAPSHOT:jar
[INFO] Configured Artifact: javax.servlet:javax.servlet-api:3.1.0:jar
[INFO] Configured Artifact: org.apache.felix:org.apache.felix.http.api:2.3.2:jar
[INFO] Configured Artifact: org.apache.felix:org.apache.felix.http.jetty:3.0.0:jar
[INFO] Configured Artifact: org.apache.felix:org.apache.felix.configadmin:1.8.2:jar
[INFO] Configured Artifact: org.osgi:org.osgi.compendium:5.0.0:jar
[INFO] Copying org.apache.felix.fileinstall-3.4.0.jar to /home/hudson/genie.sensinact/.jenkins/jobs/Gateway master Sonar/workspace/platform/sensinact-generic/target/felix/bundle/org.apache.felix.fileinstall.jar
[INFO] Copying org.apache.felix.framework.security-2.4.0.jar to /home/hudson/genie.sensinact/.jenkins/jobs/Gateway master Sonar/workspace/platform/sensinact-generic/target/felix/bundle/org.apache.felix.framework.security.jar
[INFO] Copying sensinact-utils-2.0-SNAPSHOT.jar to /home/hudson/genie.sensinact/.jenkins/jobs/Gateway master Sonar/workspace/platform/sensinact-generic/target/felix/bundle/sensinact-utils.jar
[INFO] Copying sensinact-datastore-api-2.0-SNAPSHOT.jar to /home/hudson/genie.sensinact/.jenkins/jobs/Gateway master Sonar/workspace/platform/sensinact-generic/target/felix/bundle/sensinact-datastore-api.jar
[INFO] Copying sensinact-common-2.0-SNAPSHOT.jar to /home/hudson/genie.sensinact/.jenkins/jobs/Gateway master Sonar/workspace/platform/sensinact-generic/target/felix/bundle/sensinact-common.jar
[INFO] Copying sensinact-framework-extension-2.0-SNAPSHOT.jar to /home/hudson/genie.sensinact/.jenkins/jobs/Gateway master Sonar/workspace/platform/sensinact-generic/target/felix/bundle/sensinact-framework-extension.jar
[INFO] Copying sensinact-security-none-2.0-SNAPSHOT.jar to /home/hudson/genie.sensinact/.jenkins/jobs/Gateway master Sonar/workspace/platform/sensinact-generic/target/felix/bundle/sensinact-security-none.jar
[INFO] Copying sensinact-test-configuration-2.0-SNAPSHOT.jar to /home/hudson/genie.sensinact/.jenkins/jobs/Gateway master Sonar/workspace/platform/sensinact-generic/target/felix/bundle/sensinact-test-configuration.jar
[INFO] Copying sensinact-core-2.0-SNAPSHOT.jar to /home/hudson/genie.sensinact/.jenkins/jobs/Gateway master Sonar/workspace/platform/sensinact-generic/target/felix/bundle/sensinact-core.jar
[INFO] Copying sensinact-signature-validator-2.0-SNAPSHOT.jar to /home/hudson/genie.sensinact/.jenkins/jobs/Gateway master Sonar/workspace/platform/sensinact-generic/target/felix/bundle/sensinact-signature-validator.jar
[INFO] Copying sensinact-northbound-access-2.0-SNAPSHOT.jar to /home/hudson/genie.sensinact/.jenkins/jobs/Gateway master Sonar/workspace/platform/sensinact-generic/target/felix/bundle/sensinact-northbound-access.jar
[INFO] Copying http-2.0-SNAPSHOT.jar to /home/hudson/genie.sensinact/.jenkins/jobs/Gateway master Sonar/workspace/platform/sensinact-generic/target/felix/bundle/http.jar
[INFO] Copying javax.servlet-api-3.1.0.jar to /home/hudson/genie.sensinact/.jenkins/jobs/Gateway master Sonar/workspace/platform/sensinact-generic/target/felix/bundle/javax.servlet-api.jar
[INFO] Copying org.apache.felix.http.api-2.3.2.jar to /home/hudson/genie.sensinact/.jenkins/jobs/Gateway master Sonar/workspace/platform/sensinact-generic/target/felix/bundle/org.apache.felix.http.api.jar
[INFO] Copying org.apache.felix.http.jetty-3.0.0.jar to /home/hudson/genie.sensinact/.jenkins/jobs/Gateway master Sonar/workspace/platform/sensinact-generic/target/felix/bundle/org.apache.felix.http.jetty.jar
[INFO] Copying org.apache.felix.configadmin-1.8.2.jar to /home/hudson/genie.sensinact/.jenkins/jobs/Gateway master Sonar/workspace/platform/sensinact-generic/target/felix/bundle/org.apache.felix.configadmin.jar
[INFO] Copying org.osgi.compendium-5.0.0.jar to /home/hudson/genie.sensinact/.jenkins/jobs/Gateway master Sonar/workspace/platform/sensinact-generic/target/felix/bundle/org.osgi.compendium.jar
[INFO] 
[INFO] --- maven-bundle-plugin:2.5.3:manifest (default) @ sensinact-generic ---
[WARNING] Include-Resource: overriding sensinact-resource.xsd=src/main/resources/sensinact-resource.xsd with about.html,src/main/resources/ (add {maven-resources} if you want to include the maven resources)
[INFO] 
[INFO] --- maven-resources-plugin:3.1.0:testResources (default-testResources) @ sensinact-generic ---
[INFO] Using 'UTF-8' encoding to copy filtered resources.
[INFO] Copying 9 resources
[INFO] 
[INFO] --- maven-compiler-plugin:3.0:testCompile (default-testCompile) @ sensinact-generic ---
[INFO] Changes detected - recompiling the module!
[INFO] Compiling 1 source file to /home/hudson/genie.sensinact/.jenkins/jobs/Gateway master Sonar/workspace/platform/sensinact-generic/target/test-classes
[INFO] 
[INFO] --- maven-antrun-plugin:1.8:run (createClassesDir) @ sensinact-generic ---
[INFO] Executing tasks

main:
    [mkdir] Created dir: /home/hudson/genie.sensinact/.jenkins/jobs/Gateway master Sonar/workspace/platform/sensinact-generic/target/felix/tmp
    [mkdir] Created dir: /home/hudson/genie.sensinact/.jenkins/jobs/Gateway master Sonar/workspace/platform/sensinact-generic/target/felix/tmp1
    [mkdir] Created dir: /home/hudson/genie.sensinact/.jenkins/jobs/Gateway master Sonar/workspace/platform/sensinact-generic/target/felix/tmp2
    [mkdir] Created dir: /home/hudson/genie.sensinact/.jenkins/jobs/Gateway master Sonar/workspace/platform/sensinact-generic/target/extra-test-classes
    [mkdir] Created dir: /home/hudson/genie.sensinact/.jenkins/jobs/Gateway master Sonar/workspace/platform/sensinact-generic/target/extra-test-classes2
    [mkdir] Created dir: /home/hudson/genie.sensinact/.jenkins/jobs/Gateway master Sonar/workspace/platform/sensinact-generic/target/extra-test-classes3
    [mkdir] Created dir: /home/hudson/genie.sensinact/.jenkins/jobs/Gateway master Sonar/workspace/platform/sensinact-generic/target/extra-test-classes4
    [mkdir] Created dir: /home/hudson/genie.sensinact/.jenkins/jobs/Gateway master Sonar/workspace/platform/sensinact-generic/target/extra-test-classes5
    [mkdir] Created dir: /home/hudson/genie.sensinact/.jenkins/jobs/Gateway master Sonar/workspace/platform/sensinact-generic/target/extra-test-classes6
    [javac] /home/hudson/genie.sensinact/.jenkins/jobs/Gateway master Sonar/workspace/platform/sensinact-generic/target/antrun/build-main.xml:13: warning: 'includeantruntime' was not set, defaulting to build.sysclasspath=last; set to false for repeatable builds
    [javac] Compiling 12 source files to /home/hudson/genie.sensinact/.jenkins/jobs/Gateway master Sonar/workspace/platform/sensinact-generic/target/extra-test-classes
    [javac] Picked up JAVA_TOOL_OPTIONS: -Xmx2G -Djava.io.tmpdir=/tmp/genie.sensinact
    [javac] Note: Some input files use unchecked or unsafe operations.
    [javac] Note: Recompile with -Xlint:unchecked for details.
    [javac] /home/hudson/genie.sensinact/.jenkins/jobs/Gateway master Sonar/workspace/platform/sensinact-generic/target/antrun/build-main.xml:16: warning: 'includeantruntime' was not set, defaulting to build.sysclasspath=last; set to false for repeatable builds
    [javac] Compiling 8 source files to /home/hudson/genie.sensinact/.jenkins/jobs/Gateway master Sonar/workspace/platform/sensinact-generic/target/extra-test-classes2
    [javac] Picked up JAVA_TOOL_OPTIONS: -Xmx2G -Djava.io.tmpdir=/tmp/genie.sensinact
    [javac] /home/hudson/genie.sensinact/.jenkins/jobs/Gateway master Sonar/workspace/platform/sensinact-generic/target/antrun/build-main.xml:19: warning: 'includeantruntime' was not set, defaulting to build.sysclasspath=last; set to false for repeatable builds
    [javac] Compiling 10 source files to /home/hudson/genie.sensinact/.jenkins/jobs/Gateway master Sonar/workspace/platform/sensinact-generic/target/extra-test-classes3
    [javac] Picked up JAVA_TOOL_OPTIONS: -Xmx2G -Djava.io.tmpdir=/tmp/genie.sensinact
    [javac] Note: /home/hudson/genie.sensinact/.jenkins/jobs/Gateway master Sonar/workspace/platform/sensinact-generic/extra-src3/test/java/org/eclipse/sensinact/gateway/generic/test/moke3/Activator.java uses unchecked or unsafe operations.
    [javac] Note: Recompile with -Xlint:unchecked for details.
    [javac] /home/hudson/genie.sensinact/.jenkins/jobs/Gateway master Sonar/workspace/platform/sensinact-generic/target/antrun/build-main.xml:22: warning: 'includeantruntime' was not set, defaulting to build.sysclasspath=last; set to false for repeatable builds
    [javac] Compiling 9 source files to /home/hudson/genie.sensinact/.jenkins/jobs/Gateway master Sonar/workspace/platform/sensinact-generic/target/extra-test-classes4
    [javac] Picked up JAVA_TOOL_OPTIONS: -Xmx2G -Djava.io.tmpdir=/tmp/genie.sensinact
    [javac] Note: /home/hudson/genie.sensinact/.jenkins/jobs/Gateway master Sonar/workspace/platform/sensinact-generic/extra-src4/test/java/org/eclipse/sensinact/gateway/generic/test/moke4/Activator.java uses unchecked or unsafe operations.
    [javac] Note: Recompile with -Xlint:unchecked for details.
[INFO] Executed tasks
[INFO] 
[INFO] --- maven-surefire-plugin:2.18.1:test (default-test) @ sensinact-generic ---
[INFO] Surefire report directory: /home/hudson/genie.sensinact/.jenkins/jobs/Gateway master Sonar/workspace/platform/sensinact-generic/target/surefire-reports

-------------------------------------------------------
 T E S T S
-------------------------------------------------------
Picked up JAVA_TOOL_OPTIONS: -Xmx2G -Djava.io.tmpdir=/tmp/genie.sensinact
Running org.eclipse.sensinact.gateway.generic.test.TestGenericImplementation
DEBUG: WIRE: [1.0] osgi.wiring.package; (osgi.wiring.package=javax.naming) -> [0]
DEBUG: WIRE: [1.0] osgi.wiring.package; (osgi.wiring.package=javax.naming.directory) -> [0]
DEBUG: WIRE: [1.0] osgi.wiring.package; (osgi.wiring.package=javax.sql) -> [0]
DEBUG: WIRE: [1.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers) -> [0]
DEBUG: WIRE: [1.0] osgi.wiring.package; (osgi.wiring.package=org.osgi.framework) -> [0]
DEBUG: WIRE: [1.0] osgi.wiring.package; (osgi.wiring.package=org.osgi.resource) -> [0]
DEBUG: WIRE: [2.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.4.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [2.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.cm)(version>=1.5.0)(!(version>=1.6.0))) -> [1.0]
DEBUG: WIRE: [2.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.log)(version>=1.3.0)) -> [1.0]
DEBUG: WIRE: [4.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [4.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.condpermadmin)(version>=1.1.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [4.0] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.xml)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)(!(version>=20080702.0.0))) -> [8.0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework.wiring)(version>=1.1.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.cm)(version>=1.5.0)(!(version>=2.0.0))) -> [1.0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.log)(version>=1.3.0)(!(version>=2.0.0))) -> [1.0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.util.tracker)(version>=1.5.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (osgi.wiring.package=org.xml.sax) -> [0]
DEBUG: WIRE: [9.0] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [0]
DEBUG: WIRE: [8.0] osgi.wiring.package; (osgi.wiring.package=javax.imageio) -> [0]
DEBUG: WIRE: [8.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers) -> [0]
DEBUG: WIRE: [8.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [8.0] osgi.wiring.package; (osgi.wiring.package=org.xml.sax) -> [0]
DEBUG: WIRE: [8.0] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.activation) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.crypto) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.crypto.interfaces) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.crypto.spec) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.mail) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.mail.internet) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.naming) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.naming.directory) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.security.auth.x500) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.crypto)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [5.0] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [0]
DEBUG: Bundle sensinact-signature-validator [5] sensiNact-conf.xml not found by sensinact-signature-validator [5]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.constraint)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.execution)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.primitive)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.props)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.datastore.api)(version>=2.0.0)(!(version>=3.0.0))) -> [10.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.security.signature.api)(version>=2.0.0)(!(version>=3.0.0))) -> [5.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.crypto)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.stack)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.tree)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)(!(version>=20080702.0.0))) -> [8.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.condpermadmin)(version>=1.1.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [12.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [12.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.tree)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [12.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [6.0] org.eclipse.sensinact.signature.validator; (*) -> [5.0]
DEBUG: WIRE: [6.0] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [0]
DEBUG: WIRE: [12.0] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [0]
DEBUG: WIRE: [10.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [10.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.execution)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [10.0] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)(!(version>=20080702.0.0))) -> [8.0]
DEBUG: WIRE: [10.0] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [0]
DEBUG: FRAGMENT WIRE: [12.0] osgi.wiring.host; (&(osgi.wiring.host=sensinact-core)(bundle-version>=0.0.0)) -> [6.0]
DEBUG: Bundle sensinact-core [6] sensiNact-conf.xml not found by sensinact-core [6]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.packet)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.packet.annotation)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.stream)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.uri)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.parser)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.annotation)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.local)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.constraint)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.execution)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.primitive)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method.builder)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method.trigger)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.security)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.xml)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers) -> [0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)) -> [8.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (osgi.wiring.package=org.xml.sax) -> [0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (osgi.wiring.package=org.eclipse.sensinact.gateway.test) -> [0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers) -> [0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.constraint)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.execution)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.primitive)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method.builder)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method.trigger)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.security)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.xml)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)(!(version>=20080702.0.0))) -> [8.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (osgi.wiring.package=org.xml.sax) -> [0]
DEBUG: Bundle sensinact-generic-test-moke [13] sensiNact-conf.xml not found by sensinact-generic-test-moke [13]
Felix stopped [14]
DEBUG: WIRE: [1.0] osgi.wiring.package; (osgi.wiring.package=javax.naming) -> [0]
DEBUG: WIRE: [1.0] osgi.wiring.package; (osgi.wiring.package=javax.naming.directory) -> [0]
DEBUG: WIRE: [1.0] osgi.wiring.package; (osgi.wiring.package=javax.sql) -> [0]
DEBUG: WIRE: [1.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers) -> [0]
DEBUG: WIRE: [1.0] osgi.wiring.package; (osgi.wiring.package=org.osgi.framework) -> [0]
DEBUG: WIRE: [1.0] osgi.wiring.package; (osgi.wiring.package=org.osgi.resource) -> [0]
DEBUG: WIRE: [2.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.4.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [2.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.cm)(version>=1.5.0)(!(version>=1.6.0))) -> [1.0]
DEBUG: WIRE: [2.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.log)(version>=1.3.0)) -> [1.0]
DEBUG: WIRE: [4.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [4.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.condpermadmin)(version>=1.1.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [4.0] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.activation) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.crypto) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.crypto.interfaces) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.crypto.spec) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.mail) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.mail.internet) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.naming) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.naming.directory) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.security.auth.x500) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.crypto)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [5.0] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.xml)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)(!(version>=20080702.0.0))) -> [8.0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework.wiring)(version>=1.1.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.cm)(version>=1.5.0)(!(version>=2.0.0))) -> [1.0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.log)(version>=1.3.0)(!(version>=2.0.0))) -> [1.0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.util.tracker)(version>=1.5.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (osgi.wiring.package=org.xml.sax) -> [0]
DEBUG: WIRE: [9.0] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [0]
DEBUG: WIRE: [8.0] osgi.wiring.package; (osgi.wiring.package=javax.imageio) -> [0]
DEBUG: WIRE: [8.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers) -> [0]
DEBUG: WIRE: [8.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [8.0] osgi.wiring.package; (osgi.wiring.package=org.xml.sax) -> [0]
DEBUG: WIRE: [8.0] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [0]
DEBUG: Bundle sensinact-signature-validator [5] sensiNact-conf.xml not found by sensinact-signature-validator [5]
DEBUG: FRAGMENT WIRE: [12.0] osgi.wiring.host; (&(osgi.wiring.host=sensinact-core)(bundle-version>=0.0.0)) -> [6.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.constraint)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.execution)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.primitive)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.props)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.datastore.api)(version>=2.0.0)(!(version>=3.0.0))) -> [10.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.security.signature.api)(version>=2.0.0)(!(version>=3.0.0))) -> [5.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.crypto)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.stack)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.tree)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)(!(version>=20080702.0.0))) -> [8.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.condpermadmin)(version>=1.1.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [12.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [12.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.tree)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [12.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [6.0] org.eclipse.sensinact.signature.validator; (*) -> [5.0]
DEBUG: WIRE: [6.0] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [0]
DEBUG: WIRE: [12.0] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [0]
DEBUG: WIRE: [10.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [10.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.execution)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [10.0] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)(!(version>=20080702.0.0))) -> [8.0]
DEBUG: WIRE: [10.0] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [0]
DEBUG: Bundle sensinact-core [6] sensiNact-conf.xml not found by sensinact-core [6]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.packet)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.packet.annotation)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.stream)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.uri)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.parser)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.annotation)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.local)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.constraint)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.execution)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.primitive)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method.builder)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method.trigger)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.security)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.xml)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers) -> [0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)) -> [8.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (osgi.wiring.package=org.xml.sax) -> [0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (osgi.wiring.package=org.eclipse.sensinact.gateway.test) -> [0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers) -> [0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.constraint)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.execution)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.primitive)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method.builder)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method.trigger)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.security)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.xml)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)(!(version>=20080702.0.0))) -> [8.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (osgi.wiring.package=org.xml.sax) -> [0]
DEBUG: Bundle sensinact-generic-test-moke [13] sensiNact-conf.xml not found by sensinact-generic-test-moke [13]
Felix stopped [17]
DEBUG: WIRE: [1.0] osgi.wiring.package; (osgi.wiring.package=javax.naming) -> [0]
DEBUG: WIRE: [1.0] osgi.wiring.package; (osgi.wiring.package=javax.naming.directory) -> [0]
DEBUG: WIRE: [1.0] osgi.wiring.package; (osgi.wiring.package=javax.sql) -> [0]
DEBUG: WIRE: [1.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers) -> [0]
DEBUG: WIRE: [1.0] osgi.wiring.package; (osgi.wiring.package=org.osgi.framework) -> [0]
DEBUG: WIRE: [1.0] osgi.wiring.package; (osgi.wiring.package=org.osgi.resource) -> [0]
DEBUG: WIRE: [2.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.4.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [2.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.cm)(version>=1.5.0)(!(version>=1.6.0))) -> [1.0]
DEBUG: WIRE: [2.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.log)(version>=1.3.0)) -> [1.0]
DEBUG: WIRE: [4.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [4.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.condpermadmin)(version>=1.1.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [4.0] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.xml)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)(!(version>=20080702.0.0))) -> [8.0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework.wiring)(version>=1.1.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.cm)(version>=1.5.0)(!(version>=2.0.0))) -> [1.0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.log)(version>=1.3.0)(!(version>=2.0.0))) -> [1.0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.util.tracker)(version>=1.5.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (osgi.wiring.package=org.xml.sax) -> [0]
DEBUG: WIRE: [9.0] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.activation) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.crypto) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.crypto.interfaces) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.crypto.spec) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.mail) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.mail.internet) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.naming) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.naming.directory) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.security.auth.x500) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.crypto)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [5.0] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [0]
DEBUG: WIRE: [8.0] osgi.wiring.package; (osgi.wiring.package=javax.imageio) -> [0]
DEBUG: WIRE: [8.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers) -> [0]
DEBUG: WIRE: [8.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [8.0] osgi.wiring.package; (osgi.wiring.package=org.xml.sax) -> [0]
DEBUG: WIRE: [8.0] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [0]
DEBUG: Bundle sensinact-signature-validator [5] sensiNact-conf.xml not found by sensinact-signature-validator [5]
DEBUG: FRAGMENT WIRE: [12.0] osgi.wiring.host; (&(osgi.wiring.host=sensinact-core)(bundle-version>=0.0.0)) -> [6.0]
DEBUG: WIRE: [10.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [10.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.execution)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [10.0] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)(!(version>=20080702.0.0))) -> [8.0]
DEBUG: WIRE: [10.0] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.constraint)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.execution)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.primitive)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.props)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.datastore.api)(version>=2.0.0)(!(version>=3.0.0))) -> [10.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.security.signature.api)(version>=2.0.0)(!(version>=3.0.0))) -> [5.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.crypto)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.stack)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.tree)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)(!(version>=20080702.0.0))) -> [8.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.condpermadmin)(version>=1.1.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [12.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [12.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.tree)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [12.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [6.0] org.eclipse.sensinact.signature.validator; (*) -> [5.0]
DEBUG: WIRE: [6.0] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [0]
DEBUG: WIRE: [12.0] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [0]
DEBUG: Bundle sensinact-core [6] sensiNact-conf.xml not found by sensinact-core [6]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.packet)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.packet.annotation)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.stream)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.uri)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.parser)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.annotation)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.local)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.constraint)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.execution)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.primitive)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method.builder)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method.trigger)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.security)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.xml)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers) -> [0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)) -> [8.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (osgi.wiring.package=org.xml.sax) -> [0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (osgi.wiring.package=org.eclipse.sensinact.gateway.test) -> [0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers) -> [0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.constraint)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.execution)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.primitive)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method.builder)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method.trigger)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.security)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.xml)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)(!(version>=20080702.0.0))) -> [8.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (osgi.wiring.package=org.xml.sax) -> [0]
DEBUG: Bundle sensinact-generic-test-moke [13] sensiNact-conf.xml not found by sensinact-generic-test-moke [13]
Felix stopped [12]
DEBUG: WIRE: [1.0] osgi.wiring.package; (osgi.wiring.package=javax.naming) -> [0]
DEBUG: WIRE: [1.0] osgi.wiring.package; (osgi.wiring.package=javax.naming.directory) -> [0]
DEBUG: WIRE: [1.0] osgi.wiring.package; (osgi.wiring.package=javax.sql) -> [0]
DEBUG: WIRE: [1.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers) -> [0]
DEBUG: WIRE: [1.0] osgi.wiring.package; (osgi.wiring.package=org.osgi.framework) -> [0]
DEBUG: WIRE: [1.0] osgi.wiring.package; (osgi.wiring.package=org.osgi.resource) -> [0]
DEBUG: WIRE: [2.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.4.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [2.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.cm)(version>=1.5.0)(!(version>=1.6.0))) -> [1.0]
DEBUG: WIRE: [2.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.log)(version>=1.3.0)) -> [1.0]
DEBUG: WIRE: [4.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [4.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.condpermadmin)(version>=1.1.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [4.0] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.activation) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.crypto) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.crypto.interfaces) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.crypto.spec) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.mail) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.mail.internet) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.naming) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.naming.directory) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.security.auth.x500) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.crypto)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [5.0] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.xml)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)(!(version>=20080702.0.0))) -> [8.0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework.wiring)(version>=1.1.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.cm)(version>=1.5.0)(!(version>=2.0.0))) -> [1.0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.log)(version>=1.3.0)(!(version>=2.0.0))) -> [1.0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.util.tracker)(version>=1.5.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (osgi.wiring.package=org.xml.sax) -> [0]
DEBUG: WIRE: [9.0] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [0]
DEBUG: WIRE: [8.0] osgi.wiring.package; (osgi.wiring.package=javax.imageio) -> [0]
DEBUG: WIRE: [8.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers) -> [0]
DEBUG: WIRE: [8.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [8.0] osgi.wiring.package; (osgi.wiring.package=org.xml.sax) -> [0]
DEBUG: WIRE: [8.0] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [0]
DEBUG: Bundle sensinact-signature-validator [5] sensiNact-conf.xml not found by sensinact-signature-validator [5]
DEBUG: WIRE: [10.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [10.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.execution)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [10.0] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)(!(version>=20080702.0.0))) -> [8.0]
DEBUG: WIRE: [10.0] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.constraint)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.execution)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.primitive)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.props)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.datastore.api)(version>=2.0.0)(!(version>=3.0.0))) -> [10.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.security.signature.api)(version>=2.0.0)(!(version>=3.0.0))) -> [5.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.crypto)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.stack)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.tree)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)(!(version>=20080702.0.0))) -> [8.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.condpermadmin)(version>=1.1.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [12.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [12.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.tree)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [12.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [6.0] org.eclipse.sensinact.signature.validator; (*) -> [5.0]
DEBUG: WIRE: [6.0] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [0]
DEBUG: WIRE: [12.0] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [0]
DEBUG: FRAGMENT WIRE: [12.0] osgi.wiring.host; (&(osgi.wiring.host=sensinact-core)(bundle-version>=0.0.0)) -> [6.0]
DEBUG: Bundle sensinact-core [6] sensiNact-conf.xml not found by sensinact-core [6]
DEBUG: WIRE: [7.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers) -> [0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.constraint)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.execution)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.primitive)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method.builder)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method.trigger)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.security)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.xml)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)(!(version>=20080702.0.0))) -> [8.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (osgi.wiring.package=org.xml.sax) -> [0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.packet)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.packet.annotation)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.stream)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.uri)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.parser)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.annotation)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.local)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.constraint)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.execution)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.primitive)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method.builder)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method.trigger)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.security)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.xml)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers) -> [0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)) -> [8.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (osgi.wiring.package=org.xml.sax) -> [0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (osgi.wiring.package=org.eclipse.sensinact.gateway.test) -> [0]
DEBUG: Bundle sensinact-generic-test [13] sensiNact-conf.xml not found by sensinact-generic-test [13]
Felix stopped [93]
DEBUG: WIRE: [1.0] osgi.wiring.package; (osgi.wiring.package=javax.naming) -> [0]
DEBUG: WIRE: [1.0] osgi.wiring.package; (osgi.wiring.package=javax.naming.directory) -> [0]
DEBUG: WIRE: [1.0] osgi.wiring.package; (osgi.wiring.package=javax.sql) -> [0]
DEBUG: WIRE: [1.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers) -> [0]
DEBUG: WIRE: [1.0] osgi.wiring.package; (osgi.wiring.package=org.osgi.framework) -> [0]
DEBUG: WIRE: [1.0] osgi.wiring.package; (osgi.wiring.package=org.osgi.resource) -> [0]
DEBUG: WIRE: [2.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.4.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [2.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.cm)(version>=1.5.0)(!(version>=1.6.0))) -> [1.0]
DEBUG: WIRE: [2.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.log)(version>=1.3.0)) -> [1.0]
DEBUG: WIRE: [4.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [4.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.condpermadmin)(version>=1.1.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [4.0] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.xml)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)(!(version>=20080702.0.0))) -> [8.0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework.wiring)(version>=1.1.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.cm)(version>=1.5.0)(!(version>=2.0.0))) -> [1.0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.log)(version>=1.3.0)(!(version>=2.0.0))) -> [1.0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.util.tracker)(version>=1.5.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (osgi.wiring.package=org.xml.sax) -> [0]
DEBUG: WIRE: [9.0] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.activation) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.crypto) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.crypto.interfaces) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.crypto.spec) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.mail) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.mail.internet) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.naming) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.naming.directory) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.security.auth.x500) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.crypto)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [5.0] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [0]
DEBUG: WIRE: [8.0] osgi.wiring.package; (osgi.wiring.package=javax.imageio) -> [0]
DEBUG: WIRE: [8.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers) -> [0]
DEBUG: WIRE: [8.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [8.0] osgi.wiring.package; (osgi.wiring.package=org.xml.sax) -> [0]
DEBUG: WIRE: [8.0] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [0]
DEBUG: Bundle sensinact-signature-validator [5] sensiNact-conf.xml not found by sensinact-signature-validator [5]
DEBUG: FRAGMENT WIRE: [12.0] osgi.wiring.host; (&(osgi.wiring.host=sensinact-core)(bundle-version>=0.0.0)) -> [6.0]
DEBUG: WIRE: [10.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [10.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.execution)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [10.0] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)(!(version>=20080702.0.0))) -> [8.0]
DEBUG: WIRE: [10.0] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.constraint)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.execution)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.primitive)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.props)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.datastore.api)(version>=2.0.0)(!(version>=3.0.0))) -> [10.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.security.signature.api)(version>=2.0.0)(!(version>=3.0.0))) -> [5.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.crypto)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.stack)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.tree)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)(!(version>=20080702.0.0))) -> [8.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.condpermadmin)(version>=1.1.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [12.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [12.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.tree)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [12.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [6.0] org.eclipse.sensinact.signature.validator; (*) -> [5.0]
DEBUG: WIRE: [6.0] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [0]
DEBUG: WIRE: [12.0] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [0]
DEBUG: Bundle sensinact-core [6] sensiNact-conf.xml not found by sensinact-core [6]
DEBUG: WIRE: [7.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers) -> [0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.constraint)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.execution)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.primitive)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method.builder)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method.trigger)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.security)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.xml)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)(!(version>=20080702.0.0))) -> [8.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (osgi.wiring.package=org.xml.sax) -> [0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.packet)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.packet.annotation)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.stream)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.uri)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.parser)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.annotation)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.local)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.constraint)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.execution)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.primitive)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method.builder)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method.trigger)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.security)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.xml)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers) -> [0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)) -> [8.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (osgi.wiring.package=org.xml.sax) -> [0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (osgi.wiring.package=org.eclipse.sensinact.gateway.test) -> [0]
DEBUG: Bundle sensinact-generic-test-moke [13] sensiNact-conf.xml not found by sensinact-generic-test-moke [13]
Felix stopped [14]
DEBUG: WIRE: [1.0] osgi.wiring.package; (osgi.wiring.package=javax.naming) -> [0]
DEBUG: WIRE: [1.0] osgi.wiring.package; (osgi.wiring.package=javax.naming.directory) -> [0]
DEBUG: WIRE: [1.0] osgi.wiring.package; (osgi.wiring.package=javax.sql) -> [0]
DEBUG: WIRE: [1.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers) -> [0]
DEBUG: WIRE: [1.0] osgi.wiring.package; (osgi.wiring.package=org.osgi.framework) -> [0]
DEBUG: WIRE: [1.0] osgi.wiring.package; (osgi.wiring.package=org.osgi.resource) -> [0]
DEBUG: WIRE: [2.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.4.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [2.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.cm)(version>=1.5.0)(!(version>=1.6.0))) -> [1.0]
DEBUG: WIRE: [2.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.log)(version>=1.3.0)) -> [1.0]
DEBUG: WIRE: [4.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [4.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.condpermadmin)(version>=1.1.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [4.0] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.activation) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.crypto) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.crypto.interfaces) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.crypto.spec) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.mail) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.mail.internet) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.naming) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.naming.directory) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.security.auth.x500) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.crypto)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [5.0] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [0]
DEBUG: WIRE: [8.0] osgi.wiring.package; (osgi.wiring.package=javax.imageio) -> [0]
DEBUG: WIRE: [8.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers) -> [0]
DEBUG: WIRE: [8.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [8.0] osgi.wiring.package; (osgi.wiring.package=org.xml.sax) -> [0]
DEBUG: WIRE: [8.0] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.xml)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)(!(version>=20080702.0.0))) -> [8.0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework.wiring)(version>=1.1.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.cm)(version>=1.5.0)(!(version>=2.0.0))) -> [1.0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.log)(version>=1.3.0)(!(version>=2.0.0))) -> [1.0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.util.tracker)(version>=1.5.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (osgi.wiring.package=org.xml.sax) -> [0]
DEBUG: WIRE: [9.0] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [0]
DEBUG: Bundle sensinact-signature-validator [5] sensiNact-conf.xml not found by sensinact-signature-validator [5]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.constraint)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.execution)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.primitive)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.props)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.datastore.api)(version>=2.0.0)(!(version>=3.0.0))) -> [10.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.security.signature.api)(version>=2.0.0)(!(version>=3.0.0))) -> [5.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.crypto)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.stack)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.tree)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)(!(version>=20080702.0.0))) -> [8.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.condpermadmin)(version>=1.1.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [12.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [12.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.tree)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [12.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [6.0] org.eclipse.sensinact.signature.validator; (*) -> [5.0]
DEBUG: WIRE: [6.0] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [0]
DEBUG: WIRE: [12.0] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [0]
DEBUG: FRAGMENT WIRE: [12.0] osgi.wiring.host; (&(osgi.wiring.host=sensinact-core)(bundle-version>=0.0.0)) -> [6.0]
DEBUG: WIRE: [10.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [10.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.execution)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [10.0] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)(!(version>=20080702.0.0))) -> [8.0]
DEBUG: WIRE: [10.0] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [0]
DEBUG: Bundle sensinact-core [6] sensiNact-conf.xml not found by sensinact-core [6]
DEBUG: FRAGMENT WIRE: [13.0] osgi.wiring.host; (&(osgi.wiring.host=sensinact-generic-test-moke-4)(bundle-version>=0.0.0)) -> [15.0]
DEBUG: WIRE: [15.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [15.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.packet)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [15.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.packet.annotation)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [15.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.stream)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [15.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.uri)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [15.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.parser)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [15.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.annotation)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [15.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.local)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [15.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [15.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.constraint)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [15.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.execution)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [15.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.primitive)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [15.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [15.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [15.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method.builder)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [15.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method.trigger)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [15.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.security)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [15.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [15.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.xml)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [15.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers) -> [0]
DEBUG: WIRE: [15.0] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)) -> [8.0]
DEBUG: WIRE: [15.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [15.0] osgi.wiring.package; (osgi.wiring.package=org.xml.sax) -> [0]
DEBUG: WIRE: [15.0] osgi.wiring.package; (osgi.wiring.package=org.eclipse.sensinact.gateway.test) -> [0]
DEBUG: WIRE: [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.packet)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.packet.annotation)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.stream)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.uri)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.parser)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.annotation)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.local)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.constraint)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.execution)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.primitive)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method.builder)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method.trigger)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.security)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.xml)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [14.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers) -> [0]
DEBUG: WIRE: [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)) -> [8.0]
DEBUG: WIRE: [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [14.0] osgi.wiring.package; (osgi.wiring.package=org.xml.sax) -> [0]
DEBUG: WIRE: [14.0] osgi.wiring.package; (osgi.wiring.package=org.eclipse.sensinact.gateway.test) -> [0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.packet)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.packet.annotation)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.stream)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.uri)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.parser)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.annotation)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.local)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.constraint)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.execution)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.primitive)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method.builder)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method.trigger)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.security)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.xml)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers) -> [0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)) -> [8.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (osgi.wiring.package=org.xml.sax) -> [0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (osgi.wiring.package=org.eclipse.sensinact.gateway.test) -> [0]
DEBUG: FRAGMENT WIRE: [14.0] osgi.wiring.host; (&(osgi.wiring.host=sensinact-generic-test-moke-4)(bundle-version>=0.0.0)) -> [15.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers) -> [0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.constraint)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.execution)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.primitive)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method.builder)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method.trigger)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.security)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.xml)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)(!(version>=20080702.0.0))) -> [8.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (osgi.wiring.package=org.xml.sax) -> [0]
DEBUG: Bundle sensinact-generic-test-moke-4 [15] sensiNact-conf.xml not found by sensinact-generic-test-moke-4 [15]
Felix stopped [12]
DEBUG: WIRE: [1.0] osgi.wiring.package; (osgi.wiring.package=javax.naming) -> [0]
DEBUG: WIRE: [1.0] osgi.wiring.package; (osgi.wiring.package=javax.naming.directory) -> [0]
DEBUG: WIRE: [1.0] osgi.wiring.package; (osgi.wiring.package=javax.sql) -> [0]
DEBUG: WIRE: [1.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers) -> [0]
DEBUG: WIRE: [1.0] osgi.wiring.package; (osgi.wiring.package=org.osgi.framework) -> [0]
DEBUG: WIRE: [1.0] osgi.wiring.package; (osgi.wiring.package=org.osgi.resource) -> [0]
DEBUG: WIRE: [2.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.4.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [2.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.cm)(version>=1.5.0)(!(version>=1.6.0))) -> [1.0]
DEBUG: WIRE: [2.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.log)(version>=1.3.0)) -> [1.0]
DEBUG: WIRE: [4.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [4.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.condpermadmin)(version>=1.1.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [4.0] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [0]
DEBUG: WIRE: [8.0] osgi.wiring.package; (osgi.wiring.package=javax.imageio) -> [0]
DEBUG: WIRE: [8.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers) -> [0]
DEBUG: WIRE: [8.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [8.0] osgi.wiring.package; (osgi.wiring.package=org.xml.sax) -> [0]
DEBUG: WIRE: [8.0] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.xml)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)(!(version>=20080702.0.0))) -> [8.0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework.wiring)(version>=1.1.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.cm)(version>=1.5.0)(!(version>=2.0.0))) -> [1.0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.log)(version>=1.3.0)(!(version>=2.0.0))) -> [1.0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.util.tracker)(version>=1.5.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [9.0] osgi.wiring.package; (osgi.wiring.package=org.xml.sax) -> [0]
DEBUG: WIRE: [9.0] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.activation) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.crypto) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.crypto.interfaces) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.crypto.spec) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.mail) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.mail.internet) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.naming) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.naming.directory) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (osgi.wiring.package=javax.security.auth.x500) -> [0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.crypto)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [5.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [5.0] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [0]
DEBUG: Bundle sensinact-signature-validator [5] sensiNact-conf.xml not found by sensinact-signature-validator [5]
DEBUG: FRAGMENT WIRE: [12.0] osgi.wiring.host; (&(osgi.wiring.host=sensinact-core)(bundle-version>=0.0.0)) -> [6.0]
DEBUG: WIRE: [10.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [10.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.execution)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [10.0] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)(!(version>=20080702.0.0))) -> [8.0]
DEBUG: WIRE: [10.0] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.constraint)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.execution)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.primitive)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.props)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.datastore.api)(version>=2.0.0)(!(version>=3.0.0))) -> [10.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.security.signature.api)(version>=2.0.0)(!(version>=3.0.0))) -> [5.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.crypto)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.stack)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.tree)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)(!(version>=20080702.0.0))) -> [8.0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [6.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.condpermadmin)(version>=1.1.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [12.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [12.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.tree)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [12.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [6.0] org.eclipse.sensinact.signature.validator; (*) -> [5.0]
DEBUG: WIRE: [6.0] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [0]
DEBUG: WIRE: [12.0] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [0]
DEBUG: Bundle sensinact-core [6] sensiNact-conf.xml not found by sensinact-core [6]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.packet)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.packet.annotation)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.stream)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.uri)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.parser)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.annotation)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.local)(version>=2.0.0)(!(version>=3.0.0))) -> [7.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.constraint)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.execution)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.primitive)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method.builder)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method.trigger)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.security)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.xml)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers) -> [0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)) -> [8.0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (osgi.wiring.package=org.xml.sax) -> [0]
DEBUG: WIRE: [13.0] osgi.wiring.package; (osgi.wiring.package=org.eclipse.sensinact.gateway.test) -> [0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers) -> [0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.constraint)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.execution)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.primitive)(version>=2.0.0)(!(version>=3.0.0))) -> [9.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method.builder)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method.trigger)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.security)(version>=2.0.0)(!(version>=3.0.0))) -> [6.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.xml)(version>=2.0.0)(!(version>=3.0.0))) -> [8.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)(!(version>=20080702.0.0))) -> [8.0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [0]
DEBUG: WIRE: [7.0] osgi.wiring.package; (osgi.wiring.package=org.xml.sax) -> [0]
DEBUG: Bundle sensinact-generic-test-moke [13] sensiNact-conf.xml not found by sensinact-generic-test-moke [13]
Felix stopped [9]
Tests run: 7, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 68.365 sec - in org.eclipse.sensinact.gateway.generic.test.TestGenericImplementation

Results :

Tests run: 7, Failures: 0, Errors: 0, Skipped: 0

[JENKINS] Recording test results
[INFO] 
[INFO] --- maven-bundle-plugin:2.5.3:bundle (default-bundle) @ sensinact-generic ---
[WARNING] Include-Resource: overriding sensinact-resource.xsd=src/main/resources/sensinact-resource.xsd with about.html,src/main/resources/ (add {maven-resources} if you want to include the maven resources)
[WARNING] Bundle org.eclipse.sensinact.gateway:sensinact-generic:bundle:2.0-SNAPSHOT : Invalid package name: 'sensinact-resource.xsd'
[INFO] 
[INFO] --- maven-install-plugin:3.0.0-M1:install (default-install) @ sensinact-generic ---
[INFO] Installing /home/hudson/genie.sensinact/.jenkins/jobs/Gateway master Sonar/workspace/platform/sensinact-generic/target/sensinact-generic-2.0-SNAPSHOT.jar to /opt/public/hipp/homes/genie.sensinact/.m2/repository/org/eclipse/sensinact/gateway/sensinact-generic/2.0-SNAPSHOT/sensinact-generic-2.0-SNAPSHOT.jar
[INFO] Installing /home/hudson/genie.sensinact/.jenkins/jobs/Gateway master Sonar/workspace/platform/sensinact-generic/pom.xml to /opt/public/hipp/homes/genie.sensinact/.m2/repository/org/eclipse/sensinact/gateway/sensinact-generic/2.0-SNAPSHOT/sensinact-generic-2.0-SNAPSHOT.pom
[INFO] 
[INFO] --- maven-bundle-plugin:2.5.3:install (default-install) @ sensinact-generic ---
[INFO] Installing org/eclipse/sensinact/gateway/sensinact-generic/2.0-SNAPSHOT/sensinact-generic-2.0-SNAPSHOT.jar
[INFO] Writing OBR metadata
[INFO] 
[INFO] --- groovy-maven-plugin:2.0:execute (search-sha) @ sensinact-generic ---
[INFO] SHA: bOP76LOySseEIBRKwXIMcQoY86k901ERLSrEwOedQp0=