SuccessConsole Output

Skipping 126 KB.. Full Log
 [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.constraint)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.execution)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.primitive)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.props)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.datastore.api)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-datastore-api [21](R 21.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.security.signature.api)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-signature-validator [14](R 14.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.crypto)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.stack)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.tree)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)(!(version>=20080702.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.8.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.7.0)(!(version>=2.0.0))) -> [slf4j.api [23](R 23.0)]
DEBUG: WIRE: [sensinact-security-none [22](R 22.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-security-none [22](R 22.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.tree)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-security-none [22](R 22.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.8.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] org.eclipse.sensinact.security; (*) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] org.eclipse.sensinact.data.store; (*) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] org.eclipse.sensinact.signature.validator; (*) -> [sensinact-signature-validator [14](R 14.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.8)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-datastore-api [21](R 21.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-datastore-api [21](R 21.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.execution)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-datastore-api [21](R 21.0)] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)(!(version>=20080702.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-datastore-api [21](R 21.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.8)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: FRAGMENT WIRE: [sensinact-security-none [22](R 22.0)] osgi.wiring.host; (&(osgi.wiring.host=sensinact-core)(bundle-version>=0.0.0)) -> [sensinact-core [15](R 15.0)]
DEBUG: FRAGMENT WIRE: [sensinact-security-none [22](R 22.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.8)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: Bundle sensinact-core [15] sensiNact-conf.xml not found by sensinact-core [15]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.constraint)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.execution)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.primitive)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method.builder)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method.trigger)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.security)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.xml)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)(!(version>=20080702.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.8.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (osgi.wiring.package=org.xml.sax) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.packet)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.packet.annotation)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.stream)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.uri)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.parser)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.annotation)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.local)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.constraint)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.execution)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.primitive)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method.builder)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method.trigger)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.security)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.xml)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (osgi.wiring.package=org.xml.sax) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (osgi.wiring.package=org.eclipse.sensinact.gateway.test) -> [org.apache.felix.framework [0](R 0)]
DEBUG: Bundle sensinact-generic-test-moke-1 [25] sensiNact-conf.xml not found by sensinact-generic-test-moke-1 [25]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.packet)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.packet.annotation)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.stream)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.uri)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.parser)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.annotation)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.local)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.constraint)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.execution)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.primitive)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method.builder)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method.trigger)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.security)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.xml)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (osgi.wiring.package=org.xml.sax) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (osgi.wiring.package=org.eclipse.sensinact.gateway.test) -> [org.apache.felix.framework [0](R 0)]
DEBUG: Bundle sensinact-generic-test-moke-1 [25] sensiNact-conf.xml not found by sensinact-generic-test-moke-1 [25]
Felix stopped [74]
DEBUG: WIRE: [org.osgi.service.component [1](R 1.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.dto)(version>=1.1.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.osgi.service.component [1](R 1.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.9.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.osgi.service.component [1](R 1.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework.dto)(version>=1.8.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.osgi.service.component [1](R 1.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.util.promise)(version>=1.0.0)(!(version>=2.0.0))) -> [org.osgi.util.promise [5](R 5.0)]
DEBUG: WIRE: [org.osgi.service.component [1](R 1.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.osgi.util.promise [5](R 5.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.util.function)(version>=1.1.0)(!(version>=2.0.0))) -> [org.osgi.util.function [6](R 6.0)]
DEBUG: WIRE: [org.osgi.util.promise [5](R 5.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.osgi.util.function [6](R 6.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.osgi.service.cm [2](R 2.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.6.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.osgi.service.cm [2](R 2.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.osgi.service.metatype [3](R 3.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.osgi.service.metatype [3](R 3.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.osgi.namespace.extender [4](R 4.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.resource)(version>=1.0.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.osgi.namespace.extender [4](R 4.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.5)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.osgi.util.pushstream [7](R 7.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.util.function)(version>=1.1.0)(!(version>=2.0.0))) -> [org.osgi.util.function [6](R 6.0)]
DEBUG: WIRE: [org.osgi.util.pushstream [7](R 7.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.util.promise)(version>=1.1.0)(!(version>=2.0.0))) -> [org.osgi.util.promise [5](R 5.0)]
DEBUG: WIRE: [org.osgi.util.pushstream [7](R 7.0)] osgi.ee; (&(osgi.ee=JavaSE/compact1)(version=1.8)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.osgi.service.log [8](R 8.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.8.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.osgi.service.log [8](R 8.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.util.pushstream)(version>=1.0.0)(!(version>=2.0.0))) -> [org.osgi.util.pushstream [7](R 7.0)]
DEBUG: WIRE: [org.osgi.service.log [8](R 8.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.log [9](R 9.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.8.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.log [9](R 9.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework.wiring)(version>=1.2.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.log [9](R 9.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.log)(version>=1.4.0)(!(version>=1.5.0))) -> [org.osgi.service.log [8](R 8.0)]
DEBUG: WIRE: [org.apache.felix.log [9](R 9.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.log.admin)(version>=1.0.0)(!(version>=1.1.0))) -> [org.osgi.service.log [8](R 8.0)]
DEBUG: WIRE: [org.apache.felix.log [9](R 9.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.util.tracker)(version>=1.5.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.log [9](R 9.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.scr [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.cm)(version>=1.6.0)(!(version>=2.0.0))) -> [org.osgi.service.cm [2](R 2.0)]
DEBUG: WIRE: [org.apache.felix.scr [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.log)(version>=1.3.0)(!(version>=2.0.0))) -> [org.osgi.service.log [8](R 8.0)]
DEBUG: WIRE: [org.apache.felix.scr [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.metatype)(version>=1.2.0)(!(version>=2.0.0))) -> [org.osgi.service.metatype [3](R 3.0)]
DEBUG: WIRE: [org.apache.felix.scr [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.packageadmin)(version>=1.2.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.scr [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.dto)(version>=1.0.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.scr [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.8.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.scr [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework.dto)(version>=1.8.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.scr [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework.startlevel)(version>=1.0.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.scr [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework.wiring)(version>=1.2.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.scr [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.component)(version>=1.4.0)(!(version>=1.5.0))) -> [org.osgi.service.component [1](R 1.0)]
DEBUG: WIRE: [org.apache.felix.scr [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.component.runtime)(version>=1.4.0)(!(version>=1.5.0))) -> [org.osgi.service.component [1](R 1.0)]
DEBUG: WIRE: [org.apache.felix.scr [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.component.runtime.dto)(version>=1.4.0)(!(version>=1.5.0))) -> [org.osgi.service.component [1](R 1.0)]
DEBUG: WIRE: [org.apache.felix.scr [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.util.promise)(version>=1.0.0)(!(version>=2.0.0))) -> [org.osgi.util.promise [5](R 5.0)]
DEBUG: WIRE: [org.apache.felix.scr [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.util.tracker)(version>=1.5.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.scr [10](R 10.0)] osgi.ee; (|(&(osgi.ee=JavaSE)(version=1.7))(&(osgi.ee=JavaSE/compact1)(version=1.8))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.fileinstall [11](R 11.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.6.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.fileinstall [11](R 11.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework.startlevel)(version>=1.0.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.fileinstall [11](R 11.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework.wiring)(version>=1.0.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.fileinstall [11](R 11.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.cm)(version>=1.5.0)(!(version>=2.0.0))) -> [org.osgi.service.cm [2](R 2.0)]
DEBUG: WIRE: [org.apache.felix.fileinstall [11](R 11.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.log)(version>=1.3.0)(!(version>=2.0.0))) -> [org.osgi.service.log [8](R 8.0)]
DEBUG: WIRE: [org.apache.felix.fileinstall [11](R 11.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.url)(version>=1.0.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.fileinstall [11](R 11.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.util.tracker)(version>=1.5.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.configadmin [12](R 12.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.cm)(version>=1.6.0)(!(version>=1.7.0))) -> [org.osgi.service.cm [2](R 2.0)]
DEBUG: WIRE: [org.apache.felix.configadmin [12](R 12.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.log)(version>=1.3.0)(!(version>=2.0.0))) -> [org.osgi.service.log [8](R 8.0)]
DEBUG: WIRE: [org.apache.felix.configadmin [12](R 12.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.8.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.configadmin [12](R 12.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.util.tracker)(version>=1.5.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.configadmin [12](R 12.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-utils [19](R 19.0)] osgi.wiring.package; (osgi.wiring.package=javax.imageio) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-utils [19](R 19.0)] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-utils [19](R 19.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.8.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-utils [19](R 19.0)] osgi.wiring.package; (osgi.wiring.package=org.xml.sax) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-utils [19](R 19.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.8)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.wiring.package; (osgi.wiring.package=javax.activation) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.wiring.package; (osgi.wiring.package=javax.crypto) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.wiring.package; (osgi.wiring.package=javax.crypto.interfaces) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.wiring.package; (osgi.wiring.package=javax.crypto.spec) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.wiring.package; (osgi.wiring.package=javax.mail) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.wiring.package; (osgi.wiring.package=javax.mail.internet) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.wiring.package; (osgi.wiring.package=javax.naming) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.wiring.package; (osgi.wiring.package=javax.naming.directory) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.wiring.package; (osgi.wiring.package=javax.net.ssl) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.wiring.package; (osgi.wiring.package=javax.security.auth.callback) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.wiring.package; (osgi.wiring.package=javax.security.auth.x500) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.crypto)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.8.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.8)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-common [20](R 20.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.9.0)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-common [20](R 20.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-common [20](R 20.0)] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)(!(version>=20080702.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-common [20](R 20.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework.wiring)(version>=1.2.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-common [20](R 20.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.cm)(version>=1.6.0)(!(version>=2.0.0))) -> [org.osgi.service.cm [2](R 2.0)]
DEBUG: WIRE: [sensinact-common [20](R 20.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.log)(version>=1.4.0)(!(version>=2.0.0))) -> [org.osgi.service.log [8](R 8.0)]
DEBUG: WIRE: [sensinact-common [20](R 20.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.util.tracker)(version>=1.5.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-common [20](R 20.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.8)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: Bundle sensinact-signature-validator [14] sensiNact-conf.xml not found by sensinact-signature-validator [14]
DEBUG: WIRE: [sensinact-datastore-api [21](R 21.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-datastore-api [21](R 21.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.execution)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-datastore-api [21](R 21.0)] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)(!(version>=20080702.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-datastore-api [21](R 21.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.8)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: FRAGMENT WIRE: [slf4j.simple [24](R 24.0)] osgi.wiring.host; (&(osgi.wiring.host=slf4j.api)(bundle-version>=0.0.0)) -> [slf4j.api [23](R 23.0)]
DEBUG: FRAGMENT WIRE: [slf4j.simple [24](R 24.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.5.0)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: FRAGMENT WIRE: [sensinact-security-none [22](R 22.0)] osgi.wiring.host; (&(osgi.wiring.host=sensinact-core)(bundle-version>=0.0.0)) -> [sensinact-core [15](R 15.0)]
DEBUG: FRAGMENT WIRE: [sensinact-security-none [22](R 22.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.8)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.constraint)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.execution)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.primitive)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.props)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.datastore.api)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-datastore-api [21](R 21.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.security.signature.api)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-signature-validator [14](R 14.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.crypto)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.stack)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.tree)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)(!(version>=20080702.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.8.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.7.0)(!(version>=2.0.0))) -> [slf4j.api [23](R 23.0)]
DEBUG: WIRE: [sensinact-security-none [22](R 22.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-security-none [22](R 22.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.tree)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-security-none [22](R 22.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.8.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] org.eclipse.sensinact.security; (*) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] org.eclipse.sensinact.data.store; (*) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] org.eclipse.sensinact.signature.validator; (*) -> [sensinact-signature-validator [14](R 14.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.8)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [slf4j.api [23](R 23.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.5.0)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: Bundle sensinact-core [15] sensiNact-conf.xml not found by sensinact-core [15]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.constraint)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.execution)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.primitive)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method.builder)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method.trigger)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.security)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.xml)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)(!(version>=20080702.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.8.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (osgi.wiring.package=org.xml.sax) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.packet)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.packet.annotation)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.stream)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.uri)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.parser)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.annotation)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.local)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.constraint)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.execution)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.primitive)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method.builder)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method.trigger)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.security)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.xml)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (osgi.wiring.package=org.xml.sax) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (osgi.wiring.package=org.eclipse.sensinact.gateway.test) -> [org.apache.felix.framework [0](R 0)]
DEBUG: Bundle sensinact-generic-test-moke-1 [25] sensiNact-conf.xml not found by sensinact-generic-test-moke-1 [25]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.packet)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.packet.annotation)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.stream)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.uri)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.parser)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.annotation)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.local)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.constraint)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.execution)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.primitive)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method.builder)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method.trigger)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.security)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.xml)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (osgi.wiring.package=org.xml.sax) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (osgi.wiring.package=org.eclipse.sensinact.gateway.test) -> [org.apache.felix.framework [0](R 0)]
DEBUG: Bundle sensinact-generic-test-moke-1 [25] sensiNact-conf.xml not found by sensinact-generic-test-moke-1 [25]
Felix stopped [47]
DEBUG: WIRE: [org.osgi.util.promise [5](R 5.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.util.function)(version>=1.1.0)(!(version>=2.0.0))) -> [org.osgi.util.function [6](R 6.0)]
DEBUG: WIRE: [org.osgi.util.promise [5](R 5.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.osgi.util.function [6](R 6.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.osgi.service.component [1](R 1.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.dto)(version>=1.1.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.osgi.service.component [1](R 1.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.9.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.osgi.service.component [1](R 1.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework.dto)(version>=1.8.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.osgi.service.component [1](R 1.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.util.promise)(version>=1.0.0)(!(version>=2.0.0))) -> [org.osgi.util.promise [5](R 5.0)]
DEBUG: WIRE: [org.osgi.service.component [1](R 1.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.osgi.service.cm [2](R 2.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.6.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.osgi.service.cm [2](R 2.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.osgi.service.metatype [3](R 3.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.osgi.service.metatype [3](R 3.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.osgi.namespace.extender [4](R 4.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.resource)(version>=1.0.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.osgi.namespace.extender [4](R 4.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.5)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.osgi.util.pushstream [7](R 7.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.util.function)(version>=1.1.0)(!(version>=2.0.0))) -> [org.osgi.util.function [6](R 6.0)]
DEBUG: WIRE: [org.osgi.util.pushstream [7](R 7.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.util.promise)(version>=1.1.0)(!(version>=2.0.0))) -> [org.osgi.util.promise [5](R 5.0)]
DEBUG: WIRE: [org.osgi.util.pushstream [7](R 7.0)] osgi.ee; (&(osgi.ee=JavaSE/compact1)(version=1.8)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.osgi.service.log [8](R 8.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.8.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.osgi.service.log [8](R 8.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.util.pushstream)(version>=1.0.0)(!(version>=2.0.0))) -> [org.osgi.util.pushstream [7](R 7.0)]
DEBUG: WIRE: [org.osgi.service.log [8](R 8.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.log [9](R 9.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.8.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.log [9](R 9.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework.wiring)(version>=1.2.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.log [9](R 9.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.log)(version>=1.4.0)(!(version>=1.5.0))) -> [org.osgi.service.log [8](R 8.0)]
DEBUG: WIRE: [org.apache.felix.log [9](R 9.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.log.admin)(version>=1.0.0)(!(version>=1.1.0))) -> [org.osgi.service.log [8](R 8.0)]
DEBUG: WIRE: [org.apache.felix.log [9](R 9.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.util.tracker)(version>=1.5.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.log [9](R 9.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.scr [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.cm)(version>=1.6.0)(!(version>=2.0.0))) -> [org.osgi.service.cm [2](R 2.0)]
DEBUG: WIRE: [org.apache.felix.scr [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.log)(version>=1.3.0)(!(version>=2.0.0))) -> [org.osgi.service.log [8](R 8.0)]
DEBUG: WIRE: [org.apache.felix.scr [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.metatype)(version>=1.2.0)(!(version>=2.0.0))) -> [org.osgi.service.metatype [3](R 3.0)]
DEBUG: WIRE: [org.apache.felix.scr [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.packageadmin)(version>=1.2.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.scr [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.dto)(version>=1.0.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.scr [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.8.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.scr [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework.dto)(version>=1.8.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.scr [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework.startlevel)(version>=1.0.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.scr [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework.wiring)(version>=1.2.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.scr [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.component)(version>=1.4.0)(!(version>=1.5.0))) -> [org.osgi.service.component [1](R 1.0)]
DEBUG: WIRE: [org.apache.felix.scr [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.component.runtime)(version>=1.4.0)(!(version>=1.5.0))) -> [org.osgi.service.component [1](R 1.0)]
DEBUG: WIRE: [org.apache.felix.scr [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.component.runtime.dto)(version>=1.4.0)(!(version>=1.5.0))) -> [org.osgi.service.component [1](R 1.0)]
DEBUG: WIRE: [org.apache.felix.scr [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.util.promise)(version>=1.0.0)(!(version>=2.0.0))) -> [org.osgi.util.promise [5](R 5.0)]
DEBUG: WIRE: [org.apache.felix.scr [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.util.tracker)(version>=1.5.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.scr [10](R 10.0)] osgi.ee; (|(&(osgi.ee=JavaSE)(version=1.7))(&(osgi.ee=JavaSE/compact1)(version=1.8))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.fileinstall [11](R 11.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.6.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.fileinstall [11](R 11.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework.startlevel)(version>=1.0.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.fileinstall [11](R 11.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework.wiring)(version>=1.0.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.fileinstall [11](R 11.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.cm)(version>=1.5.0)(!(version>=2.0.0))) -> [org.osgi.service.cm [2](R 2.0)]
DEBUG: WIRE: [org.apache.felix.fileinstall [11](R 11.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.log)(version>=1.3.0)(!(version>=2.0.0))) -> [org.osgi.service.log [8](R 8.0)]
DEBUG: WIRE: [org.apache.felix.fileinstall [11](R 11.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.url)(version>=1.0.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.fileinstall [11](R 11.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.util.tracker)(version>=1.5.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.configadmin [12](R 12.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.cm)(version>=1.6.0)(!(version>=1.7.0))) -> [org.osgi.service.cm [2](R 2.0)]
DEBUG: WIRE: [org.apache.felix.configadmin [12](R 12.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.log)(version>=1.3.0)(!(version>=2.0.0))) -> [org.osgi.service.log [8](R 8.0)]
DEBUG: WIRE: [org.apache.felix.configadmin [12](R 12.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.8.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.configadmin [12](R 12.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.util.tracker)(version>=1.5.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.configadmin [12](R 12.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-common [20](R 20.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.9.0)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-common [20](R 20.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-common [20](R 20.0)] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)(!(version>=20080702.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-common [20](R 20.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework.wiring)(version>=1.2.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-common [20](R 20.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.cm)(version>=1.6.0)(!(version>=2.0.0))) -> [org.osgi.service.cm [2](R 2.0)]
DEBUG: WIRE: [sensinact-common [20](R 20.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.log)(version>=1.4.0)(!(version>=2.0.0))) -> [org.osgi.service.log [8](R 8.0)]
DEBUG: WIRE: [sensinact-common [20](R 20.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.util.tracker)(version>=1.5.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-common [20](R 20.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.8)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.wiring.package; (osgi.wiring.package=javax.activation) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.wiring.package; (osgi.wiring.package=javax.crypto) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.wiring.package; (osgi.wiring.package=javax.crypto.interfaces) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.wiring.package; (osgi.wiring.package=javax.crypto.spec) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.wiring.package; (osgi.wiring.package=javax.mail) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.wiring.package; (osgi.wiring.package=javax.mail.internet) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.wiring.package; (osgi.wiring.package=javax.naming) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.wiring.package; (osgi.wiring.package=javax.naming.directory) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.wiring.package; (osgi.wiring.package=javax.net.ssl) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.wiring.package; (osgi.wiring.package=javax.security.auth.callback) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.wiring.package; (osgi.wiring.package=javax.security.auth.x500) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.crypto)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.8.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.8)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-utils [19](R 19.0)] osgi.wiring.package; (osgi.wiring.package=javax.imageio) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-utils [19](R 19.0)] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-utils [19](R 19.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.8.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-utils [19](R 19.0)] osgi.wiring.package; (osgi.wiring.package=org.xml.sax) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-utils [19](R 19.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.8)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: Bundle sensinact-signature-validator [14] sensiNact-conf.xml not found by sensinact-signature-validator [14]
DEBUG: WIRE: [sensinact-datastore-api [21](R 21.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-datastore-api [21](R 21.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.execution)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-datastore-api [21](R 21.0)] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)(!(version>=20080702.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-datastore-api [21](R 21.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.8)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [slf4j.api [23](R 23.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.5.0)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: FRAGMENT WIRE: [slf4j.simple [24](R 24.0)] osgi.wiring.host; (&(osgi.wiring.host=slf4j.api)(bundle-version>=0.0.0)) -> [slf4j.api [23](R 23.0)]
DEBUG: FRAGMENT WIRE: [slf4j.simple [24](R 24.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.5.0)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.constraint)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.execution)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.primitive)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.props)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.datastore.api)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-datastore-api [21](R 21.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.security.signature.api)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-signature-validator [14](R 14.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.crypto)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.stack)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.tree)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)(!(version>=20080702.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.8.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.7.0)(!(version>=2.0.0))) -> [slf4j.api [23](R 23.0)]
DEBUG: WIRE: [sensinact-security-none [22](R 22.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-security-none [22](R 22.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.tree)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-security-none [22](R 22.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.8.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] org.eclipse.sensinact.security; (*) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] org.eclipse.sensinact.data.store; (*) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] org.eclipse.sensinact.signature.validator; (*) -> [sensinact-signature-validator [14](R 14.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.8)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: FRAGMENT WIRE: [sensinact-security-none [22](R 22.0)] osgi.wiring.host; (&(osgi.wiring.host=sensinact-core)(bundle-version>=0.0.0)) -> [sensinact-core [15](R 15.0)]
DEBUG: FRAGMENT WIRE: [sensinact-security-none [22](R 22.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.8)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: Bundle sensinact-core [15] sensiNact-conf.xml not found by sensinact-core [15]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.constraint)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.execution)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.primitive)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method.builder)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method.trigger)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.security)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.xml)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)(!(version>=20080702.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.8.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (osgi.wiring.package=org.xml.sax) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.packet)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.packet.annotation)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.stream)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.uri)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.parser)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.annotation)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.local)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.constraint)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.execution)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.primitive)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method.builder)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method.trigger)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.security)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.xml)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (osgi.wiring.package=org.xml.sax) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.0)] osgi.wiring.package; (osgi.wiring.package=org.eclipse.sensinact.gateway.test) -> [org.apache.felix.framework [0](R 0)]
DEBUG: Bundle sensinact-generic-test-moke-1 [25] sensiNact-conf.xml not found by sensinact-generic-test-moke-1 [25]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.packet)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.packet.annotation)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.stream)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.uri)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.parser)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.annotation)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.local)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.constraint)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.execution)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.primitive)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method.builder)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method.trigger)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.security)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.xml)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (osgi.wiring.package=org.xml.sax) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-generic-test-moke-1 [25](R 25.1)] osgi.wiring.package; (osgi.wiring.package=org.eclipse.sensinact.gateway.test) -> [org.apache.felix.framework [0](R 0)]
DEBUG: Bundle sensinact-generic-test-moke-1 [25] sensiNact-conf.xml not found by sensinact-generic-test-moke-1 [25]
Felix stopped [46]
DEBUG: WIRE: [org.osgi.util.promise [5](R 5.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.util.function)(version>=1.1.0)(!(version>=2.0.0))) -> [org.osgi.util.function [6](R 6.0)]
DEBUG: WIRE: [org.osgi.util.promise [5](R 5.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.osgi.util.function [6](R 6.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.osgi.service.component [1](R 1.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.dto)(version>=1.1.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.osgi.service.component [1](R 1.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.9.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.osgi.service.component [1](R 1.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework.dto)(version>=1.8.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.osgi.service.component [1](R 1.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.util.promise)(version>=1.0.0)(!(version>=2.0.0))) -> [org.osgi.util.promise [5](R 5.0)]
DEBUG: WIRE: [org.osgi.service.component [1](R 1.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.osgi.service.cm [2](R 2.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.6.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.osgi.service.cm [2](R 2.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.osgi.service.metatype [3](R 3.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.osgi.service.metatype [3](R 3.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.osgi.namespace.extender [4](R 4.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.resource)(version>=1.0.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.osgi.namespace.extender [4](R 4.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.5)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.osgi.util.pushstream [7](R 7.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.util.function)(version>=1.1.0)(!(version>=2.0.0))) -> [org.osgi.util.function [6](R 6.0)]
DEBUG: WIRE: [org.osgi.util.pushstream [7](R 7.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.util.promise)(version>=1.1.0)(!(version>=2.0.0))) -> [org.osgi.util.promise [5](R 5.0)]
DEBUG: WIRE: [org.osgi.util.pushstream [7](R 7.0)] osgi.ee; (&(osgi.ee=JavaSE/compact1)(version=1.8)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.osgi.service.log [8](R 8.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.8.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.osgi.service.log [8](R 8.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.util.pushstream)(version>=1.0.0)(!(version>=2.0.0))) -> [org.osgi.util.pushstream [7](R 7.0)]
DEBUG: WIRE: [org.osgi.service.log [8](R 8.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.log [9](R 9.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.8.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.log [9](R 9.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework.wiring)(version>=1.2.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.log [9](R 9.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.log)(version>=1.4.0)(!(version>=1.5.0))) -> [org.osgi.service.log [8](R 8.0)]
DEBUG: WIRE: [org.apache.felix.log [9](R 9.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.log.admin)(version>=1.0.0)(!(version>=1.1.0))) -> [org.osgi.service.log [8](R 8.0)]
DEBUG: WIRE: [org.apache.felix.log [9](R 9.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.util.tracker)(version>=1.5.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.log [9](R 9.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.scr [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.cm)(version>=1.6.0)(!(version>=2.0.0))) -> [org.osgi.service.cm [2](R 2.0)]
DEBUG: WIRE: [org.apache.felix.scr [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.log)(version>=1.3.0)(!(version>=2.0.0))) -> [org.osgi.service.log [8](R 8.0)]
DEBUG: WIRE: [org.apache.felix.scr [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.metatype)(version>=1.2.0)(!(version>=2.0.0))) -> [org.osgi.service.metatype [3](R 3.0)]
DEBUG: WIRE: [org.apache.felix.scr [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.packageadmin)(version>=1.2.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.scr [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.dto)(version>=1.0.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.scr [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.8.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.scr [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework.dto)(version>=1.8.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.scr [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework.startlevel)(version>=1.0.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.scr [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework.wiring)(version>=1.2.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.scr [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.component)(version>=1.4.0)(!(version>=1.5.0))) -> [org.osgi.service.component [1](R 1.0)]
DEBUG: WIRE: [org.apache.felix.scr [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.component.runtime)(version>=1.4.0)(!(version>=1.5.0))) -> [org.osgi.service.component [1](R 1.0)]
DEBUG: WIRE: [org.apache.felix.scr [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.component.runtime.dto)(version>=1.4.0)(!(version>=1.5.0))) -> [org.osgi.service.component [1](R 1.0)]
DEBUG: WIRE: [org.apache.felix.scr [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.util.promise)(version>=1.0.0)(!(version>=2.0.0))) -> [org.osgi.util.promise [5](R 5.0)]
DEBUG: WIRE: [org.apache.felix.scr [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.util.tracker)(version>=1.5.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.scr [10](R 10.0)] osgi.ee; (|(&(osgi.ee=JavaSE)(version=1.7))(&(osgi.ee=JavaSE/compact1)(version=1.8))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.fileinstall [11](R 11.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.6.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.fileinstall [11](R 11.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework.startlevel)(version>=1.0.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.fileinstall [11](R 11.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework.wiring)(version>=1.0.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.fileinstall [11](R 11.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.cm)(version>=1.5.0)(!(version>=2.0.0))) -> [org.osgi.service.cm [2](R 2.0)]
DEBUG: WIRE: [org.apache.felix.fileinstall [11](R 11.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.log)(version>=1.3.0)(!(version>=2.0.0))) -> [org.osgi.service.log [8](R 8.0)]
DEBUG: WIRE: [org.apache.felix.fileinstall [11](R 11.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.url)(version>=1.0.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.fileinstall [11](R 11.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.util.tracker)(version>=1.5.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.configadmin [12](R 12.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.cm)(version>=1.6.0)(!(version>=1.7.0))) -> [org.osgi.service.cm [2](R 2.0)]
DEBUG: WIRE: [org.apache.felix.configadmin [12](R 12.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.log)(version>=1.3.0)(!(version>=2.0.0))) -> [org.osgi.service.log [8](R 8.0)]
DEBUG: WIRE: [org.apache.felix.configadmin [12](R 12.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.8.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.configadmin [12](R 12.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.util.tracker)(version>=1.5.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.configadmin [12](R 12.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.wiring.package; (osgi.wiring.package=javax.activation) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.wiring.package; (osgi.wiring.package=javax.crypto) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.wiring.package; (osgi.wiring.package=javax.crypto.interfaces) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.wiring.package; (osgi.wiring.package=javax.crypto.spec) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.wiring.package; (osgi.wiring.package=javax.mail) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.wiring.package; (osgi.wiring.package=javax.mail.internet) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.wiring.package; (osgi.wiring.package=javax.naming) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.wiring.package; (osgi.wiring.package=javax.naming.directory) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.wiring.package; (osgi.wiring.package=javax.net.ssl) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.wiring.package; (osgi.wiring.package=javax.security.auth.callback) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.wiring.package; (osgi.wiring.package=javax.security.auth.x500) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.crypto)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.8.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.8)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-utils [19](R 19.0)] osgi.wiring.package; (osgi.wiring.package=javax.imageio) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-utils [19](R 19.0)] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-utils [19](R 19.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.8.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-utils [19](R 19.0)] osgi.wiring.package; (osgi.wiring.package=org.xml.sax) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-utils [19](R 19.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.8)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-common [20](R 20.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.9.0)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-common [20](R 20.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-common [20](R 20.0)] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)(!(version>=20080702.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-common [20](R 20.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework.wiring)(version>=1.2.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-common [20](R 20.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.cm)(version>=1.6.0)(!(version>=2.0.0))) -> [org.osgi.service.cm [2](R 2.0)]
DEBUG: WIRE: [sensinact-common [20](R 20.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.log)(version>=1.4.0)(!(version>=2.0.0))) -> [org.osgi.service.log [8](R 8.0)]
DEBUG: WIRE: [sensinact-common [20](R 20.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.util.tracker)(version>=1.5.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-common [20](R 20.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.8)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: Bundle sensinact-signature-validator [14] sensiNact-conf.xml not found by sensinact-signature-validator [14]
DEBUG: WIRE: [slf4j.api [23](R 23.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.5.0)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: FRAGMENT WIRE: [slf4j.simple [24](R 24.0)] osgi.wiring.host; (&(osgi.wiring.host=slf4j.api)(bundle-version>=0.0.0)) -> [slf4j.api [23](R 23.0)]
DEBUG: FRAGMENT WIRE: [slf4j.simple [24](R 24.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.5.0)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.constraint)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.execution)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.primitive)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.props)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.datastore.api)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-datastore-api [21](R 21.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.security.signature.api)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-signature-validator [14](R 14.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.crypto)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.stack)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.tree)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)(!(version>=20080702.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.8.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.7.0)(!(version>=2.0.0))) -> [slf4j.api [23](R 23.0)]
DEBUG: WIRE: [sensinact-security-none [22](R 22.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-security-none [22](R 22.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.tree)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-security-none [22](R 22.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.8.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] org.eclipse.sensinact.security; (*) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] org.eclipse.sensinact.data.store; (*) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] org.eclipse.sensinact.signature.validator; (*) -> [sensinact-signature-validator [14](R 14.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.8)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-datastore-api [21](R 21.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-datastore-api [21](R 21.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.execution)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-datastore-api [21](R 21.0)] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)(!(version>=20080702.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-datastore-api [21](R 21.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.8)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: FRAGMENT WIRE: [sensinact-security-none [22](R 22.0)] osgi.wiring.host; (&(osgi.wiring.host=sensinact-core)(bundle-version>=0.0.0)) -> [sensinact-core [15](R 15.0)]
DEBUG: FRAGMENT WIRE: [sensinact-security-none [22](R 22.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.8)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: Bundle sensinact-core [15] sensiNact-conf.xml not found by sensinact-core [15]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.constraint)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.execution)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.primitive)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method.builder)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method.trigger)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.security)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.xml)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)(!(version>=20080702.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.8.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (osgi.wiring.package=org.xml.sax) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-generic-test-moke-2 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-2 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.packet)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-2 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.packet.annotation)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-2 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.stream)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-2 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.uri)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-2 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.parser)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-2 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.annotation)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-2 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.local)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-2 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-2 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.constraint)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-2 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.execution)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-2 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.primitive)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-2 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-2 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-2 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method.builder)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-2 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method.trigger)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-2 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.security)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-2 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-2 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.xml)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-2 [25](R 25.0)] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-generic-test-moke-2 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-2 [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-generic-test-moke-2 [25](R 25.0)] osgi.wiring.package; (osgi.wiring.package=org.xml.sax) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-generic-test-moke-2 [25](R 25.0)] osgi.wiring.package; (osgi.wiring.package=org.eclipse.sensinact.gateway.test) -> [org.apache.felix.framework [0](R 0)]
DEBUG: Bundle sensinact-generic-test-moke-2 [25] sensiNact-conf.xml not found by sensinact-generic-test-moke-2 [25]
DEBUG: WIRE: [sensinact-generic-test-moke-2 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-2 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.packet)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-2 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.packet.annotation)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-2 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.stream)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-2 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.uri)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-2 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.parser)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-2 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.annotation)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-2 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.local)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-2 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-2 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.constraint)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-2 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.execution)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-2 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.primitive)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-2 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-2 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-2 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method.builder)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-2 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method.trigger)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-2 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.security)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-2 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-2 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.xml)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-2 [25](R 25.1)] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-generic-test-moke-2 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-generic-test-moke-2 [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-generic-test-moke-2 [25](R 25.1)] osgi.wiring.package; (osgi.wiring.package=org.xml.sax) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-generic-test-moke-2 [25](R 25.1)] osgi.wiring.package; (osgi.wiring.package=org.eclipse.sensinact.gateway.test) -> [org.apache.felix.framework [0](R 0)]
DEBUG: Bundle sensinact-generic-test-moke-2 [25] sensiNact-conf.xml not found by sensinact-generic-test-moke-2 [25]
Felix stopped [42]
DEBUG: WIRE: [org.osgi.service.component [1](R 1.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.dto)(version>=1.1.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.osgi.service.component [1](R 1.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.9.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.osgi.service.component [1](R 1.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework.dto)(version>=1.8.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.osgi.service.component [1](R 1.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.util.promise)(version>=1.0.0)(!(version>=2.0.0))) -> [org.osgi.util.promise [5](R 5.0)]
DEBUG: WIRE: [org.osgi.service.component [1](R 1.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.osgi.util.function [6](R 6.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.osgi.util.promise [5](R 5.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.util.function)(version>=1.1.0)(!(version>=2.0.0))) -> [org.osgi.util.function [6](R 6.0)]
DEBUG: WIRE: [org.osgi.util.promise [5](R 5.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.osgi.service.cm [2](R 2.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.6.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.osgi.service.cm [2](R 2.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.osgi.service.metatype [3](R 3.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.osgi.service.metatype [3](R 3.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.osgi.namespace.extender [4](R 4.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.resource)(version>=1.0.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.osgi.namespace.extender [4](R 4.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.5)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.osgi.util.pushstream [7](R 7.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.util.function)(version>=1.1.0)(!(version>=2.0.0))) -> [org.osgi.util.function [6](R 6.0)]
DEBUG: WIRE: [org.osgi.util.pushstream [7](R 7.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.util.promise)(version>=1.1.0)(!(version>=2.0.0))) -> [org.osgi.util.promise [5](R 5.0)]
DEBUG: WIRE: [org.osgi.util.pushstream [7](R 7.0)] osgi.ee; (&(osgi.ee=JavaSE/compact1)(version=1.8)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.osgi.service.log [8](R 8.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.8.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.osgi.service.log [8](R 8.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.util.pushstream)(version>=1.0.0)(!(version>=2.0.0))) -> [org.osgi.util.pushstream [7](R 7.0)]
DEBUG: WIRE: [org.osgi.service.log [8](R 8.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.log [9](R 9.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.8.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.log [9](R 9.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework.wiring)(version>=1.2.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.log [9](R 9.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.log)(version>=1.4.0)(!(version>=1.5.0))) -> [org.osgi.service.log [8](R 8.0)]
DEBUG: WIRE: [org.apache.felix.log [9](R 9.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.log.admin)(version>=1.0.0)(!(version>=1.1.0))) -> [org.osgi.service.log [8](R 8.0)]
DEBUG: WIRE: [org.apache.felix.log [9](R 9.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.util.tracker)(version>=1.5.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.log [9](R 9.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.scr [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.cm)(version>=1.6.0)(!(version>=2.0.0))) -> [org.osgi.service.cm [2](R 2.0)]
DEBUG: WIRE: [org.apache.felix.scr [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.log)(version>=1.3.0)(!(version>=2.0.0))) -> [org.osgi.service.log [8](R 8.0)]
DEBUG: WIRE: [org.apache.felix.scr [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.metatype)(version>=1.2.0)(!(version>=2.0.0))) -> [org.osgi.service.metatype [3](R 3.0)]
DEBUG: WIRE: [org.apache.felix.scr [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.packageadmin)(version>=1.2.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.scr [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.dto)(version>=1.0.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.scr [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.8.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.scr [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework.dto)(version>=1.8.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.scr [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework.startlevel)(version>=1.0.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.scr [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework.wiring)(version>=1.2.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.scr [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.component)(version>=1.4.0)(!(version>=1.5.0))) -> [org.osgi.service.component [1](R 1.0)]
DEBUG: WIRE: [org.apache.felix.scr [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.component.runtime)(version>=1.4.0)(!(version>=1.5.0))) -> [org.osgi.service.component [1](R 1.0)]
DEBUG: WIRE: [org.apache.felix.scr [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.component.runtime.dto)(version>=1.4.0)(!(version>=1.5.0))) -> [org.osgi.service.component [1](R 1.0)]
DEBUG: WIRE: [org.apache.felix.scr [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.util.promise)(version>=1.0.0)(!(version>=2.0.0))) -> [org.osgi.util.promise [5](R 5.0)]
DEBUG: WIRE: [org.apache.felix.scr [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.util.tracker)(version>=1.5.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.scr [10](R 10.0)] osgi.ee; (|(&(osgi.ee=JavaSE)(version=1.7))(&(osgi.ee=JavaSE/compact1)(version=1.8))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.fileinstall [11](R 11.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.6.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.fileinstall [11](R 11.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework.startlevel)(version>=1.0.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.fileinstall [11](R 11.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework.wiring)(version>=1.0.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.fileinstall [11](R 11.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.cm)(version>=1.5.0)(!(version>=2.0.0))) -> [org.osgi.service.cm [2](R 2.0)]
DEBUG: WIRE: [org.apache.felix.fileinstall [11](R 11.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.log)(version>=1.3.0)(!(version>=2.0.0))) -> [org.osgi.service.log [8](R 8.0)]
DEBUG: WIRE: [org.apache.felix.fileinstall [11](R 11.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.url)(version>=1.0.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.fileinstall [11](R 11.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.util.tracker)(version>=1.5.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.configadmin [12](R 12.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.cm)(version>=1.6.0)(!(version>=1.7.0))) -> [org.osgi.service.cm [2](R 2.0)]
DEBUG: WIRE: [org.apache.felix.configadmin [12](R 12.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.log)(version>=1.3.0)(!(version>=2.0.0))) -> [org.osgi.service.log [8](R 8.0)]
DEBUG: WIRE: [org.apache.felix.configadmin [12](R 12.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.8.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.configadmin [12](R 12.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.util.tracker)(version>=1.5.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [org.apache.felix.configadmin [12](R 12.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-utils [19](R 19.0)] osgi.wiring.package; (osgi.wiring.package=javax.imageio) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-utils [19](R 19.0)] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-utils [19](R 19.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.8.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-utils [19](R 19.0)] osgi.wiring.package; (osgi.wiring.package=org.xml.sax) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-utils [19](R 19.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.8)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.wiring.package; (osgi.wiring.package=javax.activation) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.wiring.package; (osgi.wiring.package=javax.crypto) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.wiring.package; (osgi.wiring.package=javax.crypto.interfaces) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.wiring.package; (osgi.wiring.package=javax.crypto.spec) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.wiring.package; (osgi.wiring.package=javax.mail) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.wiring.package; (osgi.wiring.package=javax.mail.internet) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.wiring.package; (osgi.wiring.package=javax.naming) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.wiring.package; (osgi.wiring.package=javax.naming.directory) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.wiring.package; (osgi.wiring.package=javax.net.ssl) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.wiring.package; (osgi.wiring.package=javax.security.auth.callback) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.wiring.package; (osgi.wiring.package=javax.security.auth.x500) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.crypto)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.8.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-signature-validator [14](R 14.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.8)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-common [20](R 20.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.9.0)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-common [20](R 20.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-common [20](R 20.0)] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)(!(version>=20080702.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-common [20](R 20.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework.wiring)(version>=1.2.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-common [20](R 20.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.cm)(version>=1.6.0)(!(version>=2.0.0))) -> [org.osgi.service.cm [2](R 2.0)]
DEBUG: WIRE: [sensinact-common [20](R 20.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.log)(version>=1.4.0)(!(version>=2.0.0))) -> [org.osgi.service.log [8](R 8.0)]
DEBUG: WIRE: [sensinact-common [20](R 20.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.util.tracker)(version>=1.5.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-common [20](R 20.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.8)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: Bundle sensinact-signature-validator [14] sensiNact-conf.xml not found by sensinact-signature-validator [14]
DEBUG: FRAGMENT WIRE: [slf4j.simple [24](R 24.0)] osgi.wiring.host; (&(osgi.wiring.host=slf4j.api)(bundle-version>=0.0.0)) -> [slf4j.api [23](R 23.0)]
DEBUG: FRAGMENT WIRE: [slf4j.simple [24](R 24.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.5.0)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.constraint)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.execution)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.primitive)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.props)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.datastore.api)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-datastore-api [21](R 21.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.security.signature.api)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-signature-validator [14](R 14.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.crypto)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.stack)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.tree)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)(!(version>=20080702.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.8.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.7.0)(!(version>=2.0.0))) -> [slf4j.api [23](R 23.0)]
DEBUG: WIRE: [sensinact-security-none [22](R 22.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-security-none [22](R 22.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.tree)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-security-none [22](R 22.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.8.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] org.eclipse.sensinact.security; (*) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] org.eclipse.sensinact.data.store; (*) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] org.eclipse.sensinact.signature.validator; (*) -> [sensinact-signature-validator [14](R 14.0)]
DEBUG: WIRE: [sensinact-core [15](R 15.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.8)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [slf4j.api [23](R 23.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.5.0)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-datastore-api [21](R 21.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-datastore-api [21](R 21.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.execution)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-datastore-api [21](R 21.0)] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)(!(version>=20080702.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-datastore-api [21](R 21.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.8)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: FRAGMENT WIRE: [sensinact-security-none [22](R 22.0)] osgi.wiring.host; (&(osgi.wiring.host=sensinact-core)(bundle-version>=0.0.0)) -> [sensinact-core [15](R 15.0)]
DEBUG: FRAGMENT WIRE: [sensinact-security-none [22](R 22.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.8)) -> [org.apache.felix.framework [0](R 0)]
DEBUG: Bundle sensinact-core [15] sensiNact-conf.xml not found by sensinact-core [15]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.constraint)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.execution)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.primitive)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method.builder)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method.trigger)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.security)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.xml)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)(!(version>=20080702.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.8.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-generic [16](R 16.0)] osgi.wiring.package; (osgi.wiring.package=org.xml.sax) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-generic-test [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.packet)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.packet.annotation)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.stream)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.uri)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.parser)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.annotation)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.local)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-generic-test [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.constraint)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-generic-test [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.execution)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-generic-test [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.primitive)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-generic-test [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic-test [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic-test [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method.builder)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic-test [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method.trigger)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic-test [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.security)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic-test [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-generic-test [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.xml)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-generic-test [25](R 25.0)] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-generic-test [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-generic-test [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-generic-test [25](R 25.0)] osgi.wiring.package; (osgi.wiring.package=org.xml.sax) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-generic-test [25](R 25.0)] osgi.wiring.package; (osgi.wiring.package=org.eclipse.sensinact.gateway.test) -> [org.apache.felix.framework [0](R 0)]
DEBUG: Bundle sensinact-generic-test [25] sensiNact-conf.xml not found by sensinact-generic-test [25]
DEBUG: WIRE: [sensinact-generic-test [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.packet)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.packet.annotation)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.stream)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.uri)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.parser)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.annotation)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.generic.local)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-generic [16](R 16.0)]
DEBUG: WIRE: [sensinact-generic-test [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.bundle)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-generic-test [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.constraint)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-generic-test [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.execution)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-generic-test [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.common.primitive)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-common [20](R 20.0)]
DEBUG: WIRE: [sensinact-generic-test [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic-test [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic-test [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method.builder)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic-test [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.method.trigger)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic-test [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.core.security)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-core [15](R 15.0)]
DEBUG: WIRE: [sensinact-generic-test [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-generic-test [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.sensinact.gateway.util.xml)(version>=2.0.0)(!(version>=3.0.0))) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-generic-test [25](R 25.1)] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-generic-test [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.json)(version>=20080701.0.0)) -> [sensinact-utils [19](R 19.0)]
DEBUG: WIRE: [sensinact-generic-test [25](R 25.1)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-generic-test [25](R 25.1)] osgi.wiring.package; (osgi.wiring.package=org.xml.sax) -> [org.apache.felix.framework [0](R 0)]
DEBUG: WIRE: [sensinact-generic-test [25](R 25.1)] osgi.wiring.package; (osgi.wiring.package=org.eclipse.sensinact.gateway.test) -> [org.apache.felix.framework [0](R 0)]
DEBUG: Bundle sensinact-generic-test [25] sensiNact-conf.xml not found by sensinact-generic-test [25]
Felix stopped [46]
[INFO] Tests run: 7, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 150.963 s - in org.eclipse.sensinact.gateway.generic.test.TestGenericImplementation
[INFO] 
[INFO] Results:
[INFO] 
[INFO] Tests run: 7, Failures: 0, Errors: 0, Skipped: 0
[INFO] 
[JENKINS] Recording test results
[INFO] 
[INFO] --- maven-bundle-plugin:4.0.0:bundle (default-bundle) @ sensinact-generic ---
[WARNING] Include-Resource: overriding sensinact-resource.xsd=src/main/resources/sensinact-resource.xsd with about.html,src/main/resources/ (add {maven-resources} if you want to include the maven resources)
[INFO] 
[INFO] --- maven-install-plugin:3.0.0-M1:install (default-install) @ sensinact-generic ---
[INFO] Installing /home/jenkins/agent/workspace/Gateway master Sonar/platform/sensinact-generic/target/sensinact-generic-2.0-SNAPSHOT.jar to /home/jenkins/.m2/repository/org/eclipse/sensinact/gateway/sensinact-generic/2.0-SNAPSHOT/sensinact-generic-2.0-SNAPSHOT.jar
[INFO] Installing /home/jenkins/agent/workspace/Gateway master Sonar/platform/sensinact-generic/pom.xml to /home/jenkins/.m2/repository/org/eclipse/sensinact/gateway/sensinact-generic/2.0-SNAPSHOT/sensinact-generic-2.0-SNAPSHOT.pom
[INFO] 
[INFO] --- maven-bundle-plugin:4.0.0:install (default-install) @ sensinact-generic ---
[INFO] Installing org/eclipse/sensinact/gateway/sensinact-generic/2.0-SNAPSHOT/sensinact-generic-2.0-SNAPSHOT.jar
[INFO] Writing OBR metadata
[INFO] 
[INFO] --- groovy-maven-plugin:2.0:execute (search-sha) @ sensinact-generic ---
[INFO] SHA: DgDPy6Ixw7XTtSqe2IkJDK49Pqyclw6j537pPqbnJ8U=