FailedConsole Output

Skipping 3,968 KB.. Full Log
quirement: Import-Package: org.junit.platform.commons.util; version="[1.4.0,2.0.0)"
           -> Export-Package: org.junit.platform.commons.util; bundle-symbolic-name="org.junit.platform.commons"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api,org.junit.platform.commons,org.junit.platform.commons.function"
         Unresolved requirement: Import-Package: org.opentest4j; version="[1.1.1,2.0.0)"
           -> Export-Package: org.opentest4j; bundle-symbolic-name="org.opentest4j"; bundle-version="1.1.1.v20190212-2109"; version="1.1.1"
              org.opentest4j [409]
                No resolution report for the bundle.         Unresolved requirement: Import-Package: org.junit.platform.commons; version="[1.4.0,2.0.0)"
           -> Export-Package: org.junit.platform.commons; bundle-symbolic-name="org.junit.platform.commons"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api"
         Unresolved requirement: Import-Package: org.junit.platform.commons.logging; version="[1.4.0,2.0.0)"
           -> Export-Package: org.junit.platform.commons.logging; bundle-symbolic-name="org.junit.platform.commons"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api"
         Unresolved requirement: Import-Package: org.junit.platform.commons.support; version="[1.4.0,2.0.0)"
           -> Export-Package: org.junit.platform.commons.support; bundle-symbolic-name="org.junit.platform.commons"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api,org.junit.platform.commons.function"
  Unresolved requirement: Import-Package: org.apiguardian.api; version="[1.0.0,2.0.0)"
    -> Export-Package: org.apiguardian.api; bundle-symbolic-name="org.apiguardian"; bundle-version="1.0.0.v20190212-2109"; version="1.0.0"
  Unresolved requirement: Import-Package: org.junit; version="[4.12.0,5.0.0)"
    -> Export-Package: org.junit; bundle-symbolic-name="org.junit"; bundle-version="4.12.0.v201504281640"; version="4.12.0"

org.junit.jupiter.params [392]
  Unresolved requirement: Import-Package: kotlin; resolution:="optional"
  Unresolved requirement: Import-Package: kotlin.jvm.internal; resolution:="optional"
  Unresolved requirement: Import-Package: org.junit.platform.commons.support; version="[1.4.0,2.0.0)"
    -> Export-Package: org.junit.platform.commons.support; bundle-symbolic-name="org.junit.platform.commons"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api,org.junit.platform.commons.function"
       org.junit.platform.commons [393]
         Unresolved requirement: Import-Package: org.apiguardian.api; version="[1.0.0,2.0.0)"
           -> Export-Package: org.apiguardian.api; bundle-symbolic-name="org.apiguardian"; bundle-version="1.0.0.v20190212-2109"; version="1.0.0"
              org.apiguardian [354]
                No resolution report for the bundle.  Unresolved requirement: Import-Package: org.junit.platform.commons.function; version="[1.4.0,2.0.0)"
    -> Export-Package: org.junit.platform.commons.function; bundle-symbolic-name="org.junit.platform.commons"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api"
  Unresolved requirement: Import-Package: org.junit.platform.commons.util; version="[1.4.0,2.0.0)"
    -> Export-Package: org.junit.platform.commons.util; bundle-symbolic-name="org.junit.platform.commons"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api,org.junit.platform.commons,org.junit.platform.commons.function"
  Unresolved requirement: Import-Package: org.apiguardian.api; version="[1.0.0,2.0.0)"
    -> Export-Package: org.apiguardian.api; bundle-symbolic-name="org.apiguardian"; bundle-version="1.0.0.v20190212-2109"; version="1.0.0"
  Unresolved requirement: Import-Package: org.junit.platform.commons; version="[1.4.0,2.0.0)"
    -> Export-Package: org.junit.platform.commons; bundle-symbolic-name="org.junit.platform.commons"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api"
  Unresolved requirement: Import-Package: org.junit.jupiter.api.extension; version="[5.4.0,6.0.0)"
    -> Export-Package: org.junit.jupiter.api.extension; bundle-symbolic-name="org.junit.jupiter.api"; bundle-version="5.4.0.v20190212-2109"; version="5.4.0"; uses:="org.apiguardian.api,org.junit.jupiter.api,org.junit.platform.commons"
       org.junit.jupiter.api [389]
         Unresolved requirement: Import-Package: kotlin; resolution:="optional"
         Unresolved requirement: Import-Package: kotlin.collections; resolution:="optional"
         Unresolved requirement: Import-Package: kotlin.jvm.functions; resolution:="optional"
         Unresolved requirement: Import-Package: kotlin.jvm.internal; resolution:="optional"
         Unresolved requirement: Import-Package: org.junit.platform.commons.annotation; version="[1.4.0,2.0.0)"
           -> Export-Package: org.junit.platform.commons.annotation; bundle-symbolic-name="org.junit.platform.commons"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api"
         Unresolved requirement: Import-Package: org.apiguardian.api; version="[1.0.0,2.0.0)"
           -> Export-Package: org.apiguardian.api; bundle-symbolic-name="org.apiguardian"; bundle-version="1.0.0.v20190212-2109"; version="1.0.0"
         Unresolved requirement: Import-Package: org.junit.platform.commons.util; version="[1.4.0,2.0.0)"
           -> Export-Package: org.junit.platform.commons.util; bundle-symbolic-name="org.junit.platform.commons"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api,org.junit.platform.commons,org.junit.platform.commons.function"
         Unresolved requirement: Import-Package: org.opentest4j; version="[1.1.1,2.0.0)"
           -> Export-Package: org.opentest4j; bundle-symbolic-name="org.opentest4j"; bundle-version="1.1.1.v20190212-2109"; version="1.1.1"
              org.opentest4j [409]
                No resolution report for the bundle.         Unresolved requirement: Import-Package: org.junit.platform.commons; version="[1.4.0,2.0.0)"
           -> Export-Package: org.junit.platform.commons; bundle-symbolic-name="org.junit.platform.commons"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api"
         Unresolved requirement: Import-Package: org.junit.platform.commons.logging; version="[1.4.0,2.0.0)"
           -> Export-Package: org.junit.platform.commons.logging; bundle-symbolic-name="org.junit.platform.commons"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api"
         Unresolved requirement: Import-Package: org.junit.platform.commons.support; version="[1.4.0,2.0.0)"
           -> Export-Package: org.junit.platform.commons.support; bundle-symbolic-name="org.junit.platform.commons"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api,org.junit.platform.commons.function"
  Unresolved requirement: Import-Package: org.junit.jupiter.api; version="[5.4.0,6.0.0)"
    -> Export-Package: org.junit.jupiter.api; bundle-symbolic-name="org.junit.jupiter.api"; bundle-version="5.4.0.v20190212-2109"; version="5.4.0"; uses:="kotlin,kotlin.jvm.functions,kotlin.jvm.internal,org.apiguardian.api,org.junit.jupiter.api.function,org.junit.jupiter.api.parallel,org.junit.platform.commons.annotation,org.opentest4j"

org.junit.platform.commons [393]
  Unresolved requirement: Import-Package: org.apiguardian.api; version="[1.0.0,2.0.0)"
    -> Export-Package: org.apiguardian.api; bundle-symbolic-name="org.apiguardian"; bundle-version="1.0.0.v20190212-2109"; version="1.0.0"
       org.apiguardian [354]
         No resolution report for the bundle.
org.junit.platform.engine [394]
  Unresolved requirement: Import-Package: org.junit.platform.commons.util; version="[1.4.0,2.0.0)"
    -> Export-Package: org.junit.platform.commons.util; bundle-symbolic-name="org.junit.platform.commons"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api,org.junit.platform.commons,org.junit.platform.commons.function"
       org.junit.platform.commons [393]
         Unresolved requirement: Import-Package: org.apiguardian.api; version="[1.0.0,2.0.0)"
           -> Export-Package: org.apiguardian.api; bundle-symbolic-name="org.apiguardian"; bundle-version="1.0.0.v20190212-2109"; version="1.0.0"
              org.apiguardian [354]
                No resolution report for the bundle.  Unresolved requirement: Import-Package: org.opentest4j; version="[1.1.1,2.0.0)"
    -> Export-Package: org.opentest4j; bundle-symbolic-name="org.opentest4j"; bundle-version="1.1.1.v20190212-2109"; version="1.1.1"
       org.opentest4j [409]
         No resolution report for the bundle.  Unresolved requirement: Import-Package: org.apiguardian.api; version="[1.0.0,2.0.0)"
    -> Export-Package: org.apiguardian.api; bundle-symbolic-name="org.apiguardian"; bundle-version="1.0.0.v20190212-2109"; version="1.0.0"
  Unresolved requirement: Import-Package: org.junit.platform.commons.logging; version="[1.4.0,2.0.0)"
    -> Export-Package: org.junit.platform.commons.logging; bundle-symbolic-name="org.junit.platform.commons"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api"
  Unresolved requirement: Import-Package: org.junit.platform.commons; version="[1.4.0,2.0.0)"
    -> Export-Package: org.junit.platform.commons; bundle-symbolic-name="org.junit.platform.commons"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api"
  Unresolved requirement: Import-Package: org.junit.platform.commons.function; version="[1.4.0,2.0.0)"
    -> Export-Package: org.junit.platform.commons.function; bundle-symbolic-name="org.junit.platform.commons"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api"

org.junit.platform.launcher [395]
  Unresolved requirement: Import-Package: org.junit.platform.commons; version="[1.4.0,2.0.0)"
    -> Export-Package: org.junit.platform.commons; bundle-symbolic-name="org.junit.platform.commons"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api"
       org.junit.platform.commons [393]
         Unresolved requirement: Import-Package: org.apiguardian.api; version="[1.0.0,2.0.0)"
           -> Export-Package: org.apiguardian.api; bundle-symbolic-name="org.apiguardian"; bundle-version="1.0.0.v20190212-2109"; version="1.0.0"
              org.apiguardian [354]
                No resolution report for the bundle.  Unresolved requirement: Import-Package: org.junit.platform.commons.util; version="[1.4.0,2.0.0)"
    -> Export-Package: org.junit.platform.commons.util; bundle-symbolic-name="org.junit.platform.commons"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api,org.junit.platform.commons,org.junit.platform.commons.function"
  Unresolved requirement: Import-Package: org.junit.platform.engine; version="[1.4.0,2.0.0)"
    -> Export-Package: org.junit.platform.engine; bundle-symbolic-name="org.junit.platform.engine"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api,org.junit.platform.commons,org.junit.platform.commons.util,org.junit.platform.engine.reporting"
       org.junit.platform.engine [394]
         Unresolved requirement: Import-Package: org.junit.platform.commons.util; version="[1.4.0,2.0.0)"
           -> Export-Package: org.junit.platform.commons.util; bundle-symbolic-name="org.junit.platform.commons"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api,org.junit.platform.commons,org.junit.platform.commons.function"
         Unresolved requirement: Import-Package: org.opentest4j; version="[1.1.1,2.0.0)"
           -> Export-Package: org.opentest4j; bundle-symbolic-name="org.opentest4j"; bundle-version="1.1.1.v20190212-2109"; version="1.1.1"
              org.opentest4j [409]
                No resolution report for the bundle.         Unresolved requirement: Import-Package: org.apiguardian.api; version="[1.0.0,2.0.0)"
           -> Export-Package: org.apiguardian.api; bundle-symbolic-name="org.apiguardian"; bundle-version="1.0.0.v20190212-2109"; version="1.0.0"
         Unresolved requirement: Import-Package: org.junit.platform.commons.logging; version="[1.4.0,2.0.0)"
           -> Export-Package: org.junit.platform.commons.logging; bundle-symbolic-name="org.junit.platform.commons"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api"
         Unresolved requirement: Import-Package: org.junit.platform.commons; version="[1.4.0,2.0.0)"
           -> Export-Package: org.junit.platform.commons; bundle-symbolic-name="org.junit.platform.commons"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api"
         Unresolved requirement: Import-Package: org.junit.platform.commons.function; version="[1.4.0,2.0.0)"
           -> Export-Package: org.junit.platform.commons.function; bundle-symbolic-name="org.junit.platform.commons"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api"
  Unresolved requirement: Import-Package: org.junit.platform.commons.logging; version="[1.4.0,2.0.0)"
    -> Export-Package: org.junit.platform.commons.logging; bundle-symbolic-name="org.junit.platform.commons"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api"
  Unresolved requirement: Import-Package: org.junit.platform.engine.support.descriptor; version="[1.4.0,2.0.0)"
    -> Export-Package: org.junit.platform.engine.support.descriptor; bundle-symbolic-name="org.junit.platform.engine"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api,org.junit.platform.engine"
  Unresolved requirement: Import-Package: org.junit.platform.engine.reporting; version="[1.4.0,2.0.0)"
    -> Export-Package: org.junit.platform.engine.reporting; bundle-symbolic-name="org.junit.platform.engine"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api"
  Unresolved requirement: Import-Package: org.apiguardian.api; version="[1.0.0,2.0.0)"
    -> Export-Package: org.apiguardian.api; bundle-symbolic-name="org.apiguardian"; bundle-version="1.0.0.v20190212-2109"; version="1.0.0"

org.junit.platform.runner [396]
  Unresolved requirement: Import-Package: org.junit.platform.launcher.core; version="[1.4.0,2.0.0)"
    -> Export-Package: org.junit.platform.launcher.core; bundle-symbolic-name="org.junit.platform.launcher"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api,org.junit.platform.commons.util,org.junit.platform.engine,org.junit.platform.launcher"
       org.junit.platform.launcher [395]
         Unresolved requirement: Import-Package: org.junit.platform.commons; version="[1.4.0,2.0.0)"
           -> Export-Package: org.junit.platform.commons; bundle-symbolic-name="org.junit.platform.commons"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api"
              org.junit.platform.commons [393]
                Unresolved requirement: Import-Package: org.apiguardian.api; version="[1.0.0,2.0.0)"
                  -> Export-Package: org.apiguardian.api; bundle-symbolic-name="org.apiguardian"; bundle-version="1.0.0.v20190212-2109"; version="1.0.0"
                     org.apiguardian [354]
                       No resolution report for the bundle.         Unresolved requirement: Import-Package: org.junit.platform.commons.util; version="[1.4.0,2.0.0)"
           -> Export-Package: org.junit.platform.commons.util; bundle-symbolic-name="org.junit.platform.commons"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api,org.junit.platform.commons,org.junit.platform.commons.function"
         Unresolved requirement: Import-Package: org.junit.platform.engine; version="[1.4.0,2.0.0)"
           -> Export-Package: org.junit.platform.engine; bundle-symbolic-name="org.junit.platform.engine"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api,org.junit.platform.commons,org.junit.platform.commons.util,org.junit.platform.engine.reporting"
              org.junit.platform.engine [394]
                Unresolved requirement: Import-Package: org.junit.platform.commons.util; version="[1.4.0,2.0.0)"
                  -> Export-Package: org.junit.platform.commons.util; bundle-symbolic-name="org.junit.platform.commons"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api,org.junit.platform.commons,org.junit.platform.commons.function"
                Unresolved requirement: Import-Package: org.opentest4j; version="[1.1.1,2.0.0)"
                  -> Export-Package: org.opentest4j; bundle-symbolic-name="org.opentest4j"; bundle-version="1.1.1.v20190212-2109"; version="1.1.1"
                     org.opentest4j [409]
                       No resolution report for the bundle.                Unresolved requirement: Import-Package: org.apiguardian.api; version="[1.0.0,2.0.0)"
                  -> Export-Package: org.apiguardian.api; bundle-symbolic-name="org.apiguardian"; bundle-version="1.0.0.v20190212-2109"; version="1.0.0"
                Unresolved requirement: Import-Package: org.junit.platform.commons.logging; version="[1.4.0,2.0.0)"
                  -> Export-Package: org.junit.platform.commons.logging; bundle-symbolic-name="org.junit.platform.commons"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api"
                Unresolved requirement: Import-Package: org.junit.platform.commons; version="[1.4.0,2.0.0)"
                  -> Export-Package: org.junit.platform.commons; bundle-symbolic-name="org.junit.platform.commons"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api"
                Unresolved requirement: Import-Package: org.junit.platform.commons.function; version="[1.4.0,2.0.0)"
                  -> Export-Package: org.junit.platform.commons.function; bundle-symbolic-name="org.junit.platform.commons"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api"
         Unresolved requirement: Import-Package: org.junit.platform.commons.logging; version="[1.4.0,2.0.0)"
           -> Export-Package: org.junit.platform.commons.logging; bundle-symbolic-name="org.junit.platform.commons"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api"
         Unresolved requirement: Import-Package: org.junit.platform.engine.support.descriptor; version="[1.4.0,2.0.0)"
           -> Export-Package: org.junit.platform.engine.support.descriptor; bundle-symbolic-name="org.junit.platform.engine"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api,org.junit.platform.engine"
         Unresolved requirement: Import-Package: org.junit.platform.engine.reporting; version="[1.4.0,2.0.0)"
           -> Export-Package: org.junit.platform.engine.reporting; bundle-symbolic-name="org.junit.platform.engine"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api"
         Unresolved requirement: Import-Package: org.apiguardian.api; version="[1.0.0,2.0.0)"
           -> Export-Package: org.apiguardian.api; bundle-symbolic-name="org.apiguardian"; bundle-version="1.0.0.v20190212-2109"; version="1.0.0"
  Unresolved requirement: Import-Package: org.junit.platform.engine.discovery; version="[1.4.0,2.0.0)"
    -> Export-Package: org.junit.platform.engine.discovery; bundle-symbolic-name="org.junit.platform.engine"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api,org.junit.platform.commons.util,org.junit.platform.engine"
  Unresolved requirement: Import-Package: org.junit; version="[4.12.0,5.0.0)"
    -> Export-Package: org.junit; bundle-symbolic-name="org.junit"; bundle-version="4.12.0.v201504281640"; version="4.12.0"
       org.junit [388]
         Unresolved requirement: Require-Bundle: org.hamcrest.core; bundle-version="1.3.0"; visibility:="reexport"
           -> Bundle-SymbolicName: org.hamcrest.core; bundle-version="1.3.0.v20180420-1519"
              org.hamcrest.core [380]
                No resolution report for the bundle.  Unresolved requirement: Import-Package: org.junit.platform.engine.reporting; version="[1.4.0,2.0.0)"
    -> Export-Package: org.junit.platform.engine.reporting; bundle-symbolic-name="org.junit.platform.engine"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api"
  Unresolved requirement: Import-Package: org.junit.platform.commons.util; version="[1.4.0,2.0.0)"
    -> Export-Package: org.junit.platform.commons.util; bundle-symbolic-name="org.junit.platform.commons"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api,org.junit.platform.commons,org.junit.platform.commons.function"
  Unresolved requirement: Import-Package: org.junit.runner; version="[4.12.0,5.0.0)"
    -> Export-Package: org.junit.runner; bundle-symbolic-name="org.junit"; bundle-version="4.12.0.v201504281640"; version="4.12.0"
  Unresolved requirement: Import-Package: org.junit.platform.engine; version="[1.4.0,2.0.0)"
    -> Export-Package: org.junit.platform.engine; bundle-symbolic-name="org.junit.platform.engine"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api,org.junit.platform.commons,org.junit.platform.commons.util,org.junit.platform.engine.reporting"
  Unresolved requirement: Import-Package: org.junit.runner.manipulation; version="[4.12.0,5.0.0)"
    -> Export-Package: org.junit.runner.manipulation; bundle-symbolic-name="org.junit"; bundle-version="4.12.0.v201504281640"; version="4.12.0"
  Unresolved requirement: Import-Package: org.junit.rules; version="[4.12.0,5.0.0)"
    -> Export-Package: org.junit.rules; bundle-symbolic-name="org.junit"; bundle-version="4.12.0.v201504281640"; version="4.12.0"
  Unresolved requirement: Import-Package: org.junit.runners.model; version="[4.12.0,5.0.0)"
    -> Export-Package: org.junit.runners.model; bundle-symbolic-name="org.junit"; bundle-version="4.12.0.v201504281640"; version="4.12.0"
  Unresolved requirement: Import-Package: org.junit.runner.notification; version="[4.12.0,5.0.0)"
    -> Export-Package: org.junit.runner.notification; bundle-symbolic-name="org.junit"; bundle-version="4.12.0.v201504281640"; version="4.12.0"
  Unresolved requirement: Import-Package: org.apiguardian.api; version="[1.0.0,2.0.0)"
    -> Export-Package: org.apiguardian.api; bundle-symbolic-name="org.apiguardian"; bundle-version="1.0.0.v20190212-2109"; version="1.0.0"
  Unresolved requirement: Import-Package: org.junit.platform.engine.support.descriptor; version="[1.4.0,2.0.0)"
    -> Export-Package: org.junit.platform.engine.support.descriptor; bundle-symbolic-name="org.junit.platform.engine"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api,org.junit.platform.engine"
  Unresolved requirement: Import-Package: org.junit.platform.suite.api; version="[1.4.0,2.0.0)"
    -> Export-Package: org.junit.platform.suite.api; bundle-symbolic-name="org.junit.platform.suite.api"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api"
       org.junit.platform.suite.api [397]
         Unresolved requirement: Import-Package: org.apiguardian.api; version="[1.0.0,2.0.0)"
           -> Export-Package: org.apiguardian.api; bundle-symbolic-name="org.apiguardian"; bundle-version="1.0.0.v20190212-2109"; version="1.0.0"
  Unresolved requirement: Import-Package: org.junit.platform.launcher; version="[1.4.0,2.0.0)"
    -> Export-Package: org.junit.platform.launcher; bundle-symbolic-name="org.junit.platform.launcher"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api,org.junit.platform.commons.util,org.junit.platform.engine,org.junit.platform.engine.reporting"

org.junit.platform.suite.api [397]
  Unresolved requirement: Import-Package: org.apiguardian.api; version="[1.0.0,2.0.0)"
    -> Export-Package: org.apiguardian.api; bundle-symbolic-name="org.apiguardian"; bundle-version="1.0.0.v20190212-2109"; version="1.0.0"
       org.apiguardian [354]
         No resolution report for the bundle.
org.junit.vintage.engine [398]
  Unresolved requirement: Import-Package: org.junit.platform.commons; version="[1.4.0,2.0.0)"
    -> Export-Package: org.junit.platform.commons; bundle-symbolic-name="org.junit.platform.commons"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api"
       org.junit.platform.commons [393]
         Unresolved requirement: Import-Package: org.apiguardian.api; version="[1.0.0,2.0.0)"
           -> Export-Package: org.apiguardian.api; bundle-symbolic-name="org.apiguardian"; bundle-version="1.0.0.v20190212-2109"; version="1.0.0"
              org.apiguardian [354]
                No resolution report for the bundle.  Unresolved requirement: Import-Package: org.junit.runner; version="[4.12.0,5.0.0)"
    -> Export-Package: org.junit.runner; bundle-symbolic-name="org.junit"; bundle-version="4.12.0.v201504281640"; version="4.12.0"
       org.junit [388]
         Unresolved requirement: Require-Bundle: org.hamcrest.core; bundle-version="1.3.0"; visibility:="reexport"
           -> Bundle-SymbolicName: org.hamcrest.core; bundle-version="1.3.0.v20180420-1519"
              org.hamcrest.core [380]
                No resolution report for the bundle.  Unresolved requirement: Import-Package: org.junit.experimental.categories; version="[4.12.0,5.0.0)"
    -> Export-Package: org.junit.experimental.categories; bundle-symbolic-name="org.junit"; bundle-version="4.12.0.v201504281640"; version="4.12.0"
  Unresolved requirement: Import-Package: junit.runner; resolution:="optional"
    -> Export-Package: junit.runner; bundle-symbolic-name="org.junit"; bundle-version="4.12.0.v201504281640"; version="4.12.0"
  Unresolved requirement: Import-Package: org.junit.platform.commons.util; version="[1.4.0,2.0.0)"
    -> Export-Package: org.junit.platform.commons.util; bundle-symbolic-name="org.junit.platform.commons"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api,org.junit.platform.commons,org.junit.platform.commons.function"
  Unresolved requirement: Import-Package: org.junit.runners.model; version="[4.12.0,5.0.0)"
    -> Export-Package: org.junit.runners.model; bundle-symbolic-name="org.junit"; bundle-version="4.12.0.v201504281640"; version="4.12.0"
  Unresolved requirement: Import-Package: org.opentest4j; version="[1.1.1,2.0.0)"
    -> Export-Package: org.opentest4j; bundle-symbolic-name="org.opentest4j"; bundle-version="1.1.1.v20190212-2109"; version="1.1.1"
       org.opentest4j [409]
         No resolution report for the bundle.  Unresolved requirement: Import-Package: org.junit.platform.commons.function; version="[1.4.0,2.0.0)"
    -> Export-Package: org.junit.platform.commons.function; bundle-symbolic-name="org.junit.platform.commons"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api"
  Unresolved requirement: Import-Package: org.junit.platform.engine.support.descriptor; version="[1.4.0,2.0.0)"
    -> Export-Package: org.junit.platform.engine.support.descriptor; bundle-symbolic-name="org.junit.platform.engine"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api,org.junit.platform.engine"
       org.junit.platform.engine [394]
         Unresolved requirement: Import-Package: org.junit.platform.commons.util; version="[1.4.0,2.0.0)"
           -> Export-Package: org.junit.platform.commons.util; bundle-symbolic-name="org.junit.platform.commons"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api,org.junit.platform.commons,org.junit.platform.commons.function"
         Unresolved requirement: Import-Package: org.opentest4j; version="[1.1.1,2.0.0)"
           -> Export-Package: org.opentest4j; bundle-symbolic-name="org.opentest4j"; bundle-version="1.1.1.v20190212-2109"; version="1.1.1"
         Unresolved requirement: Import-Package: org.apiguardian.api; version="[1.0.0,2.0.0)"
           -> Export-Package: org.apiguardian.api; bundle-symbolic-name="org.apiguardian"; bundle-version="1.0.0.v20190212-2109"; version="1.0.0"
         Unresolved requirement: Import-Package: org.junit.platform.commons.logging; version="[1.4.0,2.0.0)"
           -> Export-Package: org.junit.platform.commons.logging; bundle-symbolic-name="org.junit.platform.commons"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api"
         Unresolved requirement: Import-Package: org.junit.platform.commons; version="[1.4.0,2.0.0)"
           -> Export-Package: org.junit.platform.commons; bundle-symbolic-name="org.junit.platform.commons"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api"
         Unresolved requirement: Import-Package: org.junit.platform.commons.function; version="[1.4.0,2.0.0)"
           -> Export-Package: org.junit.platform.commons.function; bundle-symbolic-name="org.junit.platform.commons"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api"
  Unresolved requirement: Import-Package: org.junit.platform.commons.logging; version="[1.4.0,2.0.0)"
    -> Export-Package: org.junit.platform.commons.logging; bundle-symbolic-name="org.junit.platform.commons"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api"
  Unresolved requirement: Import-Package: org.junit; version="[4.12.0,5.0.0)"
    -> Export-Package: org.junit; bundle-symbolic-name="org.junit"; bundle-version="4.12.0.v201504281640"; version="4.12.0"
  Unresolved requirement: Import-Package: org.junit.platform.engine.support.filter; version="[1.4.0,2.0.0)"
    -> Export-Package: org.junit.platform.engine.support.filter; bundle-symbolic-name="org.junit.platform.engine"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api,org.junit.platform.commons.util,org.junit.platform.engine"
  Unresolved requirement: Import-Package: org.junit.runner.manipulation; version="[4.12.0,5.0.0)"
    -> Export-Package: org.junit.runner.manipulation; bundle-symbolic-name="org.junit"; bundle-version="4.12.0.v201504281640"; version="4.12.0"
  Unresolved requirement: Import-Package: org.junit.runner.notification; version="[4.12.0,5.0.0)"
    -> Export-Package: org.junit.runner.notification; bundle-symbolic-name="org.junit"; bundle-version="4.12.0.v201504281640"; version="4.12.0"
  Unresolved requirement: Import-Package: org.junit.platform.engine.discovery; version="[1.4.0,2.0.0)"
    -> Export-Package: org.junit.platform.engine.discovery; bundle-symbolic-name="org.junit.platform.engine"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api,org.junit.platform.commons.util,org.junit.platform.engine"
  Unresolved requirement: Import-Package: org.junit.platform.engine; version="[1.4.0,2.0.0)"
    -> Export-Package: org.junit.platform.engine; bundle-symbolic-name="org.junit.platform.engine"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api,org.junit.platform.commons,org.junit.platform.commons.util,org.junit.platform.engine.reporting"
  Unresolved requirement: Import-Package: org.apiguardian.api; version="[1.0.0,2.0.0)"
    -> Export-Package: org.apiguardian.api; bundle-symbolic-name="org.apiguardian"; bundle-version="1.0.0.v20190212-2109"; version="1.0.0"
  Unresolved requirement: Import-Package: org.junit.internal.builders; version="[4.12.0,5.0.0)"
    -> Export-Package: org.junit.internal.builders; bundle-symbolic-name="org.junit"; bundle-version="4.12.0.v201504281640"; version="4.12.0"; x-internal:="true"

org.kohsuke.args4j [399]

org.mockito [400]
  Unresolved requirement: Import-Package: org.hamcrest; resolution:="optional"
  Unresolved requirement: Import-Package: net.bytebuddy.agent; version="[1.9.0,2.0.0)"
    -> Export-Package: net.bytebuddy.agent; bundle-symbolic-name="net.bytebuddy.byte-buddy-agent"; bundle-version="1.9.0.v20181106-1534"; version="1.9.0"
       net.bytebuddy.byte-buddy-agent [254]
         Unresolved requirement: Import-Package: org.newsclub.net.unix; resolution:="optional"
  Unresolved requirement: Import-Package: org.junit.runner.notification; resolution:="optional"
    -> Export-Package: org.junit.runner.notification; bundle-symbolic-name="org.junit"; bundle-version="4.12.0.v201504281640"; version="4.12.0"
       org.junit [388]
         Unresolved requirement: Require-Bundle: org.hamcrest.core; bundle-version="1.3.0"; visibility:="reexport"
           -> Bundle-SymbolicName: org.hamcrest.core; bundle-version="1.3.0.v20180420-1519"
              org.hamcrest.core [380]
                No resolution report for the bundle.  Unresolved requirement: Import-Package: net.bytebuddy.dynamic.loading; version="[1.9.0,2.0.0)"
    -> Export-Package: net.bytebuddy.dynamic.loading; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; uses:="net.bytebuddy.build,net.bytebuddy.description.type,net.bytebuddy.dynamic,net.bytebuddy.matcher,net.bytebuddy.utility"
       net.bytebuddy.byte-buddy [252]
  Unresolved requirement: Import-Package: net.bytebuddy.matcher; version="[1.9.0,2.0.0)"
    -> Export-Package: net.bytebuddy.matcher; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; uses:="net.bytebuddy.build,net.bytebuddy.description,net.bytebuddy.description.annotation,net.bytebuddy.description.field,net.bytebuddy.description.method,net.bytebuddy.description.type,net.bytebuddy.utility"
  Unresolved requirement: Import-Package: net.bytebuddy.description.field; version="[1.9.0,2.0.0)"
    -> Export-Package: net.bytebuddy.description.field; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; uses:="net.bytebuddy.build,net.bytebuddy.description,net.bytebuddy.description.annotation,net.bytebuddy.description.type,net.bytebuddy.matcher"
  Unresolved requirement: Import-Package: net.bytebuddy.description.method; version="[1.9.0,2.0.0)"
    -> Export-Package: net.bytebuddy.description.method; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; uses:="net.bytebuddy.build,net.bytebuddy.description,net.bytebuddy.description.annotation,net.bytebuddy.description.modifier,net.bytebuddy.description.type,net.bytebuddy.matcher"
  Unresolved requirement: Import-Package: net.bytebuddy.dynamic; version="[1.9.0,2.0.0)"
    -> Export-Package: net.bytebuddy.dynamic; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; uses:="net.bytebuddy,net.bytebuddy.asm,net.bytebuddy.build,net.bytebuddy.description,net.bytebuddy.description.annotation,net.bytebuddy.description.field,net.bytebuddy.description.method,net.bytebuddy.description.modifier,net.bytebuddy.description.type,net.bytebuddy.dynamic.loading,net.bytebuddy.dynamic.scaffold,net.bytebuddy.implementation,net.bytebuddy.implementation.attribute,net.bytebuddy.implementation.auxiliary,net.bytebuddy.implementation.bytecode,net.bytebuddy.jar.asm,net.bytebuddy.matcher,net.bytebuddy.pool,net.bytebuddy.utility"
  Unresolved requirement: Import-Package: org.objenesis; version="[2.6.0,3.0.0)"
    -> Export-Package: org.objenesis; bundle-symbolic-name="org.objenesis"; bundle-version="2.6.0.v20180420-1519"; version="2.6.0"; uses:="org.objenesis.instantiator,org.objenesis.strategy"
       org.objenesis [408]
         Unresolved requirement: Import-Package: sun.misc; resolution:="optional"
  Unresolved requirement: Import-Package: net.bytebuddy.jar.asm; version="[1.9.0,2.0.0)"
    -> Export-Package: net.bytebuddy.jar.asm; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"
  Unresolved requirement: Import-Package: org.junit.runner; resolution:="optional"
    -> Export-Package: org.junit.runner; bundle-symbolic-name="org.junit"; bundle-version="4.12.0.v201504281640"; version="4.12.0"
  Unresolved requirement: Import-Package: net.bytebuddy.utility; version="[1.9.0,2.0.0)"
    -> Export-Package: net.bytebuddy.utility; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; uses:="net.bytebuddy.build,net.bytebuddy.description,net.bytebuddy.description.enumeration,net.bytebuddy.description.field,net.bytebuddy.description.method,net.bytebuddy.description.type,net.bytebuddy.jar.asm"
  Unresolved requirement: Import-Package: junit.framework; resolution:="optional"
    -> Export-Package: junit.framework; bundle-symbolic-name="org.junit"; bundle-version="4.12.0.v201504281640"; version="4.12.0"
  Unresolved requirement: Import-Package: org.junit.rules; resolution:="optional"
    -> Export-Package: org.junit.rules; bundle-symbolic-name="org.junit"; bundle-version="4.12.0.v201504281640"; version="4.12.0"
  Unresolved requirement: Import-Package: net.bytebuddy.pool; version="[1.9.0,2.0.0)"
    -> Export-Package: net.bytebuddy.pool; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; uses:="net.bytebuddy.build,net.bytebuddy.description,net.bytebuddy.description.annotation,net.bytebuddy.description.enumeration,net.bytebuddy.description.field,net.bytebuddy.description.method,net.bytebuddy.description.type,net.bytebuddy.dynamic,net.bytebuddy.jar.asm,net.bytebuddy.jar.asm.signature"
  Unresolved requirement: Import-Package: net.bytebuddy.description.modifier; version="[1.9.0,2.0.0)"
    -> Export-Package: net.bytebuddy.description.modifier; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; uses:="net.bytebuddy.build"
  Unresolved requirement: Import-Package: net.bytebuddy; version="[1.9.0,2.0.0)"
    -> Export-Package: net.bytebuddy; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; uses:="net.bytebuddy.build,net.bytebuddy.description.method,net.bytebuddy.description.type,net.bytebuddy.dynamic,net.bytebuddy.dynamic.scaffold,net.bytebuddy.dynamic.scaffold.inline,net.bytebuddy.dynamic.scaffold.subclass,net.bytebuddy.implementation,net.bytebuddy.implementation.attribute,net.bytebuddy.implementation.auxiliary,net.bytebuddy.implementation.bytecode,net.bytebuddy.jar.asm,net.bytebuddy.matcher"
  Unresolved requirement: Import-Package: net.bytebuddy.implementation.bytecode.assign; version="[1.9.0,2.0.0)"
    -> Export-Package: net.bytebuddy.implementation.bytecode.assign; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; x-internal:="true"; uses:="net.bytebuddy.build,net.bytebuddy.description.type,net.bytebuddy.implementation,net.bytebuddy.implementation.bytecode,net.bytebuddy.jar.asm"
  Unresolved requirement: Import-Package: net.bytebuddy.implementation.bind.annotation; version="[1.9.0,2.0.0)"
    -> Export-Package: net.bytebuddy.implementation.bind.annotation; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; x-internal:="true"; uses:="net.bytebuddy,net.bytebuddy.build,net.bytebuddy.description.annotation,net.bytebuddy.description.field,net.bytebuddy.description.method,net.bytebuddy.description.type,net.bytebuddy.dynamic,net.bytebuddy.dynamic.scaffold,net.bytebuddy.implementation,net.bytebuddy.implementation.auxiliary,net.bytebuddy.implementation.bind,net.bytebuddy.implementation.bytecode,net.bytebuddy.implementation.bytecode.assign,net.bytebuddy.jar.asm"
  Unresolved requirement: Import-Package: org.junit; resolution:="optional"
    -> Export-Package: org.junit; bundle-symbolic-name="org.junit"; bundle-version="4.12.0.v201504281640"; version="4.12.0"
  Unresolved requirement: Import-Package: org.junit.runners; resolution:="optional"
    -> Export-Package: org.junit.runners; bundle-symbolic-name="org.junit"; bundle-version="4.12.0.v201504281640"; version="4.12.0"
  Unresolved requirement: Import-Package: net.bytebuddy.description; version="[1.9.0,2.0.0)"
    -> Export-Package: net.bytebuddy.description; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; uses:="net.bytebuddy.description.annotation,net.bytebuddy.description.method,net.bytebuddy.description.modifier,net.bytebuddy.description.type,net.bytebuddy.matcher"
  Unresolved requirement: Import-Package: net.bytebuddy.implementation.attribute; version="[1.9.0,2.0.0)"
    -> Export-Package: net.bytebuddy.implementation.attribute; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; x-internal:="true"; uses:="net.bytebuddy.build,net.bytebuddy.description.annotation,net.bytebuddy.description.field,net.bytebuddy.description.method,net.bytebuddy.description.type,net.bytebuddy.jar.asm"
  Unresolved requirement: Import-Package: org.junit.runners.model; resolution:="optional"
    -> Export-Package: org.junit.runners.model; bundle-symbolic-name="org.junit"; bundle-version="4.12.0.v201504281640"; version="4.12.0"
  Unresolved requirement: Import-Package: net.bytebuddy.asm; version="[1.9.0,2.0.0)"
    -> Export-Package: net.bytebuddy.asm; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; uses:="net.bytebuddy,net.bytebuddy.build,net.bytebuddy.description,net.bytebuddy.description.annotation,net.bytebuddy.description.enumeration,net.bytebuddy.description.field,net.bytebuddy.description.method,net.bytebuddy.description.modifier,net.bytebuddy.description.type,net.bytebuddy.dynamic,net.bytebuddy.dynamic.scaffold,net.bytebuddy.implementation,net.bytebuddy.implementation.bytecode,net.bytebuddy.implementation.bytecode.assign,net.bytebuddy.jar.asm,net.bytebuddy.matcher,net.bytebuddy.pool,net.bytebuddy.utility.visitor"
  Unresolved requirement: Import-Package: org.junit.runner.manipulation; resolution:="optional"
    -> Export-Package: org.junit.runner.manipulation; bundle-symbolic-name="org.junit"; bundle-version="4.12.0.v201504281640"; version="4.12.0"
  Unresolved requirement: Import-Package: net.bytebuddy.implementation; version="[1.9.0,2.0.0)"
    -> Export-Package: net.bytebuddy.implementation; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; x-internal:="true"; uses:="net.bytebuddy,net.bytebuddy.build,net.bytebuddy.description.annotation,net.bytebuddy.description.enumeration,net.bytebuddy.description.field,net.bytebuddy.description.method,net.bytebuddy.description.modifier,net.bytebuddy.description.type,net.bytebuddy.dynamic,net.bytebuddy.dynamic.scaffold,net.bytebuddy.implementation.attribute,net.bytebuddy.implementation.auxiliary,net.bytebuddy.implementation.bind,net.bytebuddy.implementation.bind.annotation,net.bytebuddy.implementation.bytecode,net.bytebuddy.implementation.bytecode.assign,net.bytebuddy.jar.asm,net.bytebuddy.matcher,net.bytebuddy.utility"
  Unresolved requirement: Import-Package: net.bytebuddy.description.type; version="[1.9.0,2.0.0)"
    -> Export-Package: net.bytebuddy.description.type; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; uses:="net.bytebuddy.build,net.bytebuddy.description,net.bytebuddy.description.annotation,net.bytebuddy.description.field,net.bytebuddy.description.method,net.bytebuddy.implementation.bytecode,net.bytebuddy.jar.asm.signature,net.bytebuddy.matcher"
  Unresolved requirement: Import-Package: net.bytebuddy.dynamic.scaffold; version="[1.9.0,2.0.0)"
    -> Export-Package: net.bytebuddy.dynamic.scaffold; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; uses:="net.bytebuddy,net.bytebuddy.asm,net.bytebuddy.build,net.bytebuddy.description.annotation,net.bytebuddy.description.field,net.bytebuddy.description.method,net.bytebuddy.description.modifier,net.bytebuddy.description.type,net.bytebuddy.dynamic,net.bytebuddy.dynamic.scaffold.inline,net.bytebuddy.implementation,net.bytebuddy.implementation.attribute,net.bytebuddy.implementation.auxiliary,net.bytebuddy.implementation.bytecode,net.bytebuddy.jar.asm,net.bytebuddy.jar.asm.commons,net.bytebuddy.matcher,net.bytebuddy.pool,net.bytebuddy.utility.visitor"

org.mockito [401]
  Unresolved requirement: Import-Package: org.hamcrest; resolution:="optional"
  Unresolved requirement: Import-Package: net.bytebuddy.description; version="[1.7.9,2.0.0)"
    -> Export-Package: net.bytebuddy.description; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; uses:="net.bytebuddy.description.annotation,net.bytebuddy.description.method,net.bytebuddy.description.modifier,net.bytebuddy.description.type,net.bytebuddy.matcher"
       net.bytebuddy.byte-buddy [252]
  Unresolved requirement: Import-Package: org.mockito.internal.stubbing.answers; version="[2.13.0,3.0.0)"; resolution:="optional"
    -> Export-Package: org.mockito.internal.stubbing.answers; bundle-symbolic-name="org.mockito"; bundle-version="2.23.0.v20181106-1534"; version="2.23.0"; x-internal:="true"; uses:="org.mockito.internal.invocation,org.mockito.invocation,org.mockito.stubbing"
       org.mockito [400]
         Unresolved requirement: Import-Package: org.hamcrest; resolution:="optional"
         Unresolved requirement: Import-Package: net.bytebuddy.agent; version="[1.9.0,2.0.0)"
           -> Export-Package: net.bytebuddy.agent; bundle-symbolic-name="net.bytebuddy.byte-buddy-agent"; bundle-version="1.9.0.v20181106-1534"; version="1.9.0"
              net.bytebuddy.byte-buddy-agent [254]
                Unresolved requirement: Import-Package: org.newsclub.net.unix; resolution:="optional"
         Unresolved requirement: Import-Package: org.junit.runner.notification; resolution:="optional"
           -> Export-Package: org.junit.runner.notification; bundle-symbolic-name="org.junit"; bundle-version="4.12.0.v201504281640"; version="4.12.0"
              org.junit [388]
                Unresolved requirement: Require-Bundle: org.hamcrest.core; bundle-version="1.3.0"; visibility:="reexport"
                  -> Bundle-SymbolicName: org.hamcrest.core; bundle-version="1.3.0.v20180420-1519"
                     org.hamcrest.core [380]
                       No resolution report for the bundle.         Unresolved requirement: Import-Package: net.bytebuddy.dynamic.loading; version="[1.9.0,2.0.0)"
           -> Export-Package: net.bytebuddy.dynamic.loading; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; uses:="net.bytebuddy.build,net.bytebuddy.description.type,net.bytebuddy.dynamic,net.bytebuddy.matcher,net.bytebuddy.utility"
         Unresolved requirement: Import-Package: net.bytebuddy.matcher; version="[1.9.0,2.0.0)"
           -> Export-Package: net.bytebuddy.matcher; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; uses:="net.bytebuddy.build,net.bytebuddy.description,net.bytebuddy.description.annotation,net.bytebuddy.description.field,net.bytebuddy.description.method,net.bytebuddy.description.type,net.bytebuddy.utility"
         Unresolved requirement: Import-Package: net.bytebuddy.description.field; version="[1.9.0,2.0.0)"
           -> Export-Package: net.bytebuddy.description.field; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; uses:="net.bytebuddy.build,net.bytebuddy.description,net.bytebuddy.description.annotation,net.bytebuddy.description.type,net.bytebuddy.matcher"
         Unresolved requirement: Import-Package: net.bytebuddy.description.method; version="[1.9.0,2.0.0)"
           -> Export-Package: net.bytebuddy.description.method; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; uses:="net.bytebuddy.build,net.bytebuddy.description,net.bytebuddy.description.annotation,net.bytebuddy.description.modifier,net.bytebuddy.description.type,net.bytebuddy.matcher"
         Unresolved requirement: Import-Package: net.bytebuddy.dynamic; version="[1.9.0,2.0.0)"
           -> Export-Package: net.bytebuddy.dynamic; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; uses:="net.bytebuddy,net.bytebuddy.asm,net.bytebuddy.build,net.bytebuddy.description,net.bytebuddy.description.annotation,net.bytebuddy.description.field,net.bytebuddy.description.method,net.bytebuddy.description.modifier,net.bytebuddy.description.type,net.bytebuddy.dynamic.loading,net.bytebuddy.dynamic.scaffold,net.bytebuddy.implementation,net.bytebuddy.implementation.attribute,net.bytebuddy.implementation.auxiliary,net.bytebuddy.implementation.bytecode,net.bytebuddy.jar.asm,net.bytebuddy.matcher,net.bytebuddy.pool,net.bytebuddy.utility"
         Unresolved requirement: Import-Package: org.objenesis; version="[2.6.0,3.0.0)"
           -> Export-Package: org.objenesis; bundle-symbolic-name="org.objenesis"; bundle-version="2.6.0.v20180420-1519"; version="2.6.0"; uses:="org.objenesis.instantiator,org.objenesis.strategy"
              org.objenesis [408]
                Unresolved requirement: Import-Package: sun.misc; resolution:="optional"
         Unresolved requirement: Import-Package: net.bytebuddy.jar.asm; version="[1.9.0,2.0.0)"
           -> Export-Package: net.bytebuddy.jar.asm; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"
         Unresolved requirement: Import-Package: org.junit.runner; resolution:="optional"
           -> Export-Package: org.junit.runner; bundle-symbolic-name="org.junit"; bundle-version="4.12.0.v201504281640"; version="4.12.0"
         Unresolved requirement: Import-Package: net.bytebuddy.utility; version="[1.9.0,2.0.0)"
           -> Export-Package: net.bytebuddy.utility; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; uses:="net.bytebuddy.build,net.bytebuddy.description,net.bytebuddy.description.enumeration,net.bytebuddy.description.field,net.bytebuddy.description.method,net.bytebuddy.description.type,net.bytebuddy.jar.asm"
         Unresolved requirement: Import-Package: junit.framework; resolution:="optional"
           -> Export-Package: junit.framework; bundle-symbolic-name="org.junit"; bundle-version="4.12.0.v201504281640"; version="4.12.0"
         Unresolved requirement: Import-Package: org.junit.rules; resolution:="optional"
           -> Export-Package: org.junit.rules; bundle-symbolic-name="org.junit"; bundle-version="4.12.0.v201504281640"; version="4.12.0"
         Unresolved requirement: Import-Package: net.bytebuddy.pool; version="[1.9.0,2.0.0)"
           -> Export-Package: net.bytebuddy.pool; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; uses:="net.bytebuddy.build,net.bytebuddy.description,net.bytebuddy.description.annotation,net.bytebuddy.description.enumeration,net.bytebuddy.description.field,net.bytebuddy.description.method,net.bytebuddy.description.type,net.bytebuddy.dynamic,net.bytebuddy.jar.asm,net.bytebuddy.jar.asm.signature"
         Unresolved requirement: Import-Package: net.bytebuddy.description.modifier; version="[1.9.0,2.0.0)"
           -> Export-Package: net.bytebuddy.description.modifier; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; uses:="net.bytebuddy.build"
         Unresolved requirement: Import-Package: net.bytebuddy; version="[1.9.0,2.0.0)"
           -> Export-Package: net.bytebuddy; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; uses:="net.bytebuddy.build,net.bytebuddy.description.method,net.bytebuddy.description.type,net.bytebuddy.dynamic,net.bytebuddy.dynamic.scaffold,net.bytebuddy.dynamic.scaffold.inline,net.bytebuddy.dynamic.scaffold.subclass,net.bytebuddy.implementation,net.bytebuddy.implementation.attribute,net.bytebuddy.implementation.auxiliary,net.bytebuddy.implementation.bytecode,net.bytebuddy.jar.asm,net.bytebuddy.matcher"
         Unresolved requirement: Import-Package: net.bytebuddy.implementation.bytecode.assign; version="[1.9.0,2.0.0)"
           -> Export-Package: net.bytebuddy.implementation.bytecode.assign; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; x-internal:="true"; uses:="net.bytebuddy.build,net.bytebuddy.description.type,net.bytebuddy.implementation,net.bytebuddy.implementation.bytecode,net.bytebuddy.jar.asm"
         Unresolved requirement: Import-Package: net.bytebuddy.implementation.bind.annotation; version="[1.9.0,2.0.0)"
           -> Export-Package: net.bytebuddy.implementation.bind.annotation; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; x-internal:="true"; uses:="net.bytebuddy,net.bytebuddy.build,net.bytebuddy.description.annotation,net.bytebuddy.description.field,net.bytebuddy.description.method,net.bytebuddy.description.type,net.bytebuddy.dynamic,net.bytebuddy.dynamic.scaffold,net.bytebuddy.implementation,net.bytebuddy.implementation.auxiliary,net.bytebuddy.implementation.bind,net.bytebuddy.implementation.bytecode,net.bytebuddy.implementation.bytecode.assign,net.bytebuddy.jar.asm"
         Unresolved requirement: Import-Package: org.junit; resolution:="optional"
           -> Export-Package: org.junit; bundle-symbolic-name="org.junit"; bundle-version="4.12.0.v201504281640"; version="4.12.0"
         Unresolved requirement: Import-Package: org.junit.runners; resolution:="optional"
           -> Export-Package: org.junit.runners; bundle-symbolic-name="org.junit"; bundle-version="4.12.0.v201504281640"; version="4.12.0"
         Unresolved requirement: Import-Package: net.bytebuddy.description; version="[1.9.0,2.0.0)"
           -> Export-Package: net.bytebuddy.description; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; uses:="net.bytebuddy.description.annotation,net.bytebuddy.description.method,net.bytebuddy.description.modifier,net.bytebuddy.description.type,net.bytebuddy.matcher"
         Unresolved requirement: Import-Package: net.bytebuddy.implementation.attribute; version="[1.9.0,2.0.0)"
           -> Export-Package: net.bytebuddy.implementation.attribute; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; x-internal:="true"; uses:="net.bytebuddy.build,net.bytebuddy.description.annotation,net.bytebuddy.description.field,net.bytebuddy.description.method,net.bytebuddy.description.type,net.bytebuddy.jar.asm"
         Unresolved requirement: Import-Package: org.junit.runners.model; resolution:="optional"
           -> Export-Package: org.junit.runners.model; bundle-symbolic-name="org.junit"; bundle-version="4.12.0.v201504281640"; version="4.12.0"
         Unresolved requirement: Import-Package: net.bytebuddy.asm; version="[1.9.0,2.0.0)"
           -> Export-Package: net.bytebuddy.asm; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; uses:="net.bytebuddy,net.bytebuddy.build,net.bytebuddy.description,net.bytebuddy.description.annotation,net.bytebuddy.description.enumeration,net.bytebuddy.description.field,net.bytebuddy.description.method,net.bytebuddy.description.modifier,net.bytebuddy.description.type,net.bytebuddy.dynamic,net.bytebuddy.dynamic.scaffold,net.bytebuddy.implementation,net.bytebuddy.implementation.bytecode,net.bytebuddy.implementation.bytecode.assign,net.bytebuddy.jar.asm,net.bytebuddy.matcher,net.bytebuddy.pool,net.bytebuddy.utility.visitor"
         Unresolved requirement: Import-Package: org.junit.runner.manipulation; resolution:="optional"
           -> Export-Package: org.junit.runner.manipulation; bundle-symbolic-name="org.junit"; bundle-version="4.12.0.v201504281640"; version="4.12.0"
         Unresolved requirement: Import-Package: net.bytebuddy.implementation; version="[1.9.0,2.0.0)"
           -> Export-Package: net.bytebuddy.implementation; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; x-internal:="true"; uses:="net.bytebuddy,net.bytebuddy.build,net.bytebuddy.description.annotation,net.bytebuddy.description.enumeration,net.bytebuddy.description.field,net.bytebuddy.description.method,net.bytebuddy.description.modifier,net.bytebuddy.description.type,net.bytebuddy.dynamic,net.bytebuddy.dynamic.scaffold,net.bytebuddy.implementation.attribute,net.bytebuddy.implementation.auxiliary,net.bytebuddy.implementation.bind,net.bytebuddy.implementation.bind.annotation,net.bytebuddy.implementation.bytecode,net.bytebuddy.implementation.bytecode.assign,net.bytebuddy.jar.asm,net.bytebuddy.matcher,net.bytebuddy.utility"
         Unresolved requirement: Import-Package: net.bytebuddy.description.type; version="[1.9.0,2.0.0)"
           -> Export-Package: net.bytebuddy.description.type; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; uses:="net.bytebuddy.build,net.bytebuddy.description,net.bytebuddy.description.annotation,net.bytebuddy.description.field,net.bytebuddy.description.method,net.bytebuddy.implementation.bytecode,net.bytebuddy.jar.asm.signature,net.bytebuddy.matcher"
         Unresolved requirement: Import-Package: net.bytebuddy.dynamic.scaffold; version="[1.9.0,2.0.0)"
           -> Export-Package: net.bytebuddy.dynamic.scaffold; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; uses:="net.bytebuddy,net.bytebuddy.asm,net.bytebuddy.build,net.bytebuddy.description.annotation,net.bytebuddy.description.field,net.bytebuddy.description.method,net.bytebuddy.description.modifier,net.bytebuddy.description.type,net.bytebuddy.dynamic,net.bytebuddy.dynamic.scaffold.inline,net.bytebuddy.implementation,net.bytebuddy.implementation.attribute,net.bytebuddy.implementation.auxiliary,net.bytebuddy.implementation.bytecode,net.bytebuddy.jar.asm,net.bytebuddy.jar.asm.commons,net.bytebuddy.matcher,net.bytebuddy.pool,net.bytebuddy.utility.visitor"
  Unresolved requirement: Import-Package: org.mockito.configuration; version="[2.13.0,3.0.0)"; resolution:="optional"
    -> Export-Package: org.mockito.configuration; bundle-symbolic-name="org.mockito"; bundle-version="2.23.0.v20181106-1534"; version="2.23.0"; uses:="org.mockito.plugins,org.mockito.stubbing"
  Unresolved requirement: Import-Package: org.junit.runner.notification; resolution:="optional"
    -> Export-Package: org.junit.runner.notification; bundle-symbolic-name="org.junit"; bundle-version="4.12.0.v201504281640"; version="4.12.0"
  Unresolved requirement: Import-Package: org.mockito.listeners; version="[2.13.0,3.0.0)"; resolution:="optional"
    -> Export-Package: org.mockito.listeners; bundle-symbolic-name="org.mockito"; bundle-version="2.23.0.v20181106-1534"; version="2.23.0"; uses:="org.mockito,org.mockito.invocation,org.mockito.mock,org.mockito.verification"
  Unresolved requirement: Import-Package: net.bytebuddy.description.field; version="[1.7.9,2.0.0)"
    -> Export-Package: net.bytebuddy.description.field; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; uses:="net.bytebuddy.build,net.bytebuddy.description,net.bytebuddy.description.annotation,net.bytebuddy.description.type,net.bytebuddy.matcher"
  Unresolved requirement: Import-Package: net.bytebuddy.implementation.bind.annotation; version="[1.7.9,2.0.0)"
    -> Export-Package: net.bytebuddy.implementation.bind.annotation; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; x-internal:="true"; uses:="net.bytebuddy,net.bytebuddy.build,net.bytebuddy.description.annotation,net.bytebuddy.description.field,net.bytebuddy.description.method,net.bytebuddy.description.type,net.bytebuddy.dynamic,net.bytebuddy.dynamic.scaffold,net.bytebuddy.implementation,net.bytebuddy.implementation.auxiliary,net.bytebuddy.implementation.bind,net.bytebuddy.implementation.bytecode,net.bytebuddy.implementation.bytecode.assign,net.bytebuddy.jar.asm"
  Unresolved requirement: Import-Package: org.mockito.internal.progress; version="[2.13.0,3.0.0)"; resolution:="optional"
    -> Export-Package: org.mockito.internal.progress; bundle-symbolic-name="org.mockito"; bundle-version="2.23.0.v20181106-1534"; version="2.23.0"; x-internal:="true"; uses:="org.mockito,org.mockito.internal.matchers,org.mockito.listeners,org.mockito.mock,org.mockito.stubbing,org.mockito.verification"
  Unresolved requirement: Import-Package: org.mockito.internal.util; version="[2.13.0,3.0.0)"; resolution:="optional"
    -> Export-Package: org.mockito.internal.util; bundle-symbolic-name="org.mockito"; bundle-version="2.23.0.v20181106-1534"; version="2.23.0"; x-internal:="true"; uses:="org.mockito,org.mockito.internal.stubbing,org.mockito.invocation,org.mockito.mock,org.mockito.plugins,org.mockito.stubbing"
  Unresolved requirement: Import-Package: net.bytebuddy.pool; version="[1.7.9,2.0.0)"
    -> Export-Package: net.bytebuddy.pool; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.7.9.v20180420-1519"; version="1.7.9"; uses:="net.bytebuddy.description,net.bytebuddy.description.annotation,net.bytebuddy.description.enumeration,net.bytebuddy.description.field,net.bytebuddy.description.method,net.bytebuddy.description.type,net.bytebuddy.dynamic,net.bytebuddy.jar.asm,net.bytebuddy.jar.asm.signature"
       net.bytebuddy.byte-buddy [253]
         Unresolved requirement: Import-Package: net.bytebuddy.jar.asm.tree; resolution:="optional"
         Unresolved requirement: Import-Package: net.bytebuddy.dynamic.scaffold.inline; version="[1.7.0,2.0.0)"; resolution:="optional"
           -> Export-Package: net.bytebuddy.dynamic.scaffold.inline; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; uses:="net.bytebuddy,net.bytebuddy.asm,net.bytebuddy.build,net.bytebuddy.description.annotation,net.bytebuddy.description.field,net.bytebuddy.description.method,net.bytebuddy.description.modifier,net.bytebuddy.description.type,net.bytebuddy.dynamic,net.bytebuddy.dynamic.scaffold,net.bytebuddy.implementation,net.bytebuddy.implementation.attribute,net.bytebuddy.implementation.auxiliary,net.bytebuddy.implementation.bytecode,net.bytebuddy.jar.asm,net.bytebuddy.matcher,net.bytebuddy.pool"
         Unresolved requirement: Import-Package: net.bytebuddy; version="[1.7.0,2.0.0)"; resolution:="optional"
           -> Export-Package: net.bytebuddy; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; uses:="net.bytebuddy.build,net.bytebuddy.description.method,net.bytebuddy.description.type,net.bytebuddy.dynamic,net.bytebuddy.dynamic.scaffold,net.bytebuddy.dynamic.scaffold.inline,net.bytebuddy.dynamic.scaffold.subclass,net.bytebuddy.implementation,net.bytebuddy.implementation.attribute,net.bytebuddy.implementation.auxiliary,net.bytebuddy.implementation.bytecode,net.bytebuddy.jar.asm,net.bytebuddy.matcher"
         Unresolved requirement: Import-Package: net.bytebuddy.implementation.bind.annotation; version="[1.7.0,2.0.0)"; resolution:="optional"
           -> Export-Package: net.bytebuddy.implementation.bind.annotation; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; x-internal:="true"; uses:="net.bytebuddy,net.bytebuddy.build,net.bytebuddy.description.annotation,net.bytebuddy.description.field,net.bytebuddy.description.method,net.bytebuddy.description.type,net.bytebuddy.dynamic,net.bytebuddy.dynamic.scaffold,net.bytebuddy.implementation,net.bytebuddy.implementation.auxiliary,net.bytebuddy.implementation.bind,net.bytebuddy.implementation.bytecode,net.bytebuddy.implementation.bytecode.assign,net.bytebuddy.jar.asm"
         Unresolved requirement: Import-Package: net.bytebuddy.description; version="[1.7.0,2.0.0)"; resolution:="optional"
           -> Export-Package: net.bytebuddy.description; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; uses:="net.bytebuddy.description.annotation,net.bytebuddy.description.method,net.bytebuddy.description.modifier,net.bytebuddy.description.type,net.bytebuddy.matcher"
         Unresolved requirement: Import-Package: net.bytebuddy.implementation.attribute; version="[1.7.0,2.0.0)"; resolution:="optional"
           -> Export-Package: net.bytebuddy.implementation.attribute; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; x-internal:="true"; uses:="net.bytebuddy.build,net.bytebuddy.description.annotation,net.bytebuddy.description.field,net.bytebuddy.description.method,net.bytebuddy.description.type,net.bytebuddy.jar.asm"
         Unresolved requirement: Import-Package: net.bytebuddy.implementation.bytecode.member; version="[1.7.0,2.0.0)"; resolution:="optional"
           -> Export-Package: net.bytebuddy.implementation.bytecode.member; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; x-internal:="true"; uses:="net.bytebuddy.build,net.bytebuddy.description.enumeration,net.bytebuddy.description.field,net.bytebuddy.description.method,net.bytebuddy.description.type,net.bytebuddy.implementation,net.bytebuddy.implementation.bytecode,net.bytebuddy.jar.asm,net.bytebuddy.utility"
         Unresolved requirement: Import-Package: net.bytebuddy.implementation.bind; version="[1.7.0,2.0.0)"; resolution:="optional"
           -> Export-Package: net.bytebuddy.implementation.bind; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; x-internal:="true"; uses:="net.bytebuddy.build,net.bytebuddy.description.method,net.bytebuddy.description.type,net.bytebuddy.implementation,net.bytebuddy.implementation.bytecode,net.bytebuddy.implementation.bytecode.assign,net.bytebuddy.jar.asm"
         Unresolved requirement: Import-Package: net.bytebuddy.implementation.bytecode.assign.reference; version="[1.7.0,2.0.0)"; resolution:="optional"
           -> Export-Package: net.bytebuddy.implementation.bytecode.assign.reference; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; x-internal:="true"; uses:="net.bytebuddy.description.type,net.bytebuddy.implementation.bytecode,net.bytebuddy.implementation.bytecode.assign"
         Unresolved requirement: Import-Package: net.bytebuddy.description.annotation; version="[1.7.0,2.0.0)"; resolution:="optional"
           -> Export-Package: net.bytebuddy.description.annotation; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; uses:="net.bytebuddy.build,net.bytebuddy.description.enumeration,net.bytebuddy.description.method,net.bytebuddy.description.type,net.bytebuddy.matcher"
         Unresolved requirement: Import-Package: net.bytebuddy.dynamic.scaffold.subclass; version="[1.7.0,2.0.0)"; resolution:="optional"
           -> Export-Package: net.bytebuddy.dynamic.scaffold.subclass; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; uses:="net.bytebuddy,net.bytebuddy.asm,net.bytebuddy.build,net.bytebuddy.description.method,net.bytebuddy.description.type,net.bytebuddy.dynamic,net.bytebuddy.dynamic.scaffold,net.bytebuddy.implementation,net.bytebuddy.implementation.attribute,net.bytebuddy.implementation.auxiliary,net.bytebuddy.matcher,net.bytebuddy.pool"
         Unresolved requirement: Import-Package: net.bytebuddy.asm; version="[1.7.0,2.0.0)"; resolution:="optional"
           -> Export-Package: net.bytebuddy.asm; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; uses:="net.bytebuddy,net.bytebuddy.build,net.bytebuddy.description,net.bytebuddy.description.annotation,net.bytebuddy.description.enumeration,net.bytebuddy.description.field,net.bytebuddy.description.method,net.bytebuddy.description.modifier,net.bytebuddy.description.type,net.bytebuddy.dynamic,net.bytebuddy.dynamic.scaffold,net.bytebuddy.implementation,net.bytebuddy.implementation.bytecode,net.bytebuddy.implementation.bytecode.assign,net.bytebuddy.jar.asm,net.bytebuddy.matcher,net.bytebuddy.pool,net.bytebuddy.utility.visitor"
         Unresolved requirement: Import-Package: net.bytebuddy.implementation.bytecode.constant; version="[1.7.0,2.0.0)"; resolution:="optional"
           -> Export-Package: net.bytebuddy.implementation.bytecode.constant; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; x-internal:="true"; uses:="net.bytebuddy.build,net.bytebuddy.description.field,net.bytebuddy.description.method,net.bytebuddy.description.type,net.bytebuddy.implementation,net.bytebuddy.implementation.bytecode,net.bytebuddy.jar.asm,net.bytebuddy.utility"
         Unresolved requirement: Import-Package: net.bytebuddy.description.method; version="[1.7.0,2.0.0)"; resolution:="optional"
           -> Export-Package: net.bytebuddy.description.method; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; uses:="net.bytebuddy.build,net.bytebuddy.description,net.bytebuddy.description.annotation,net.bytebuddy.description.modifier,net.bytebuddy.description.type,net.bytebuddy.matcher"
         Unresolved requirement: Import-Package: net.bytebuddy.implementation; version="[1.7.0,2.0.0)"; resolution:="optional"
           -> Export-Package: net.bytebuddy.implementation; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; x-internal:="true"; uses:="net.bytebuddy,net.bytebuddy.build,net.bytebuddy.description.annotation,net.bytebuddy.description.enumeration,net.bytebuddy.description.field,net.bytebuddy.description.method,net.bytebuddy.description.modifier,net.bytebuddy.description.type,net.bytebuddy.dynamic,net.bytebuddy.dynamic.scaffold,net.bytebuddy.implementation.attribute,net.bytebuddy.implementation.auxiliary,net.bytebuddy.implementation.bind,net.bytebuddy.implementation.bind.annotation,net.bytebuddy.implementation.bytecode,net.bytebuddy.implementation.bytecode.assign,net.bytebuddy.jar.asm,net.bytebuddy.matcher,net.bytebuddy.utility"
         Unresolved requirement: Import-Package: net.bytebuddy.jar.asm.commons; version="[1.7.0,2.0.0)"; resolution:="optional"
           -> Export-Package: net.bytebuddy.jar.asm.commons; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; uses:="net.bytebuddy.jar.asm,net.bytebuddy.jar.asm.signature"
         Unresolved requirement: Import-Package: net.bytebuddy.dynamic; version="[1.7.0,2.0.0)"; resolution:="optional"
           -> Export-Package: net.bytebuddy.dynamic; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; uses:="net.bytebuddy,net.bytebuddy.asm,net.bytebuddy.build,net.bytebuddy.description,net.bytebuddy.description.annotation,net.bytebuddy.description.field,net.bytebuddy.description.method,net.bytebuddy.description.modifier,net.bytebuddy.description.type,net.bytebuddy.dynamic.loading,net.bytebuddy.dynamic.scaffold,net.bytebuddy.implementation,net.bytebuddy.implementation.attribute,net.bytebuddy.implementation.auxiliary,net.bytebuddy.implementation.bytecode,net.bytebuddy.jar.asm,net.bytebuddy.matcher,net.bytebuddy.pool,net.bytebuddy.utility"
         Unresolved requirement: Import-Package: net.bytebuddy.utility.privilege; version="[1.7.0,2.0.0)"; resolution:="optional"
           -> Export-Package: net.bytebuddy.utility.privilege; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; uses:="net.bytebuddy.build"
         Unresolved requirement: Import-Package: net.bytebuddy.utility.visitor; version="[1.7.0,2.0.0)"; resolution:="optional"
           -> Export-Package: net.bytebuddy.utility.visitor; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; uses:="net.bytebuddy.description.method,net.bytebuddy.implementation.bytecode,net.bytebuddy.jar.asm"
         Unresolved requirement: Import-Package: net.bytebuddy.implementation.bytecode; version="[1.7.0,2.0.0)"; resolution:="optional"
           -> Export-Package: net.bytebuddy.implementation.bytecode; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; x-internal:="true"; uses:="net.bytebuddy.build,net.bytebuddy.description.method,net.bytebuddy.description.type,net.bytebuddy.implementation,net.bytebuddy.jar.asm"
         Unresolved requirement: Import-Package: net.bytebuddy.jar.asm.signature; version="[1.7.0,2.0.0)"; resolution:="optional"
           -> Export-Package: net.bytebuddy.jar.asm.signature; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"
         Unresolved requirement: Import-Package: net.bytebuddy.jar.asm; version="[1.7.0,2.0.0)"; resolution:="optional"
           -> Export-Package: net.bytebuddy.jar.asm; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"
         Unresolved requirement: Import-Package: net.bytebuddy.description.field; version="[1.7.0,2.0.0)"; resolution:="optional"
           -> Export-Package: net.bytebuddy.description.field; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; uses:="net.bytebuddy.build,net.bytebuddy.description,net.bytebuddy.description.annotation,net.bytebuddy.description.type,net.bytebuddy.matcher"
  Unresolved requirement: Import-Package: org.mockito.exceptions.verification.junit; version="[2.13.0,3.0.0)"; resolution:="optional"
    -> Export-Package: org.mockito.exceptions.verification.junit; bundle-symbolic-name="org.mockito"; bundle-version="2.23.0.v20181106-1534"; version="2.23.0"; uses:="junit.framework"
  Unresolved requirement: Import-Package: org.mockito.internal.creation.settings; version="[2.13.0,3.0.0)"; resolution:="optional"
    -> Export-Package: org.mockito.internal.creation.settings; bundle-symbolic-name="org.mockito"; bundle-version="2.23.0.v20181106-1534"; version="2.23.0"; x-internal:="true"; uses:="org.mockito.internal.listeners,org.mockito.listeners,org.mockito.mock,org.mockito.stubbing"
  Unresolved requirement: Import-Package: org.junit; resolution:="optional"
    -> Export-Package: org.junit; bundle-symbolic-name="org.junit"; bundle-version="4.12.0.v201504281640"; version="4.12.0"
  Unresolved requirement: Import-Package: org.mockito.internal.configuration.injection.filter; version="[2.13.0,3.0.0)"; resolution:="optional"
    -> Export-Package: org.mockito.internal.configuration.injection.filter; bundle-symbolic-name="org.mockito"; bundle-version="2.23.0.v20181106-1534"; version="2.23.0"; x-internal:="true"
  Unresolved requirement: Import-Package: net.bytebuddy.asm; version="[1.7.9,2.0.0)"
    -> Export-Package: net.bytebuddy.asm; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; uses:="net.bytebuddy,net.bytebuddy.build,net.bytebuddy.description,net.bytebuddy.description.annotation,net.bytebuddy.description.enumeration,net.bytebuddy.description.field,net.bytebuddy.description.method,net.bytebuddy.description.modifier,net.bytebuddy.description.type,net.bytebuddy.dynamic,net.bytebuddy.dynamic.scaffold,net.bytebuddy.implementation,net.bytebuddy.implementation.bytecode,net.bytebuddy.implementation.bytecode.assign,net.bytebuddy.jar.asm,net.bytebuddy.matcher,net.bytebuddy.pool,net.bytebuddy.utility.visitor"
  Unresolved requirement: Import-Package: net.bytebuddy.dynamic; version="[1.7.9,2.0.0)"
    -> Export-Package: net.bytebuddy.dynamic; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; uses:="net.bytebuddy,net.bytebuddy.asm,net.bytebuddy.build,net.bytebuddy.description,net.bytebuddy.description.annotation,net.bytebuddy.description.field,net.bytebuddy.description.method,net.bytebuddy.description.modifier,net.bytebuddy.description.type,net.bytebuddy.dynamic.loading,net.bytebuddy.dynamic.scaffold,net.bytebuddy.implementation,net.bytebuddy.implementation.attribute,net.bytebuddy.implementation.auxiliary,net.bytebuddy.implementation.bytecode,net.bytebuddy.jar.asm,net.bytebuddy.matcher,net.bytebuddy.pool,net.bytebuddy.utility"
  Unresolved requirement: Import-Package: org.mockito.internal.framework; version="[2.13.0,3.0.0)"; resolution:="optional"
    -> Export-Package: org.mockito.internal.framework; bundle-symbolic-name="org.mockito"; bundle-version="2.23.0.v20181106-1534"; version="2.23.0"; x-internal:="true"; uses:="org.mockito,org.mockito.internal.util,org.mockito.invocation,org.mockito.listeners,org.mockito.plugins,org.mockito.quality"
  Unresolved requirement: Import-Package: org.mockito.internal.junit.util; version="[2.13.0,3.0.0)"; resolution:="optional"
    -> Export-Package: org.mockito.internal.junit.util; bundle-symbolic-name="org.mockito"; bundle-version="2.23.0.v20181106-1534"; version="2.23.0"; x-internal:="true"; uses:="org.junit.runner.notification"
  Unresolved requirement: Import-Package: org.mockito.internal.verification.api; version="[2.13.0,3.0.0)"; resolution:="optional"
    -> Export-Package: org.mockito.internal.verification.api; bundle-symbolic-name="org.mockito"; bundle-version="2.23.0.v20181106-1534"; version="2.23.0"; x-internal:="true"; uses:="org.mockito.internal.invocation,org.mockito.invocation"
  Unresolved requirement: Import-Package: org.mockito.stubbing; version="[2.13.0,3.0.0)"; resolution:="optional"
    -> Export-Package: org.mockito.stubbing; bundle-symbolic-name="org.mockito"; bundle-version="2.23.0.v20181106-1534"; version="2.23.0"; uses:="org.mockito,org.mockito.invocation,org.mockito.quality"
  Unresolved requirement: Import-Package: org.mockito.internal.verification.argumentmatching; version="[2.13.0,3.0.0)"; resolution:="optional"
    -> Export-Package: org.mockito.internal.verification.argumentmatching; bundle-symbolic-name="org.mockito"; bundle-version="2.23.0.v20181106-1534"; version="2.23.0"; x-internal:="true"; uses:="org.mockito"
  Unresolved requirement: Import-Package: org.junit.runners; resolution:="optional"
    -> Export-Package: org.junit.runners; bundle-symbolic-name="org.junit"; bundle-version="4.12.0.v201504281640"; version="4.12.0"
  Unresolved requirement: Import-Package: org.mockito.invocation; version="[2.13.0,3.0.0)"; resolution:="optional"
    -> Export-Package: org.mockito.invocation; bundle-symbolic-name="org.mockito"; bundle-version="2.23.0.v20181106-1534"; version="2.23.0"; uses:="org.mockito,org.mockito.mock"
  Unresolved requirement: Import-Package: org.mockito.verification; version="[2.13.0,3.0.0)"; resolution:="optional"
    -> Export-Package: org.mockito.verification; bundle-symbolic-name="org.mockito"; bundle-version="2.23.0.v20181106-1534"; version="2.23.0"; uses:="org.mockito,org.mockito.internal.verification,org.mockito.internal.verification.api"
  Unresolved requirement: Import-Package: net.bytebuddy.description.modifier; version="[1.7.9,2.0.0)"
    -> Export-Package: net.bytebuddy.description.modifier; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.7.9.v20180420-1519"; version="1.7.9"
  Unresolved requirement: Import-Package: junit.framework; resolution:="optional"
    -> Export-Package: junit.framework; bundle-symbolic-name="org.junit"; bundle-version="4.12.0.v201504281640"; version="4.12.0"
  Unresolved requirement: Import-Package: net.bytebuddy; version="[1.7.9,2.0.0)"
    -> Export-Package: net.bytebuddy; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; uses:="net.bytebuddy.build,net.bytebuddy.description.method,net.bytebuddy.description.type,net.bytebuddy.dynamic,net.bytebuddy.dynamic.scaffold,net.bytebuddy.dynamic.scaffold.inline,net.bytebuddy.dynamic.scaffold.subclass,net.bytebuddy.implementation,net.bytebuddy.implementation.attribute,net.bytebuddy.implementation.auxiliary,net.bytebuddy.implementation.bytecode,net.bytebuddy.jar.asm,net.bytebuddy.matcher"
  Unresolved requirement: Import-Package: net.bytebuddy.dynamic.scaffold; version="[1.7.9,2.0.0)"
    -> Export-Package: net.bytebuddy.dynamic.scaffold; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.7.9.v20180420-1519"; version="1.7.9"; uses:="net.bytebuddy,net.bytebuddy.asm,net.bytebuddy.description.annotation,net.bytebuddy.description.field,net.bytebuddy.description.method,net.bytebuddy.description.modifier,net.bytebuddy.description.type,net.bytebuddy.dynamic,net.bytebuddy.dynamic.scaffold.inline,net.bytebuddy.implementation,net.bytebuddy.implementation.attribute,net.bytebuddy.implementation.auxiliary,net.bytebuddy.implementation.bytecode,net.bytebuddy.jar.asm,net.bytebuddy.matcher,net.bytebuddy.pool"
  Unresolved requirement: Import-Package: org.mockito.internal.stubbing; version="[2.13.0,3.0.0)"; resolution:="optional"
    -> Export-Package: org.mockito.internal.stubbing; bundle-symbolic-name="org.mockito"; bundle-version="2.23.0.v20181106-1534"; version="2.23.0"; x-internal:="true"; uses:="org.mockito.internal.invocation,org.mockito.invocation,org.mockito.mock,org.mockito.quality,org.mockito.stubbing"
  Unresolved requirement: Import-Package: net.bytebuddy.dynamic.loading; version="[1.7.9,2.0.0)"
    -> Export-Package: net.bytebuddy.dynamic.loading; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.7.9.v20180420-1519"; version="1.7.9"; uses:="net.bytebuddy.description.type,net.bytebuddy.dynamic,net.bytebuddy.matcher,net.bytebuddy.utility"
  Unresolved requirement: Import-Package: org.mockito.internal.verification; version="[2.13.0,3.0.0)"; resolution:="optional"
    -> Export-Package: org.mockito.internal.verification; bundle-symbolic-name="org.mockito"; bundle-version="2.23.0.v20181106-1534"; version="2.23.0"; x-internal:="true"; uses:="org.mockito.internal,org.mockito.internal.invocation,org.mockito.internal.stubbing,org.mockito.internal.util,org.mockito.internal.verification.api,org.mockito.invocation,org.mockito.listeners,org.mockito.verification"
  Unresolved requirement: Import-Package: org.mockito.exceptions.base; version="[2.13.0,3.0.0)"; resolution:="optional"
    -> Export-Package: org.mockito.exceptions.base; bundle-symbolic-name="org.mockito"; bundle-version="2.23.0.v20181106-1534"; version="2.23.0"
  Unresolved requirement: Import-Package: org.mockito.internal.util.concurrent; version="[2.13.0,3.0.0)"; resolution:="optional"
    -> Export-Package: org.mockito.internal.util.concurrent; bundle-symbolic-name="org.mockito"; bundle-version="2.23.0.v20181106-1534"; version="2.23.0"; x-internal:="true"
  Unresolved requirement: Import-Package: net.bytebuddy.jar.asm; version="[1.7.9,2.0.0)"
    -> Export-Package: net.bytebuddy.jar.asm; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"
  Unresolved requirement: Import-Package: net.bytebuddy.utility; version="[1.7.9,2.0.0)"
    -> Export-Package: net.bytebuddy.utility; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.7.9.v20180420-1519"; version="1.7.9"; uses:="net.bytebuddy.description,net.bytebuddy.description.field,net.bytebuddy.description.method,net.bytebuddy.description.type,net.bytebuddy.implementation.bytecode"
  Unresolved requirement: Import-Package: org.mockito.internal.configuration.plugins; version="[2.13.0,3.0.0)"; resolution:="optional"
    -> Export-Package: org.mockito.internal.configuration.plugins; bundle-symbolic-name="org.mockito"; bundle-version="2.23.0.v20181106-1534"; version="2.23.0"; x-internal:="true"; uses:="org.mockito.plugins"
  Unresolved requirement: Import-Package: org.mockito.internal.configuration.injection; version="[2.13.0,3.0.0)"; resolution:="optional"
    -> Export-Package: org.mockito.internal.configuration.injection; bundle-symbolic-name="org.mockito"; bundle-version="2.23.0.v20181106-1534"; version="2.23.0"; x-internal:="true"
  Unresolved requirement: Import-Package: net.bytebuddy.matcher; version="[1.7.9,2.0.0)"
    -> Export-Package: net.bytebuddy.matcher; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.7.9.v20180420-1519"; version="1.7.9"; uses:="net.bytebuddy.description,net.bytebuddy.description.annotation,net.bytebuddy.description.field,net.bytebuddy.description.method,net.bytebuddy.description.type,net.bytebuddy.utility"
  Unresolved requirement: Import-Package: org.mockito.internal.runners; version="[2.13.0,3.0.0)"; resolution:="optional"
    -> Export-Package: org.mockito.internal.runners; bundle-symbolic-name="org.mockito"; bundle-version="2.23.0.v20181106-1534"; version="2.23.0"; x-internal:="true"; uses:="org.junit.runner,org.junit.runner.manipulation,org.junit.runner.notification,org.junit.runners.model,org.mockito.internal.junit,org.mockito.internal.util"
  Unresolved requirement: Import-Package: net.bytebuddy.implementation.attribute; version="[1.7.9,2.0.0)"
    -> Export-Package: net.bytebuddy.implementation.attribute; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; x-internal:="true"; uses:="net.bytebuddy.build,net.bytebuddy.description.annotation,net.bytebuddy.description.field,net.bytebuddy.description.method,net.bytebuddy.description.type,net.bytebuddy.jar.asm"
  Unresolved requirement: Import-Package: org.mockito; version="[2.13.0,3.0.0)"; resolution:="optional"
    -> Export-Package: org.mockito; bundle-symbolic-name="org.mockito"; bundle-version="2.23.0.v20181106-1534"; version="2.23.0"; uses:="org.mockito.exceptions.misusing,org.mockito.invocation,org.mockito.listeners,org.mockito.mock,org.mockito.plugins,org.mockito.quality,org.mockito.session,org.mockito.stubbing,org.mockito.verification"
  Unresolved requirement: Import-Package: org.mockito.internal.configuration.injection.scanner; version="[2.13.0,3.0.0)"; resolution:="optional"
    -> Export-Package: org.mockito.internal.configuration.injection.scanner; bundle-symbolic-name="org.mockito"; bundle-version="2.23.0.v20181106-1534"; version="2.23.0"; x-internal:="true"
  Unresolved requirement: Import-Package: org.mockito.exceptions.stacktrace; version="[2.13.0,3.0.0)"; resolution:="optional"
    -> Export-Package: org.mockito.exceptions.stacktrace; bundle-symbolic-name="org.mockito"; bundle-version="2.23.0.v20181106-1534"; version="2.23.0"
  Unresolved requirement: Import-Package: org.mockito.internal.util.collections; version="[2.13.0,3.0.0)"; resolution:="optional"
    -> Export-Package: org.mockito.internal.util.collections; bundle-symbolic-name="org.mockito"; bundle-version="2.23.0.v20181106-1534"; version="2.23.0"; x-internal:="true"
  Unresolved requirement: Import-Package: org.objenesis; version="[2.6.0,3.0.0)"
    -> Export-Package: org.objenesis; bundle-symbolic-name="org.objenesis"; bundle-version="2.6.0.v20180420-1519"; version="2.6.0"; uses:="org.objenesis.instantiator,org.objenesis.strategy"
  Unresolved requirement: Import-Package: org.mockito.internal.debugging; version="[2.13.0,3.0.0)"; resolution:="optional"
    -> Export-Package: org.mockito.internal.debugging; bundle-symbolic-name="org.mockito"; bundle-version="2.23.0.v20181106-1534"; version="2.23.0"; x-internal:="true"; uses:="org.mockito,org.mockito.internal.exceptions.stacktrace,org.mockito.internal.invocation,org.mockito.invocation,org.mockito.listeners"
  Unresolved requirement: Import-Package: org.mockito.internal.matchers.apachecommons; version="[2.13.0,3.0.0)"; resolution:="optional"
    -> Export-Package: org.mockito.internal.matchers.apachecommons; bundle-symbolic-name="org.mockito"; bundle-version="2.23.0.v20181106-1534"; version="2.23.0"; x-internal:="true"; uses:="org.mockito"
  Unresolved requirement: Import-Package: org.mockito.internal.hamcrest; version="[2.13.0,3.0.0)"; resolution:="optional"
    -> Export-Package: org.mockito.internal.hamcrest; bundle-symbolic-name="org.mockito"; bundle-version="2.23.0.v20181106-1534"; version="2.23.0"; x-internal:="true"; uses:="org.hamcrest,org.mockito"
  Unresolved requirement: Import-Package: net.bytebuddy.implementation; version="[1.7.9,2.0.0)"
    -> Export-Package: net.bytebuddy.implementation; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; x-internal:="true"; uses:="net.bytebuddy,net.bytebuddy.build,net.bytebuddy.description.annotation,net.bytebuddy.description.enumeration,net.bytebuddy.description.field,net.bytebuddy.description.method,net.bytebuddy.description.modifier,net.bytebuddy.description.type,net.bytebuddy.dynamic,net.bytebuddy.dynamic.scaffold,net.bytebuddy.implementation.attribute,net.bytebuddy.implementation.auxiliary,net.bytebuddy.implementation.bind,net.bytebuddy.implementation.bind.annotation,net.bytebuddy.implementation.bytecode,net.bytebuddy.implementation.bytecode.assign,net.bytebuddy.jar.asm,net.bytebuddy.matcher,net.bytebuddy.utility"
  Unresolved requirement: Import-Package: org.mockito.exceptions.misusing; version="[2.13.0,3.0.0)"; resolution:="optional"
    -> Export-Package: org.mockito.exceptions.misusing; bundle-symbolic-name="org.mockito"; bundle-version="2.23.0.v20181106-1534"; version="2.23.0"; uses:="org.mockito.exceptions.base"
  Unresolved requirement: Import-Package: net.bytebuddy.description.type; version="[1.7.9,2.0.0)"
    -> Export-Package: net.bytebuddy.description.type; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.7.9.v20180420-1519"; version="1.7.9"; uses:="net.bytebuddy.description,net.bytebuddy.description.annotation,net.bytebuddy.description.field,net.bytebuddy.description.method,net.bytebuddy.implementation.bytecode,net.bytebuddy.jar.asm.signature,net.bytebuddy.matcher"
  Unresolved requirement: Import-Package: org.mockito.internal.exceptions.stacktrace; version="[2.13.0,3.0.0)"; resolution:="optional"
    -> Export-Package: org.mockito.internal.exceptions.stacktrace; bundle-symbolic-name="org.mockito"; bundle-version="2.23.0.v20181106-1534"; version="2.23.0"; x-internal:="true"; uses:="org.mockito.exceptions.stacktrace,org.mockito.plugins"
  Unresolved requirement: Import-Package: org.mockito.internal.reporting; version="[2.13.0,3.0.0)"; resolution:="optional"
    -> Export-Package: org.mockito.internal.reporting; bundle-symbolic-name="org.mockito"; bundle-version="2.23.0.v20181106-1534"; version="2.23.0"; x-internal:="true"; uses:="org.mockito,org.mockito.invocation"
  Unresolved requirement: Import-Package: net.bytebuddy.agent; version="[1.7.9,2.0.0)"
    -> Export-Package: net.bytebuddy.agent; bundle-symbolic-name="net.bytebuddy.byte-buddy-agent"; bundle-version="1.9.0.v20181106-1534"; version="1.9.0"
  Unresolved requirement: Import-Package: org.junit.rules; resolution:="optional"
    -> Export-Package: org.junit.rules; bundle-symbolic-name="org.junit"; bundle-version="4.12.0.v201504281640"; version="4.12.0"
  Unresolved requirement: Import-Package: org.mockito.internal.runners.util; version="[2.13.0,3.0.0)"; resolution:="optional"
    -> Export-Package: org.mockito.internal.runners.util; bundle-symbolic-name="org.mockito"; bundle-version="2.23.0.v20181106-1534"; version="2.23.0"; x-internal:="true"; uses:="org.junit.runner.notification,org.mockito.internal.runners"
  Unresolved requirement: Import-Package: org.mockito.internal.verification.checkers; version="[2.13.0,3.0.0)"; resolution:="optional"
    -> Export-Package: org.mockito.internal.verification.checkers; bundle-symbolic-name="org.mockito"; bundle-version="2.23.0.v20181106-1534"; version="2.23.0"; x-internal:="true"; uses:="org.mockito.internal.reporting,org.mockito.internal.verification.api,org.mockito.invocation"
  Unresolved requirement: Import-Package: org.mockito.quality; version="[2.13.0,3.0.0)"; resolution:="optional"
    -> Export-Package: org.mockito.quality; bundle-symbolic-name="org.mockito"; bundle-version="2.23.0.v20181106-1534"; version="2.23.0"; uses:="org.mockito"
  Unresolved requirement: Import-Package: net.bytebuddy.implementation.bytecode.assign; version="[1.7.9,2.0.0)"
    -> Export-Package: net.bytebuddy.implementation.bytecode.assign; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.7.9.v20180420-1519"; version="1.7.9"; x-internal:="true"; uses:="net.bytebuddy.description.type,net.bytebuddy.implementation,net.bytebuddy.implementation.bytecode,net.bytebuddy.jar.asm"
  Unresolved requirement: Import-Package: org.mockito.internal.session; version="[2.13.0,3.0.0)"; resolution:="optional"
    -> Export-Package: org.mockito.internal.session; bundle-symbolic-name="org.mockito"; bundle-version="2.23.0.v20181106-1534"; version="2.23.0"; x-internal:="true"; uses:="org.mockito,org.mockito.internal.util,org.mockito.quality,org.mockito.session"
  Unresolved requirement: Import-Package: org.junit.runner; resolution:="optional"
    -> Export-Package: org.junit.runner; bundle-symbolic-name="org.junit"; bundle-version="4.12.0.v201504281640"; version="4.12.0"
  Unresolved requirement: Import-Package: org.junit.runner.manipulation; resolution:="optional"
    -> Export-Package: org.junit.runner.manipulation; bundle-symbolic-name="org.junit"; bundle-version="4.12.0.v201504281640"; version="4.12.0"
  Unresolved requirement: Import-Package: org.mockito.internal.exceptions; version="[2.13.0,3.0.0)"; resolution:="optional"
    -> Export-Package: org.mockito.internal.exceptions; bundle-symbolic-name="org.mockito"; bundle-version="2.23.0.v20181106-1534"; version="2.23.0"; x-internal:="true"; uses:="org.mockito.exceptions.base,org.mockito.exceptions.misusing,org.mockito.exceptions.verification,org.mockito.internal.matchers,org.mockito.internal.reporting,org.mockito.invocation,org.mockito.listeners,org.mockito.mock"
  Unresolved requirement: Import-Package: net.bytebuddy.description.method; version="[1.7.9,2.0.0)"
    -> Export-Package: net.bytebuddy.description.method; bundle-symbolic-name="net.bytebuddy.byte-buddy"; bundle-version="1.9.0.v20181107-1410"; version="1.9.0"; uses:="net.bytebuddy.build,net.bytebuddy.description,net.bytebuddy.description.annotation,net.bytebuddy.description.modifier,net.bytebuddy.description.type,net.bytebuddy.matcher"
  Unresolved requirement: Import-Package: org.junit.runners.model; resolution:="optional"
    -> Export-Package: org.junit.runners.model; bundle-symbolic-name="org.junit"; bundle-version="4.12.0.v201504281640"; version="4.12.0"
  Unresolved requirement: Import-Package: org.mockito.internal.stubbing.defaultanswers; version="[2.13.0,3.0.0)"; resolution:="optional"
    -> Export-Package: org.mockito.internal.stubbing.defaultanswers; bundle-symbolic-name="org.mockito"; bundle-version="2.23.0.v20181106-1534"; version="2.23.0"; x-internal:="true"; uses:="org.mockito.internal.util.reflection,org.mockito.invocation,org.mockito.stubbing"
  Unresolved requirement: Import-Package: org.mockito.exceptions.verification; version="[2.13.0,3.0.0)"; resolution:="optional"
    -> Export-Package: org.mockito.exceptions.verification; bundle-symbolic-name="org.mockito"; bundle-version="2.23.0.v20181106-1534"; version="2.23.0"; uses:="org.mockito.exceptions.base"

org.mozilla.javascript [402]
  No resolution report for the bundle.
org.objectweb.asm [403]
  No resolution report for the bundle.
org.objectweb.asm.analysis [404]
  Unresolved requirement: Import-Package: org.objectweb.asm; version="[7.1.0,7.2.0)"
    -> Export-Package: org.objectweb.asm; bundle-symbolic-name="org.objectweb.asm"; bundle-version="7.1.0.v20190412-2143"; version="7.1.0"
       org.objectweb.asm [403]
         No resolution report for the bundle.  Unresolved requirement: Import-Package: org.objectweb.asm.tree; version="[7.1.0,7.2.0)"
    -> Export-Package: org.objectweb.asm.tree; bundle-symbolic-name="org.objectweb.asm.tree"; bundle-version="7.1.0.v20190412-2143"; version="7.1.0"; uses:="org.objectweb.asm"
       org.objectweb.asm.tree [406]
         Unresolved requirement: Import-Package: org.objectweb.asm; version="[7.1.0,7.2.0)"
           -> Export-Package: org.objectweb.asm; bundle-symbolic-name="org.objectweb.asm"; bundle-version="7.1.0.v20190412-2143"; version="7.1.0"

org.objectweb.asm.commons [405]
  Unresolved requirement: Import-Package: org.objectweb.asm; version="[7.1.0,7.2.0)"
    -> Export-Package: org.objectweb.asm; bundle-symbolic-name="org.objectweb.asm"; bundle-version="7.1.0.v20190412-2143"; version="7.1.0"
       org.objectweb.asm [403]
         No resolution report for the bundle.  Unresolved requirement: Import-Package: org.objectweb.asm.signature; version="[7.1.0,7.2.0)"
    -> Export-Package: org.objectweb.asm.signature; bundle-symbolic-name="org.objectweb.asm"; bundle-version="7.1.0.v20190412-2143"; version="7.1.0"
  Unresolved requirement: Import-Package: org.objectweb.asm.tree; version="[7.1.0,7.2.0)"
    -> Export-Package: org.objectweb.asm.tree; bundle-symbolic-name="org.objectweb.asm.tree"; bundle-version="7.1.0.v20190412-2143"; version="7.1.0"; uses:="org.objectweb.asm"
       org.objectweb.asm.tree [406]
         Unresolved requirement: Import-Package: org.objectweb.asm; version="[7.1.0,7.2.0)"
           -> Export-Package: org.objectweb.asm; bundle-symbolic-name="org.objectweb.asm"; bundle-version="7.1.0.v20190412-2143"; version="7.1.0"

org.objectweb.asm.tree [406]
  Unresolved requirement: Import-Package: org.objectweb.asm; version="[7.1.0,7.2.0)"
    -> Export-Package: org.objectweb.asm; bundle-symbolic-name="org.objectweb.asm"; bundle-version="7.1.0.v20190412-2143"; version="7.1.0"
       org.objectweb.asm [403]
         No resolution report for the bundle.
org.objectweb.asm.util [407]
  Unresolved requirement: Import-Package: org.objectweb.asm.tree.analysis; version="[7.1.0,7.2.0)"
    -> Export-Package: org.objectweb.asm.tree.analysis; bundle-symbolic-name="org.objectweb.asm.analysis"; bundle-version="7.1.0.v20190412-2143"; version="7.1.0"; uses:="org.objectweb.asm,org.objectweb.asm.tree"
       org.objectweb.asm.analysis [404]
         Unresolved requirement: Import-Package: org.objectweb.asm; version="[7.1.0,7.2.0)"
           -> Export-Package: org.objectweb.asm; bundle-symbolic-name="org.objectweb.asm"; bundle-version="7.1.0.v20190412-2143"; version="7.1.0"
              org.objectweb.asm [403]
                No resolution report for the bundle.         Unresolved requirement: Import-Package: org.objectweb.asm.tree; version="[7.1.0,7.2.0)"
           -> Export-Package: org.objectweb.asm.tree; bundle-symbolic-name="org.objectweb.asm.tree"; bundle-version="7.1.0.v20190412-2143"; version="7.1.0"; uses:="org.objectweb.asm"
              org.objectweb.asm.tree [406]
                Unresolved requirement: Import-Package: org.objectweb.asm; version="[7.1.0,7.2.0)"
                  -> Export-Package: org.objectweb.asm; bundle-symbolic-name="org.objectweb.asm"; bundle-version="7.1.0.v20190412-2143"; version="7.1.0"
  Unresolved requirement: Import-Package: org.objectweb.asm; version="[7.1.0,7.2.0)"
    -> Export-Package: org.objectweb.asm; bundle-symbolic-name="org.objectweb.asm"; bundle-version="7.1.0.v20190412-2143"; version="7.1.0"
  Unresolved requirement: Import-Package: org.objectweb.asm.tree; version="[7.1.0,7.2.0)"
    -> Export-Package: org.objectweb.asm.tree; bundle-symbolic-name="org.objectweb.asm.tree"; bundle-version="7.1.0.v20190412-2143"; version="7.1.0"; uses:="org.objectweb.asm"
  Unresolved requirement: Import-Package: org.objectweb.asm.signature; version="[7.1.0,7.2.0)"
    -> Export-Package: org.objectweb.asm.signature; bundle-symbolic-name="org.objectweb.asm"; bundle-version="7.1.0.v20190412-2143"; version="7.1.0"

org.objenesis [408]
  Unresolved requirement: Import-Package: sun.misc; resolution:="optional"

org.opentest4j [409]
  No resolution report for the bundle.
org.reactivestreams [410]
  No resolution report for the bundle.
org.slf4j.api [411]

org.slf4j.apis.jcl [412]
  Unresolved requirement: Import-Package: org.slf4j; version="[1.7.10,1.8.0)"
    -> Export-Package: org.slf4j; bundle-symbolic-name="org.slf4j.api"; bundle-version="1.7.10.v20170428-1633"; version="1.7.10"; uses:="org.slf4j.spi"
       org.slf4j.api [411]
  Unresolved requirement: Import-Package: org.slf4j.spi; version="[1.7.10,1.8.0)"
    -> Export-Package: org.slf4j.spi; bundle-symbolic-name="org.slf4j.api"; bundle-version="1.7.10.v20170428-1633"; version="1.7.10"; uses:="org.slf4j"

org.slf4j.apis.log4j [413]
  Unresolved requirement: Import-Package: org.slf4j.helpers; version="[1.7.10,1.8.0)"
    -> Export-Package: org.slf4j.helpers; bundle-symbolic-name="org.slf4j.api"; bundle-version="1.7.10.v20170428-1633"; version="1.7.10"; uses:="org.slf4j,org.slf4j.spi"
       org.slf4j.api [411]
  Unresolved requirement: Import-Package: org.slf4j.spi; version="[1.7.10,1.8.0)"
    -> Export-Package: org.slf4j.spi; bundle-symbolic-name="org.slf4j.api"; bundle-version="1.7.10.v20170428-1633"; version="1.7.10"; uses:="org.slf4j"
  Unresolved requirement: Import-Package: org.slf4j; version="[1.7.10,1.8.0)"
    -> Export-Package: org.slf4j; bundle-symbolic-name="org.slf4j.api"; bundle-version="1.7.10.v20170428-1633"; version="1.7.10"; uses:="org.slf4j.spi"

org.slf4j.binding.nop [414]
  Unresolved requirement: Import-Package: org.slf4j; version="[1.7.10,1.8.0)"
    -> Export-Package: org.slf4j; bundle-symbolic-name="org.slf4j.api"; bundle-version="1.7.10.v20170428-1633"; version="1.7.10"; uses:="org.slf4j.spi"
       org.slf4j.api [411]
  Unresolved requirement: Import-Package: org.slf4j.spi; version="[1.7.10,1.8.0)"
    -> Export-Package: org.slf4j.spi; bundle-symbolic-name="org.slf4j.api"; bundle-version="1.7.10.v20170428-1633"; version="1.7.10"; uses:="org.slf4j"
  Unresolved requirement: Import-Package: org.slf4j.helpers; version="[1.7.10,1.8.0)"
    -> Export-Package: org.slf4j.helpers; bundle-symbolic-name="org.slf4j.api"; bundle-version="1.7.10.v20170428-1633"; version="1.7.10"; uses:="org.slf4j,org.slf4j.spi"
  Unresolved requirement: Fragment-Host: org.slf4j.api; bundle-version="[1.7.10,1.8.0)"
    -> Bundle-SymbolicName: org.slf4j.api; bundle-version="1.7.10.v20170428-1633"

org.slf4j.binding.simple [415]
  Unresolved requirement: Import-Package: org.slf4j.spi; version="[1.7.10,1.8.0)"
    -> Export-Package: org.slf4j.spi; bundle-symbolic-name="org.slf4j.api"; bundle-version="1.7.10.v20170428-1633"; version="1.7.10"; uses:="org.slf4j"
       org.slf4j.api [411]
  Unresolved requirement: Import-Package: org.slf4j.helpers; version="[1.7.10,1.8.0)"
    -> Export-Package: org.slf4j.helpers; bundle-symbolic-name="org.slf4j.api"; bundle-version="1.7.10.v20170428-1633"; version="1.7.10"; uses:="org.slf4j,org.slf4j.spi"
  Unresolved requirement: Import-Package: org.slf4j; version="[1.7.10,1.8.0)"
    -> Export-Package: org.slf4j; bundle-symbolic-name="org.slf4j.api"; bundle-version="1.7.10.v20170428-1633"; version="1.7.10"; uses:="org.slf4j.spi"
  Unresolved requirement: Fragment-Host: org.slf4j.api; bundle-version="[1.7.10,1.8.0)"
    -> Bundle-SymbolicName: org.slf4j.api; bundle-version="1.7.10.v20170428-1633"

org.slf4j.bridge.jul [416]
  Unresolved requirement: Import-Package: org.slf4j; version="[1.7.10,1.8.0)"
    -> Export-Package: org.slf4j; bundle-symbolic-name="org.slf4j.api"; bundle-version="1.7.10.v20170428-1633"; version="1.7.10"; uses:="org.slf4j.spi"
       org.slf4j.api [411]
  Unresolved requirement: Import-Package: org.slf4j.spi; version="[1.7.10,1.8.0)"
    -> Export-Package: org.slf4j.spi; bundle-symbolic-name="org.slf4j.api"; bundle-version="1.7.10.v20170428-1633"; version="1.7.10"; uses:="org.slf4j"

org.slf4j.ext [417]
  Unresolved requirement: Import-Package: ch.qos.cal10n; resolution:="optional"
  Unresolved requirement: Import-Package: org.apache.commons.lang.text; resolution:="optional"
  Unresolved requirement: Import-Package: javassist; resolution:="optional"
    -> Export-Package: javassist; bundle-symbolic-name="javassist"; bundle-version="3.13.0.GA_v201209210905"; version="3.13.0.GA"; uses:="javassist.bytecode,javassist.bytecode.annotation,javassist.compiler,javassist.compiler.ast,javassist.expr"
       javassist [241]
         No resolution report for the bundle.  Unresolved requirement: Import-Package: javassist.bytecode; resolution:="optional"
    -> Export-Package: javassist.bytecode; bundle-symbolic-name="javassist"; bundle-version="3.13.0.GA_v201209210905"; version="3.13.0.GA"; uses:="javassist,javassist.bytecode.annotation"
  Unresolved requirement: Require-Bundle: org.slf4j.api; bundle-version="[1.7.10,1.8.0)"
    -> Bundle-SymbolicName: org.slf4j.api; bundle-version="1.7.10.v20170428-1633"
       org.slf4j.api [411]

org.slf4j.jcl [418]
  Unresolved requirement: Import-Package: org.slf4j; version="[1.7.2,1.8.0)"
    -> Export-Package: org.slf4j; bundle-symbolic-name="org.slf4j.api"; bundle-version="1.7.10.v20170428-1633"; version="1.7.10"; uses:="org.slf4j.spi"
       org.slf4j.api [411]
  Unresolved requirement: Import-Package: org.slf4j.spi; version="[1.7.2,1.8.0)"
    -> Export-Package: org.slf4j.spi; bundle-symbolic-name="org.slf4j.api"; bundle-version="1.7.10.v20170428-1633"; version="1.7.10"; uses:="org.slf4j"

org.tukaani.xz [419]

org.tukaani.xz [420]
  Unresolved requirement: Import-Package: org.tukaani.xz.rangecoder; version="[1.5.0,2.0.0)"; resolution:="optional"
    -> Export-Package: org.tukaani.xz.rangecoder; bundle-symbolic-name="org.tukaani.xz"; bundle-version="1.6.0.v20170629-1752"; version="1.6.0"
       org.tukaani.xz [419]
  Unresolved requirement: Import-Package: org.tukaani.xz.simple; version="[1.5.0,2.0.0)"; resolution:="optional"
    -> Export-Package: org.tukaani.xz.simple; bundle-symbolic-name="org.tukaani.xz"; bundle-version="1.6.0.v20170629-1752"; version="1.6.0"
  Unresolved requirement: Import-Package: org.tukaani.xz; version="[1.5.0,2.0.0)"; resolution:="optional"
    -> Export-Package: org.tukaani.xz; bundle-symbolic-name="org.tukaani.xz"; bundle-version="1.6.0.v20170629-1752"; version="1.6.0"
  Unresolved requirement: Import-Package: org.tukaani.xz.check; version="[1.5.0,2.0.0)"; resolution:="optional"
    -> Export-Package: org.tukaani.xz.check; bundle-symbolic-name="org.tukaani.xz"; bundle-version="1.6.0.v20170629-1752"; version="1.6.0"; uses:="org.tukaani.xz"
  Unresolved requirement: Import-Package: org.tukaani.xz.lzma; version="[1.5.0,2.0.0)"; resolution:="optional"
    -> Export-Package: org.tukaani.xz.lzma; bundle-symbolic-name="org.tukaani.xz"; bundle-version="1.6.0.v20170629-1752"; version="1.6.0"; uses:="org.tukaani.xz.lz,org.tukaani.xz.rangecoder"

org.uddi4j [421]
  Unresolved requirement: Require-Bundle: org.apache.axis; bundle-version="[1.3.0,2.0.0)"
    -> Bundle-SymbolicName: org.apache.axis; bundle-version="1.4.0.v201411182030"
       org.apache.axis [261]
         Unresolved requirement: Import-Package: javax.mail; resolution:="optional"
         Unresolved requirement: Import-Package: javax.mail.internet; resolution:="optional"
         Unresolved requirement: Require-Bundle: org.apache.commons.discovery; bundle-version="[0.2.0,1.0.0)"
           -> Bundle-SymbolicName: org.apache.commons.discovery; bundle-version="0.2.0.v201004190315"
              org.apache.commons.discovery [289]
                Unresolved requirement: Import-Package: org.apache.commons.logging; version="[1.0.4,2.0.0)"
                  -> Export-Package: org.apache.commons.logging; bundle-symbolic-name="org.slf4j.apis.jcl"; bundle-version="1.7.10.v20160208-0839"; version="1.7.10"
                     org.slf4j.apis.jcl [412]
                       Unresolved requirement: Import-Package: org.slf4j; version="[1.7.10,1.8.0)"
                         -> Export-Package: org.slf4j; bundle-symbolic-name="org.slf4j.api"; bundle-version="1.7.10.v20170428-1633"; version="1.7.10"; uses:="org.slf4j.spi"
                            org.slf4j.api [411]
                       Unresolved requirement: Import-Package: org.slf4j.spi; version="[1.7.10,1.8.0)"
                         -> Export-Package: org.slf4j.spi; bundle-symbolic-name="org.slf4j.api"; bundle-version="1.7.10.v20170428-1633"; version="1.7.10"; uses:="org.slf4j"
                Unresolved requirement: Require-Bundle: org.junit; bundle-version="3.8.0"; resolution:="optional"
                  -> Bundle-SymbolicName: org.junit; bundle-version="4.12.0.v201504281640"
                     org.junit [388]
                       Unresolved requirement: Require-Bundle: org.hamcrest.core; bundle-version="1.3.0"; visibility:="reexport"
                         -> Bundle-SymbolicName: org.hamcrest.core; bundle-version="1.3.0.v20180420-1519"
                            org.hamcrest.core [380]
                              No resolution report for the bundle.         Unresolved requirement: Require-Bundle: org.apache.ant; bundle-version="[1.6.5,2.0.0)"; resolution:="optional"
           -> Bundle-SymbolicName: org.apache.ant; bundle-version="1.10.6.v20190516-0412"
              org.apache.ant [260]
                Unresolved requirement: Import-Package: COM.ibm.netrexx.process; resolution:="optional"
                Unresolved requirement: Import-Package: com.sun.media.jai.codec; resolution:="optional"
                Unresolved requirement: Import-Package: javax.mail; version="[1.6.0,2.0.0)"; resolution:="optional"
                Unresolved requirement: Import-Package: javax.mail.internet; version="[1.6.0,2.0.0)"; resolution:="optional"
                Unresolved requirement: Import-Package: javax.media.jai; resolution:="optional"
                Unresolved requirement: Import-Package: jdepend.textui; resolution:="optional"
                Unresolved requirement: Import-Package: jdepend.xmlui; resolution:="optional"
                Unresolved requirement: Import-Package: netrexx.lang; resolution:="optional"
                Unresolved requirement: Import-Package: org.apache.bcel.classfile; version="[6.2.0,7.0.0)"; resolution:="optional"
                Unresolved requirement: Import-Package: org.apache.bsf; resolution:="optional"
                Unresolved requirement: Import-Package: org.apache.commons.net.bsd; version="[3.6.0,4.0.0)"; resolution:="optional"
                Unresolved requirement: Import-Package: org.apache.commons.net.ftp; version="[3.6.0,4.0.0)"; resolution:="optional"
                Unresolved requirement: Import-Package: org.apache.commons.net.telnet; version="[3.6.0,4.0.0)"; resolution:="optional"
                Unresolved requirement: Import-Package: org.apache.oro.text.regex; resolution:="optional"
                Unresolved requirement: Import-Package: org.apache.xml.resolver; resolution:="optional"
                Unresolved requirement: Import-Package: org.apache.xml.resolver.helpers; resolution:="optional"
                Unresolved requirement: Import-Package: org.apache.xml.resolver.tools; resolution:="optional"
                Unresolved requirement: Import-Package: org.apache.tools.ant.taskdefs.optional.extension.resolvers; version="[1.10.0,2.0.0)"; resolution:="optional"
                  -> Export-Package: org.apache.tools.ant.taskdefs.optional.extension.resolvers; bundle-symbolic-name="org.apache.ant"; bundle-version="1.10.5.v20180808-0324"; version="1.10.5"; uses:="org.apache.tools.ant,org.apache.tools.ant.taskdefs.optional.extension"
                     org.apache.ant [11]
                       Unresolved requirement: Import-Package: COM.ibm.netrexx.process; resolution:="optional"
                       Unresolved requirement: Import-Package: com.sun.media.jai.codec; resolution:="optional"
                       Unresolved requirement: Import-Package: javax.mail; version="[1.6.0,2.0.0)"; resolution:="optional"
                       Unresolved requirement: Import-Package: javax.mail.internet; version="[1.6.0,2.0.0)"; resolution:="optional"
                       Unresolved requirement: Import-Package: javax.media.jai; resolution:="optional"
                       Unresolved requirement: Import-Package: jdepend.textui; resolution:="optional"
                       Unresolved requirement: Import-Package: jdepend.xmlui; resolution:="optional"
                       Unresolved requirement: Import-Package: netrexx.lang; resolution:="optional"
                       Unresolved requirement: Import-Package: org.apache.bcel.classfile; version="[6.2.0,7.0.0)"; resolution:="optional"
                       Unresolved requirement: Import-Package: org.apache.bsf; resolution:="optional"
                       Unresolved requirement: Import-Package: org.apache.commons.net.bsd; version="[3.6.0,4.0.0)"; resolution:="optional"
                       Unresolved requirement: Import-Package: org.apache.commons.net.ftp; version="[3.6.0,4.0.0)"; resolution:="optional"
                       Unresolved requirement: Import-Package: org.apache.commons.net.telnet; version="[3.6.0,4.0.0)"; resolution:="optional"
                       Unresolved requirement: Import-Package: org.apache.oro.text.regex; resolution:="optional"
                       Unresolved requirement: Import-Package: org.apache.xml.resolver; resolution:="optional"
                       Unresolved requirement: Import-Package: org.apache.xml.resolver.helpers; resolution:="optional"
                       Unresolved requirement: Import-Package: org.apache.xml.resolver.tools; resolution:="optional"
                       Unresolved requirement: Import-Package: org.junit; resolution:="optional"
                         -> Export-Package: org.junit; bundle-symbolic-name="org.junit"; bundle-version="4.12.0.v201504281640"; version="4.12.0"
                       Unresolved requirement: Import-Package: org.apache.commons.logging; resolution:="optional"
                         -> Export-Package: org.apache.commons.logging; bundle-symbolic-name="org.slf4j.apis.jcl"; bundle-version="1.7.10.v20160208-0839"; version="1.7.10"
                       Unresolved requirement: Import-Package: org.apache.tools.ant.taskdefs; version="[1.10.0,2.0.0)"; resolution:="optional"
                         -> Export-Package: org.apache.tools.ant.taskdefs; bundle-symbolic-name="org.apache.ant"; bundle-version="1.10.6.v20190516-0412"; version="1.10.6"; uses:="javax.xml.namespace,org.apache.tools.ant,org.apache.tools.ant.filters,org.apache.tools.ant.taskdefs.compilers,org.apache.tools.ant.taskdefs.condition,org.apache.tools.ant.taskdefs.email,org.apache.tools.ant.taskdefs.launcher,org.apache.tools.ant.taskdefs.rmic,org.apache.tools.ant.types,org.apache.tools.ant.types.resources,org.apache.tools.ant.types.resources.selectors,org.apache.tools.ant.types.selectors,org.apache.tools.ant.types.selectors.modifiedselector,org.apache.tools.ant.types.spi,org.apache.tools.ant.util,org.apache.tools.ant.util.facade,org.apache.tools.tar,org.apache.tools.zip,org.w3c.dom,org.xml.sax"
                       Unresolved requirement: Import-Package: org.tukaani.xz; resolution:="optional"
                         -> Export-Package: org.tukaani.xz; bundle-symbolic-name="org.tukaani.xz"; bundle-version="1.6.0.v20170629-1752"; version="1.6.0"
                            org.tukaani.xz [419]
                       Unresolved requirement: Import-Package: org.apache.tools.ant.types; version="[1.10.0,2.0.0)"; resolution:="optional"
                         -> Export-Package: org.apache.tools.ant.types; bundle-symbolic-name="org.apache.ant"; bundle-version="1.10.6.v20190516-0412"; version="1.10.6"; uses:="javax.xml.transform,org.apache.tools.ant,org.apache.tools.ant.filters,org.apache.tools.ant.taskdefs,org.apache.tools.ant.types.selectors,org.apache.tools.ant.types.selectors.modifiedselector,org.apache.tools.ant.util,org.apache.tools.ant.util.regexp,org.junit,org.junit.rules,org.xml.sax"
                       Unresolved requirement: Import-Package: org.junit.runner; resolution:="optional"
                         -> Export-Package: org.junit.runner; bundle-symbolic-name="org.junit"; bundle-version="4.12.0.v201504281640"; version="4.12.0"
                       Unresolved requirement: Import-Package: org.apache.regexp; resolution:="optional"
                         -> Export-Package: org.apache.regexp; bundle-symbolic-name="org.apache.xalan"; bundle-version="2.7.1.v201005080400"; version="2.7.1"
                            org.apache.xalan [348]
                              Unresolved requirement: Require-Bundle: java_cup.runtime; bundle-version="0.10.0"; resolution:="optional"
                              Unresolved requirement: Require-Bundle: org.apache.bcel; bundle-version="5.2.0"; resolution:="optional"
                              Unresolved requirement: Require-Bundle: org.apache.xerces; bundle-version="[2.9.0,3.0.0)"; resolution:="optional"
                              Unresolved requirement: Require-Bundle: org.apache.xml.serializer; bundle-version="[2.7.1,3.0.0)"
                                -> Bundle-SymbolicName: org.apache.xml.serializer; bundle-version="2.7.1.v201005080400"
                                   org.apache.xml.serializer [349]
                                     No resolution report for the bundle.                       Unresolved requirement: Import-Package: org.apache.tools.zip; version="[1.10.0,2.0.0)"; resolution:="optional"
                         -> Export-Package: org.apache.tools.zip; bundle-symbolic-name="org.apache.ant"; bundle-version="1.10.6.v20190516-0412"; version="1.10.6"
                       Unresolved requirement: Import-Package: org.junit.platform.engine.support.descriptor; resolution:="optional"
                         -> Export-Package: org.junit.platform.engine.support.descriptor; bundle-symbolic-name="org.junit.platform.engine"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api,org.junit.platform.engine"
                            org.junit.platform.engine [394]
                              Unresolved requirement: Import-Package: org.junit.platform.commons.util; version="[1.4.0,2.0.0)"
                                -> Export-Package: org.junit.platform.commons.util; bundle-symbolic-name="org.junit.platform.commons"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api,org.junit.platform.commons,org.junit.platform.commons.function"
                                   org.junit.platform.commons [393]
                                     Unresolved requirement: Import-Package: org.apiguardian.api; version="[1.0.0,2.0.0)"
                                       -> Export-Package: org.apiguardian.api; bundle-symbolic-name="org.apiguardian"; bundle-version="1.0.0.v20190212-2109"; version="1.0.0"
                                          org.apiguardian [354]
                                            No resolution report for the bundle.                              Unresolved requirement: Import-Package: org.opentest4j; version="[1.1.1,2.0.0)"
                                -> Export-Package: org.opentest4j; bundle-symbolic-name="org.opentest4j"; bundle-version="1.1.1.v20190212-2109"; version="1.1.1"
                                   org.opentest4j [409]
                                     No resolution report for the bundle.                              Unresolved requirement: Import-Package: org.apiguardian.api; version="[1.0.0,2.0.0)"
                                -> Export-Package: org.apiguardian.api; bundle-symbolic-name="org.apiguardian"; bundle-version="1.0.0.v20190212-2109"; version="1.0.0"
                              Unresolved requirement: Import-Package: org.junit.platform.commons.logging; version="[1.4.0,2.0.0)"
                                -> Export-Package: org.junit.platform.commons.logging; bundle-symbolic-name="org.junit.platform.commons"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api"
                              Unresolved requirement: Import-Package: org.junit.platform.commons; version="[1.4.0,2.0.0)"
                                -> Export-Package: org.junit.platform.commons; bundle-symbolic-name="org.junit.platform.commons"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api"
                              Unresolved requirement: Import-Package: org.junit.platform.commons.function; version="[1.4.0,2.0.0)"
                                -> Export-Package: org.junit.platform.commons.function; bundle-symbolic-name="org.junit.platform.commons"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api"
                       Unresolved requirement: Import-Package: org.junit.platform.launcher.core; resolution:="optional"
                         -> Export-Package: org.junit.platform.launcher.core; bundle-symbolic-name="org.junit.platform.launcher"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api,org.junit.platform.commons.util,org.junit.platform.engine,org.junit.platform.launcher"
                            org.junit.platform.launcher [395]
                              Unresolved requirement: Import-Package: org.junit.platform.commons; version="[1.4.0,2.0.0)"
                                -> Export-Package: org.junit.platform.commons; bundle-symbolic-name="org.junit.platform.commons"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api"
                              Unresolved requirement: Import-Package: org.junit.platform.commons.util; version="[1.4.0,2.0.0)"
                                -> Export-Package: org.junit.platform.commons.util; bundle-symbolic-name="org.junit.platform.commons"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api,org.junit.platform.commons,org.junit.platform.commons.function"
                              Unresolved requirement: Import-Package: org.junit.platform.engine; version="[1.4.0,2.0.0)"
                                -> Export-Package: org.junit.platform.engine; bundle-symbolic-name="org.junit.platform.engine"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api,org.junit.platform.commons,org.junit.platform.commons.util,org.junit.platform.engine.reporting"
                              Unresolved requirement: Import-Package: org.junit.platform.commons.logging; version="[1.4.0,2.0.0)"
                                -> Export-Package: org.junit.platform.commons.logging; bundle-symbolic-name="org.junit.platform.commons"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api"
                              Unresolved requirement: Import-Package: org.junit.platform.engine.support.descriptor; version="[1.4.0,2.0.0)"
                                -> Export-Package: org.junit.platform.engine.support.descriptor; bundle-symbolic-name="org.junit.platform.engine"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api,org.junit.platform.engine"
                              Unresolved requirement: Import-Package: org.junit.platform.engine.reporting; version="[1.4.0,2.0.0)"
                                -> Export-Package: org.junit.platform.engine.reporting; bundle-symbolic-name="org.junit.platform.engine"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api"
                              Unresolved requirement: Import-Package: org.apiguardian.api; version="[1.0.0,2.0.0)"
                                -> Export-Package: org.apiguardian.api; bundle-symbolic-name="org.apiguardian"; bundle-version="1.0.0.v20190212-2109"; version="1.0.0"
                       Unresolved requirement: Import-Package: org.junit.runner.notification; resolution:="optional"
                         -> Export-Package: org.junit.runner.notification; bundle-symbolic-name="org.junit"; bundle-version="4.12.0.v201504281640"; version="4.12.0"
                       Unresolved requirement: Import-Package: org.junit.platform.engine; resolution:="optional"
                         -> Export-Package: org.junit.platform.engine; bundle-symbolic-name="org.junit.platform.engine"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api,org.junit.platform.commons,org.junit.platform.commons.util,org.junit.platform.engine.reporting"
                       Unresolved requirement: Import-Package: org.apache.tools.ant.attribute; version="[1.10.0,2.0.0)"; resolution:="optional"
                         -> Export-Package: org.apache.tools.ant.attribute; bundle-symbolic-name="org.apache.ant"; bundle-version="1.10.6.v20190516-0412"; version="1.10.6"; uses:="org.apache.tools.ant"
                       Unresolved requirement: Import-Package: org.apache.tools.ant.types.optional.image; version="[1.10.0,2.0.0)"; resolution:="optional"
                         -> Export-Package: org.apache.tools.ant.types.optional.image; bundle-symbolic-name="org.apache.ant"; bundle-version="1.10.6.v20190516-0412"; version="1.10.6"; uses:="javax.media.jai,org.apache.tools.ant.types"
                       Unresolved requirement: Import-Package: org.apache.tools.ant.launch; version="[1.10.0,2.0.0)"; resolution:="optional"
                         -> Export-Package: org.apache.tools.ant.launch; bundle-symbolic-name="org.apache.ant"; bundle-version="1.10.6.v20190516-0412"; version="1.10.6"
                       Unresolved requirement: Import-Package: org.apache.tools.ant.taskdefs.optional.depend.constantpool; version="[1.10.0,2.0.0)"; resolution:="optional"
                         -> Export-Package: org.apache.tools.ant.taskdefs.optional.depend.constantpool; bundle-symbolic-name="org.apache.ant"; bundle-version="1.10.6.v20190516-0412"; version="1.10.6"
                       Unresolved requirement: Import-Package: org.apache.tools.ant.taskdefs.email; version="[1.10.0,2.0.0)"; resolution:="optional"
                         -> Export-Package: org.apache.tools.ant.taskdefs.email; bundle-symbolic-name="org.apache.ant"; bundle-version="1.10.6.v20190516-0412"; version="1.10.6"; uses:="org.apache.tools.ant,org.apache.tools.ant.types"
                       Unresolved requirement: Import-Package: org.junit.platform.engine.discovery; resolution:="optional"
                         -> Export-Package: org.junit.platform.engine.discovery; bundle-symbolic-name="org.junit.platform.engine"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api,org.junit.platform.commons.util,org.junit.platform.engine"
                       Unresolved requirement: Import-Package: org.apache.tools.ant.types.selectors.modifiedselector; version="[1.10.0,2.0.0)"; resolution:="optional"
                         -> Export-Package: org.apache.tools.ant.types.selectors.modifiedselector; bundle-symbolic-name="org.apache.ant"; bundle-version="1.10.6.v20190516-0412"; version="1.10.6"; uses:="org.apache.tools.ant,org.apache.tools.ant.types,org.apache.tools.ant.types.resources.selectors,org.apache.tools.ant.types.selectors"
                       Unresolved requirement: Import-Package: org.apache.tools.ant.taskdefs.optional.jsp.compilers; version="[1.10.0,2.0.0)"; resolution:="optional"
                         -> Export-Package: org.apache.tools.ant.taskdefs.optional.jsp.compilers; bundle-symbolic-name="org.apache.ant"; bundle-version="1.10.6.v20190516-0412"; version="1.10.6"; uses:="org.apache.tools.ant,org.apache.tools.ant.taskdefs.optional.jsp,org.apache.tools.ant.types"
                       Unresolved requirement: Import-Package: org.junit.rules; resolution:="optional"
                         -> Export-Package: org.junit.rules; bundle-symbolic-name="org.junit"; bundle-version="4.12.0.v201504281640"; version="4.12.0"
                       Unresolved requirement: Import-Package: junit.framework; resolution:="optional"
                         -> Export-Package: junit.framework; bundle-symbolic-name="org.junit"; bundle-version="4.12.0.v201504281640"; version="4.12.0"
                       Unresolved requirement: Import-Package: org.apache.log4j; version="[1.2.0,2.0.0)"; resolution:="optional"
                         -> Export-Package: org.apache.log4j; bundle-symbolic-name="org.slf4j.apis.log4j"; bundle-version="1.7.10.v20160208-0839"; version="1.2.17.internalx-internaltrueversion1710implx-internaltrueversion1710version1710"; uses:="org.apache.log4j.spi,org.slf4j"
                            org.slf4j.apis.log4j [413]
                              Unresolved requirement: Import-Package: org.slf4j.helpers; version="[1.7.10,1.8.0)"
                                -> Export-Package: org.slf4j.helpers; bundle-symbolic-name="org.slf4j.api"; bundle-version="1.7.10.v20170428-1633"; version="1.7.10"; uses:="org.slf4j,org.slf4j.spi"
                              Unresolved requirement: Import-Package: org.slf4j.spi; version="[1.7.10,1.8.0)"
                                -> Export-Package: org.slf4j.spi; bundle-symbolic-name="org.slf4j.api"; bundle-version="1.7.10.v20170428-1633"; version="1.7.10"; uses:="org.slf4j"
                              Unresolved requirement: Import-Package: org.slf4j; version="[1.7.10,1.8.0)"
                                -> Export-Package: org.slf4j; bundle-symbolic-name="org.slf4j.api"; bundle-version="1.7.10.v20170428-1633"; version="1.7.10"; uses:="org.slf4j.spi"
                       Unresolved requirement: Import-Package: org.apache.xalan.trace; resolution:="optional"
                         -> Export-Package: org.apache.xalan.trace; bundle-symbolic-name="org.apache.xalan"; bundle-version="2.7.1.v201005080400"; version="2.7.1"
                       Unresolved requirement: Import-Package: org.junit.platform.engine.reporting; resolution:="optional"
                         -> Export-Package: org.junit.platform.engine.reporting; bundle-symbolic-name="org.junit.platform.engine"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api"
                       Unresolved requirement: Import-Package: org.apache.tools.ant.util.facade; version="[1.10.0,2.0.0)"; resolution:="optional"
                         -> Export-Package: org.apache.tools.ant.util.facade; bundle-symbolic-name="org.apache.ant"; bundle-version="1.10.6.v20190516-0412"; version="1.10.6"; uses:="org.apache.tools.ant,org.apache.tools.ant.types"
                       Unresolved requirement: Import-Package: com.jcraft.jsch; resolution:="optional"
                         -> Export-Package: com.jcraft.jsch; bundle-symbolic-name="com.jcraft.jsch"; bundle-version="0.1.54.v20170116-1932"; version="0.1.54"
                            com.jcraft.jsch [4]
                              Unresolved requirement: Import-Package: com.jcraft.jzlib; version="1.0.7"; resolution:="optional"
                       Unresolved requirement: Import-Package: org.apache.xalan.transformer; resolution:="optional"
                         -> Export-Package: org.apache.xalan.transformer; bundle-symbolic-name="org.apache.xalan"; bundle-version="2.7.1.v201005080400"; version="2.7.1"
                       Unresolved requirement: Import-Package: org.junit.platform.launcher; resolution:="optional"
                         -> Export-Package: org.junit.platform.launcher; bundle-symbolic-name="org.junit.platform.launcher"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api,org.junit.platform.commons.util,org.junit.platform.engine,org.junit.platform.engine.reporting"
                       Unresolved requirement: Import-Package: org.apache.tools.ant.taskdefs.optional.net; version="[1.10.0,2.0.0)"; resolution:="optional"
                         -> Export-Package: org.apache.tools.ant.taskdefs.optional.net; bundle-symbolic-name="org.apache.ant"; bundle-version="1.10.6.v20190516-0412"; version="1.10.6"; uses:="org.apache.commons.net.bsd,org.apache.commons.net.ftp,org.apache.commons.net.telnet,org.apache.tools.ant,org.apache.tools.ant.taskdefs.email,org.apache.tools.ant.types,org.apache.tools.ant.util"
                       Unresolved requirement: Import-Package: org.junit.runner.manipulation; resolution:="optional"
                         -> Export-Package: org.junit.runner.manipulation; bundle-symbolic-name="org.junit"; bundle-version="4.12.0.v201504281640"; version="4.12.0"
                       Unresolved requirement: Import-Package: org.junit.platform.launcher.listeners; resolution:="optional"
                         -> Export-Package: org.junit.platform.launcher.listeners; bundle-symbolic-name="org.junit.platform.launcher"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api,org.junit.platform.engine,org.junit.platform.launcher"
                Unresolved requirement: Import-Package: org.junit.platform.engine.support.descriptor; resolution:="optional"
                  -> Export-Package: org.junit.platform.engine.support.descriptor; bundle-symbolic-name="org.junit.platform.engine"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api,org.junit.platform.engine"
                Unresolved requirement: Import-Package: org.apache.tools.ant.taskdefs.condition; version="[1.10.0,2.0.0)"; resolution:="optional"
                  -> Export-Package: org.apache.tools.ant.taskdefs.condition; bundle-symbolic-name="org.apache.ant"; bundle-version="1.10.5.v20180808-0324"; version="1.10.5"; uses:="org.apache.tools.ant,org.apache.tools.ant.taskdefs,org.apache.tools.ant.types,org.apache.tools.ant.types.selectors"
                Unresolved requirement: Import-Package: org.junit.platform.engine.discovery; resolution:="optional"
                  -> Export-Package: org.junit.platform.engine.discovery; bundle-symbolic-name="org.junit.platform.engine"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api,org.junit.platform.commons.util,org.junit.platform.engine"
                Unresolved requirement: Import-Package: org.apache.tools.ant.filters; version="[1.10.0,2.0.0)"; resolution:="optional"
                  -> Export-Package: org.apache.tools.ant.filters; bundle-symbolic-name="org.apache.ant"; bundle-version="1.10.5.v20180808-0324"; version="1.10.5"; uses:="org.apache.tools.ant,org.apache.tools.ant.types,org.apache.tools.ant.util"
                Unresolved requirement: Import-Package: org.apache.tools.ant.helper; version="[1.10.0,2.0.0)"; resolution:="optional"
                  -> Export-Package: org.apache.tools.ant.helper; bundle-symbolic-name="org.apache.ant"; bundle-version="1.10.5.v20180808-0324"; version="1.10.5"; uses:="org.apache.tools.ant,org.apache.tools.ant.types,org.xml.sax,org.xml.sax.helpers"
                Unresolved requirement: Import-Package: org.junit.runner.notification; resolution:="optional"
                  -> Export-Package: org.junit.runner.notification; bundle-symbolic-name="org.junit"; bundle-version="4.12.0.v201504281640"; version="4.12.0"
                Unresolved requirement: Import-Package: org.junit; resolution:="optional"
                  -> Export-Package: org.junit; bundle-symbolic-name="org.junit"; bundle-version="4.12.0.v201504281640"; version="4.12.0"
                Unresolved requirement: Import-Package: org.apache.tools.ant.property; version="[1.10.0,2.0.0)"; resolution:="optional"
                  -> Export-Package: org.apache.tools.ant.property; bundle-symbolic-name="org.apache.ant"; bundle-version="1.10.5.v20180808-0324"; version="1.10.5"; uses:="org.apache.tools.ant"
                Unresolved requirement: Import-Package: org.apache.tools.ant.taskdefs.rmic; version="[1.10.0,2.0.0)"; resolution:="optional"
                  -> Export-Package: org.apache.tools.ant.taskdefs.rmic; bundle-symbolic-name="org.apache.ant"; bundle-version="1.10.5.v20180808-0324"; version="1.10.5"; uses:="org.apache.tools.ant,org.apache.tools.ant.taskdefs,org.apache.tools.ant.types,org.apache.tools.ant.util"
                Unresolved requirement: Import-Package: org.apache.log4j; version="[1.2.0,2.0.0)"; resolution:="optional"
                  -> Export-Package: org.apache.log4j; bundle-symbolic-name="org.slf4j.apis.log4j"; bundle-version="1.7.10.v20160208-0839"; version="1.2.17.internalx-internaltrueversion1710implx-internaltrueversion1710version1710"; uses:="org.apache.log4j.spi,org.slf4j"
                Unresolved requirement: Import-Package: org.junit.platform.launcher; resolution:="optional"
                  -> Export-Package: org.junit.platform.launcher; bundle-symbolic-name="org.junit.platform.launcher"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api,org.junit.platform.commons.util,org.junit.platform.engine,org.junit.platform.engine.reporting"
                Unresolved requirement: Import-Package: org.apache.tools.ant.taskdefs.optional.native2ascii; version="[1.10.0,2.0.0)"; resolution:="optional"
                  -> Export-Package: org.apache.tools.ant.taskdefs.optional.native2ascii; bundle-symbolic-name="org.apache.ant"; bundle-version="1.10.5.v20180808-0324"; version="1.10.5"; uses:="org.apache.tools.ant,org.apache.tools.ant.taskdefs.optional,org.apache.tools.ant.types"
                Unresolved requirement: Import-Package: org.apache.tools.ant.util.depend; version="[1.10.0,2.0.0)"; resolution:="optional"
                  -> Export-Package: org.apache.tools.ant.util.depend; bundle-symbolic-name="org.apache.ant"; bundle-version="1.10.5.v20180808-0324"; version="1.10.5"; uses:="org.apache.tools.ant.types"
                Unresolved requirement: Import-Package: org.apache.tools.tar; version="[1.10.0,2.0.0)"; resolution:="optional"
                  -> Export-Package: org.apache.tools.tar; bundle-symbolic-name="org.apache.ant"; bundle-version="1.10.5.v20180808-0324"; version="1.10.5"; uses:="org.apache.tools.zip"
                Unresolved requirement: Import-Package: org.apache.tools.ant.dispatch; version="[1.10.0,2.0.0)"; resolution:="optional"
                  -> Export-Package: org.apache.tools.ant.dispatch; bundle-symbolic-name="org.apache.ant"; bundle-version="1.10.5.v20180808-0324"; version="1.10.5"; uses:="org.apache.tools.ant"
                Unresolved requirement: Import-Package: org.apache.tools.ant.taskdefs.optional.javah; version="[1.10.0,2.0.0)"; resolution:="optional"
                  -> Export-Package: org.apache.tools.ant.taskdefs.optional.javah; bundle-symbolic-name="org.apache.ant"; bundle-version="1.10.5.v20180808-0324"; version="1.10.5"; uses:="org.apache.tools.ant,org.apache.tools.ant.taskdefs.optional,org.apache.tools.ant.types"
                Unresolved requirement: Import-Package: com.jcraft.jsch; resolution:="optional"
                  -> Export-Package: com.jcraft.jsch; bundle-symbolic-name="com.jcraft.jsch"; bundle-version="0.1.54.v20170116-1932"; version="0.1.54"
                Unresolved requirement: Import-Package: org.apache.xalan.transformer; resolution:="optional"
                  -> Export-Package: org.apache.xalan.transformer; bundle-symbolic-name="org.apache.xalan"; bundle-version="2.7.1.v201005080400"; version="2.7.1"
                Unresolved requirement: Import-Package: org.apache.tools.ant.taskdefs.launcher; version="[1.10.0,2.0.0)"; resolution:="optional"
                  -> Export-Package: org.apache.tools.ant.taskdefs.launcher; bundle-symbolic-name="org.apache.ant"; bundle-version="1.10.5.v20180808-0324"; version="1.10.5"; uses:="org.apache.tools.ant,org.apache.tools.ant.util"
                Unresolved requirement: Import-Package: org.apache.xalan.trace; resolution:="optional"
                  -> Export-Package: org.apache.xalan.trace; bundle-symbolic-name="org.apache.xalan"; bundle-version="2.7.1.v201005080400"; version="2.7.1"
                Unresolved requirement: Import-Package: org.apache.tools.ant.types.resources.comparators; version="[1.10.0,2.0.0)"; resolution:="optional"
                  -> Export-Package: org.apache.tools.ant.types.resources.comparators; bundle-symbolic-name="org.apache.ant"; bundle-version="1.10.5.v20180808-0324"; version="1.10.5"; uses:="org.apache.tools.ant,org.apache.tools.ant.types"
                Unresolved requirement: Import-Package: org.junit.platform.engine; resolution:="optional"
                  -> Export-Package: org.junit.platform.engine; bundle-symbolic-name="org.junit.platform.engine"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api,org.junit.platform.commons,org.junit.platform.commons.util,org.junit.platform.engine.reporting"
                Unresolved requirement: Import-Package: org.junit.rules; resolution:="optional"
                  -> Export-Package: org.junit.rules; bundle-symbolic-name="org.junit"; bundle-version="4.12.0.v201504281640"; version="4.12.0"
                Unresolved requirement: Import-Package: org.apache.tools.ant.types.spi; version="[1.10.0,2.0.0)"; resolution:="optional"
                  -> Export-Package: org.apache.tools.ant.types.spi; bundle-symbolic-name="org.apache.ant"; bundle-version="1.10.5.v20180808-0324"; version="1.10.5"; uses:="org.apache.tools.ant"
                Unresolved requirement: Import-Package: org.apache.tools.ant.taskdefs.optional.extension; version="[1.10.0,2.0.0)"; resolution:="optional"
                  -> Export-Package: org.apache.tools.ant.taskdefs.optional.extension; bundle-symbolic-name="org.apache.ant"; bundle-version="1.10.5.v20180808-0324"; version="1.10.5"; uses:="org.apache.tools.ant,org.apache.tools.ant.taskdefs.optional.extension.resolvers,org.apache.tools.ant.types,org.apache.tools.ant.util"
                Unresolved requirement: Import-Package: org.apache.tools.ant.input; version="[1.10.0,2.0.0)"; resolution:="optional"
                  -> Export-Package: org.apache.tools.ant.input; bundle-symbolic-name="org.apache.ant"; bundle-version="1.10.5.v20180808-0324"; version="1.10.5"; uses:="org.apache.tools.ant"
                Unresolved requirement: Import-Package: org.junit.platform.launcher.listeners; resolution:="optional"
                  -> Export-Package: org.junit.platform.launcher.listeners; bundle-symbolic-name="org.junit.platform.launcher"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api,org.junit.platform.engine,org.junit.platform.launcher"
                Unresolved requirement: Import-Package: org.junit.runner; resolution:="optional"
                  -> Export-Package: org.junit.runner; bundle-symbolic-name="org.junit"; bundle-version="4.12.0.v201504281640"; version="4.12.0"
                Unresolved requirement: Import-Package: org.apache.tools.ant.listener; version="[1.10.0,2.0.0)"; resolution:="optional"
                  -> Export-Package: org.apache.tools.ant.listener; bundle-symbolic-name="org.apache.ant"; bundle-version="1.10.5.v20180808-0324"; version="1.10.5"; uses:="org.apache.tools.ant"
                Unresolved requirement: Import-Package: org.apache.tools.ant.types.resources; version="[1.10.0,2.0.0)"; resolution:="optional"
                  -> Export-Package: org.apache.tools.ant.types.resources; bundle-symbolic-name="org.apache.ant"; bundle-version="1.10.5.v20180808-0324"; version="1.10.5"; uses:="org.apache.tools.ant,org.apache.tools.ant.types,org.apache.tools.ant.types.resources.comparators,org.apache.tools.ant.types.resources.selectors,org.apache.tools.ant.types.selectors,org.apache.tools.ant.util,org.apache.tools.tar,org.apache.tools.zip"
                Unresolved requirement: Import-Package: junit.framework; resolution:="optional"
                  -> Export-Package: junit.framework; bundle-symbolic-name="org.junit"; bundle-version="4.12.0.v201504281640"; version="4.12.0"
                Unresolved requirement: Import-Package: org.apache.tools.ant.util.java15; version="[1.10.0,2.0.0)"; resolution:="optional"
                  -> Export-Package: org.apache.tools.ant.util.java15; bundle-symbolic-name="org.apache.ant"; bundle-version="1.10.5.v20180808-0324"; version="1.10.5"
                Unresolved requirement: Import-Package: org.junit.platform.launcher.core; resolution:="optional"
                  -> Export-Package: org.junit.platform.launcher.core; bundle-symbolic-name="org.junit.platform.launcher"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api,org.junit.platform.commons.util,org.junit.platform.engine,org.junit.platform.launcher"
                Unresolved requirement: Import-Package: org.junit.platform.engine.reporting; resolution:="optional"
                  -> Export-Package: org.junit.platform.engine.reporting; bundle-symbolic-name="org.junit.platform.engine"; bundle-version="1.4.0.v20190212-2109"; version="1.4.0"; uses:="org.apiguardian.api"
                Unresolved requirement: Import-Package: org.apache.commons.logging; resolution:="optional"
                  -> Export-Package: org.apache.commons.logging; bundle-symbolic-name="org.slf4j.apis.jcl"; bundle-version="1.7.10.v20160208-0839"; version="1.7.10"
                Unresolved requirement: Import-Package: org.apache.tools.ant.taskdefs.optional.jsp; version="[1.10.0,2.0.0)"; resolution:="optional"
                  -> Export-Package: org.apache.tools.ant.taskdefs.optional.jsp; bundle-symbolic-name="org.apache.ant"; bundle-version="1.10.5.v20180808-0324"; version="1.10.5"; uses:="org.apache.tools.ant,org.apache.tools.ant.taskdefs,org.apache.tools.ant.types"
                Unresolved requirement: Import-Package: org.apache.tools.mail; version="[1.10.0,2.0.0)"; resolution:="optional"
                  -> Export-Package: org.apache.tools.mail; bundle-symbolic-name="org.apache.ant"; bundle-version="1.10.5.v20180808-0324"; version="1.10.5"
                Unresolved requirement: Import-Package: org.apache.tools.ant.util; version="[1.10.0,2.0.0)"; resolution:="optional"
                  -> Export-Package: org.apache.tools.ant.util; bundle-symbolic-name="org.apache.ant"; bundle-version="1.10.5.v20180808-0324"; version="1.10.5"; uses:="javax.xml.parsers,org.apache.tools.ant,org.apache.tools.ant.types,org.apache.tools.ant.types.resources,org.apache.tools.ant.types.resources.selectors,org.apache.tools.ant.util.optional,org.apache.tools.ant.util.regexp,org.w3c.dom,org.xml.sax"
                Unresolved requirement: Import-Package: org.apache.tools.ant.types.selectors; version="[1.10.0,2.0.0)"; resolution:="optional"
                  -> Export-Package: org.apache.tools.ant.types.selectors; bundle-symbolic-name="org.apache.ant"; bundle-version="1.10.5.v20180808-0324"; version="1.10.5"; uses:="org.apache.tools.ant,org.apache.tools.ant.types,org.apache.tools.ant.types.resources.selectors,org.apache.tools.ant.types.selectors.modifiedselector,org.apache.tools.ant.util"
                Unresolved requirement: Import-Package: org.apache.tools.ant.util.optional; version="[1.10.0,2.0.0)"; resolution:="optional"
                  -> Export-Package: org.apache.tools.ant.util.optional; bundle-symbolic-name="org.apache.ant"; bundle-version="1.10.5.v20180808-0324"; version="1.10.5"; uses:="org.apache.tools.ant,org.apache.tools.ant.util"
                Unresolved requirement: Import-Package: org.apache.tools.bzip2; version="[1.10.0,2.0.0)"; resolution:="optional"
                  -> Export-Package: org.apache.tools.bzip2; bundle-symbolic-name="org.apache.ant"; bundle-version="1.10.5.v20180808-0324"; version="1.10.5"
                Unresolved requirement: Import-Package: org.apache.tools.ant; version="[1.10.0,2.0.0)"; resolution:="optional"
                  -> Export-Package: org.apache.tools.ant; bundle-symbolic-name="org.apache.ant"; bundle-version="1.10.5.v20180808-0324"; version="1.10.5"; uses:="junit.framework,org.apache.tools.ant.input,org.apache.tools.ant.launch,org.apache.tools.ant.property,org.apache.tools.ant.taskdefs.condition,org.apache.tools.ant.types,org.apache.tools.ant.types.selectors,org.junit.rules,org.xml.sax"
                Unresolved requirement: Import-Package: org.apache.tools.ant.filters.util; version="[1.10.0,2.0.0)"; resolution:="optional"
                  -> Export-Package: org.apache.tools.ant.filters.util; bundle-symbolic-name="org.apache.ant"; bundle-version="1.10.5.v20180808-0324"; version="1.10.5"; uses:="org.apache.tools.ant,org.apache.tools.ant.types"
                Unresolved requirement: Import-Package: org.apache.tools.ant.types.resources.selectors; version="[1.10.0,2.0.0)"; resolution:="optional"
                  -> Export-Package: org.apache.tools.ant.types.resources.selectors; bundle-symbolic-name="org.apache.ant"; bundle-version="1.10.5.v20180808-0324"; version="1.10.5"; uses:="org.apache.tools.ant,org.apache.tools.ant.types,org.apache.tools.ant.types.resources.comparators"
                Unresolved requirement: Import-Package: org.apache.tools.ant.util.regexp; version="[1.10.0,2.0.0)"; resolution:="optional"
                  -> Export-Package: org.apache.tools.ant.util.regexp; bundle-symbolic-name="org.apache.ant"; bundle-version="1.10.5.v20180808-0324"; version="1.10.5"; uses:="org.apache.oro.text.regex,org.apache.regexp,org.apache.tools.ant,org.junit"
                Unresolved requirement: Import-Package: org.apache.tools.ant.taskdefs.compilers; version="[1.10.0,2.0.0)"; resolution:="optional"
                  -> Export-Package: org.apache.tools.ant.taskdefs.compilers; bundle-symbolic-name="org.apache.ant"; bundle-version="1.10.5.v20180808-0324"; version="1.10.5"; uses:="org.apache.tools.ant,org.apache.tools.ant.taskdefs,org.apache.tools.ant.types"
                Unresolved requirement: Import-Package: org.apache.regexp; resolution:="optional"
                  -> Export-Package: org.apache.regexp; bundle-symbolic-name="org.apache.xalan"; bundle-version="2.7.1.v201005080400"; version="2.7.1"
                Unresolved requirement: Import-Package: org.junit.runner.manipulation; resolution:="optional"
                  -> Export-Package: org.junit.runner.manipulation; bundle-symbolic-name="org.junit"; bundle-version="4.12.0.v201504281640"; version="4.12.0"
                Unresolved requirement: Import-Package: org.tukaani.xz; resolution:="optional"
                  -> Export-Package: org.tukaani.xz; bundle-symbolic-name="org.tukaani.xz"; bundle-version="1.6.0.v20170629-1752"; version="1.6.0"
                Unresolved requirement: Import-Package: org.apache.tools.ant.taskdefs.optional; version="[1.10.0,2.0.0)"; resolution:="optional"
                  -> Export-Package: org.apache.tools.ant.taskdefs.optional; bundle-symbolic-name="org.apache.ant"; bundle-version="1.10.5.v20180808-0324"; version="1.10.5"; uses:="javax.xml.transform,org.apache.tools.ant,org.apache.tools.ant.taskdefs,org.apache.tools.ant.taskdefs.optional.javah,org.apache.tools.ant.taskdefs.optional.native2ascii,org.apache.tools.ant.types,org.apache.tools.ant.util,org.apache.tools.ant.util.facade,org.junit,org.junit.rules,org.w3c.dom,org.xml.sax"
         Unresolved requirement: Require-Bundle: javax.xml.rpc; bundle-version="[1.1.0,2.0.0)"
           -> Bundle-SymbolicName: javax.xml.rpc; bundle-version="1.1.0.v201209140446"
              javax.xml.rpc [249]
                Unresolved requirement: Require-Bundle: org.apache.xerces; bundle-version="[2.8.0,3.0.0)"; resolution:="optional"
                Unresolved requirement: Import-Package: javax.xml.soap
                  -> Export-Package: javax.xml.soap; bundle-symbolic-name="javax.xml.soap"; bundle-version="1.3.0.v201105210645"; version="1.3.0"; uses:="javax.activation,  javax.xml.namespace,  javax.xml.transform,  org.w3c.dom"
                     javax.xml.soap [250]
                       No resolution report for the bundle.         Unresolved requirement: Import-Package: org.apache.commons.logging.impl; version="[1.0.4,2.0.0)"; resolution:="optional"
           -> Export-Package: org.apache.commons.logging.impl; bundle-symbolic-name="org.slf4j.apis.jcl"; bundle-version="1.7.10.v20160208-0839"; version="1.1.1.orgapachecommonsloggingversion111"; x-internal:="true"; uses:="org.apache.commons.logging"
         Unresolved requirement: Require-Bundle: javax.wsdl; bundle-version="[1.5.1,2.0.0)"
           -> Bundle-SymbolicName: javax.wsdl; bundle-version="1.6.2.v201012040545"
              javax.wsdl [246]
                No resolution report for the bundle.         Unresolved requirement: Import-Package: org.apache.commons.logging; version="[1.0.4,2.0.0)"; resolution:="optional"
           -> Export-Package: org.apache.commons.logging; bundle-symbolic-name="org.slf4j.apis.jcl"; bundle-version="1.7.10.v20160208-0839"; version="1.7.10"
         Unresolved requirement: Require-Bundle: javax.xml.soap; bundle-version="[1.2.0,2.0.0)"
           -> Bundle-SymbolicName: javax.xml.soap; bundle-version="1.3.0.v201105210645"

osgi> Really want to stop Equinox? (y/n; default=y)  
+ exit 1
Build step 'Execute shell' marked build as failure
Started calculate disk usage of build
Finished Calculation of disk usage of build in 0 seconds
Started calculate disk usage of workspace
Finished Calculation of disk usage of workspace in 0 seconds
Finished: FAILURE