Test Result : Scenario: Starting job with invalid Command Execution and Package Install steps

0 failures
31 tests
Took 24 ms.

All Tests

Test nameDurationStatus
And Command "pwd" is executed0 msFixed
And I confirm job target has step index 0 and status "PROCESS_FAILED"0 msFixed
And I confirm the executed job is finished0 msFixed
And I create a job with the name "TestJob"0 msFixed
And I create a new job target item0 msFixed
And I create a new step entities from the existing creator0 msFixed
And I create a regular step creator with the name "TestStep1" and properties0 msFixed
And I find 3 device events0 msFixed
And I find 3 device events0 msFixed
And I get the KuraMock device0 msPassed
And I login as user with name "kapua-sys" and password "kapua-password"0 msPassed
And I logout0 msFixed
And I query for the execution items for the current job and I count 1 or more0 msFixed
And I search for step definition with the name0 msFixed
And I search the database for created job steps and I find 20 msFixed
And I select account "kapua-sys"0 msPassed
And I start a job0 msFixed
And I wait 1 second0 msPassed
And I wait 1 second0 msPassed
And Packages are requested and 1 package is received0 msFixed
And Packages are requested and 1 package is received0 msFixed
Given I start the Kura Mock0 msPassed
Scenario: Starting job with invalid Command Execution and Package Install steps24 msFixed
Then Device status is "CONNECTED"0 msPassed
Then No exception was thrown0 msFixed
Then The type of the last event is "DEPLOY"0 msFixed
When Device is connected0 msPassed
When I query for the job with the name "TestJob" and I find it0 msFixed
When I search for events from device "rpione3" in account "kapua-sys"0 msFixed
When I search for events from device "rpione3" in account "kapua-sys"0 msFixed
When KuraMock is disconnected0 msFixed