Test Result : Scenario: Restarting job with invalid Bundle Start and Bundle Stop steps and multiple devices two times

0 failures
41 tests
Took 36 ms.

All Tests

Test nameDurationStatus
And A bundle named org.eclipse.kura.linux.bluetooth with id 77 and version 1.0.300 is present and ACTIVE0 msFixed
And A bundle named org.eclipse.kura.linux.bluetooth with id 77 and version 1.0.300 is present and ACTIVE0 msFixed
And A regular step creator with the name "TestStep" and the following properties0 msPassed
And A regular step creator with the name "TestStep2" and the following properties0 msFixed
And Bundles are requested0 msFixed
And Bundles are requested0 msFixed
And Devices are connected0 msPassed
And I add targets to job0 msFixed
And I confirm job target has step index 0 and status "PROCESS_FAILED"0 msFixed
And I confirm job target has step index 0 and status "PROCESS_FAILED"0 msFixed
And I confirm the executed job is finished0 msFixed
And I confirm the executed job is finished0 msFixed
And I get the KuraMock devices0 msPassed
And I login as user with name "kapua-sys" and password "kapua-password"0 msPassed
And I logout0 msFixed
And I restart a job0 msFixed
And I search the database for created job steps and I find 20 msFixed
And I select account "kapua-sys"0 msPassed
And I wait 1 second0 msPassed
And I wait 1 second0 msPassed
And I wait 1 second0 msPassed
And KuraMock is disconnected2 msFixed
And Search for step definition with the name "Bundle Start"0 msFixed
And Search for step definition with the name "Bundle Stop"0 msFixed
And The type of the last event is "BUNDLE"0 msFixed
Given I create a job with the name "TestJob"0 msFixed
Given I query for the job with the name "TestJob" and I find it0 msFixed
Given I query for the job with the name "TestJob" and I find it0 msFixed
Scenario: Restarting job with invalid Bundle Start and Bundle Stop steps and multiple devices two times34 msFixed
Then A bundle named slf4j.api with id 34 and version 1.7.21 is present and RESOLVED0 msFixed
Then A bundle named slf4j.api with id 34 and version 1.7.21 is present and RESOLVED0 msFixed
Then Devices status is "CONNECTED"0 msPassed
Then I restart a job0 msFixed
Then No exception was thrown0 msFixed
When I add 2 devices to Kura Mock0 msPassed
When I create a new step entity from the existing creator0 msFixed
When I create a new step entity from the existing creator0 msFixed
When I query for the execution items for the current job and I count 10 msFixed
When I query for the execution items for the current job and I count 20 msFixed
When I search events from devices in account "kapua-sys" and 2 events are found0 msFixed
When I search events from devices in account "kapua-sys" and 2 events are found0 msFixed