Test Result : Scenario: Test STRICT user coupling on single connection

2 failures , 10 skipped
25 tests
Took 6 ms.

All Tests

Test nameDurationStatus
And A full set of device privileges for account "test-acc-1"0 msPassed
And Devices such as0 msPassed
And I wait for 2 seconds0 msSkipped
And I wait for 2 seconds0 msFixed
And I wait for 2 seconds0 msSkipped
And Such a set of privileged users for account "test-acc-1"0 msPassed
And The broker URI is tcp://test-user-1:KeepCalm123.@localhost:18830 msFixed
And The broker URI is tcp://test-user-2:KeepCalm123.@localhost:18830 msSkipped
And The connection status is "CONNECTED"2 msFailed
And The connection status is "DISCONNECTED"0 msSkipped
And The connection user is "test-user-1"0 msSkipped
And The default connection coupling mode for account "test-acc-1" is set to "LOOSE"0 msFixed
And The following device connections0 msPassed
Given Account0 msPassed
Given The account name is test-acc-1 and the client ID is device-10 msFixed
Given The account name is test-acc-1 and the client ID is device-10 msSkipped
Scenario: Test STRICT user coupling on single connection4 msFailed
Then I find 1 connection0 msFixed
Then I find 1 connection0 msSkipped
Then I stop the simulator0 msSkipped
When I login as user with name "kapua-sys" and password "kapua-password"0 msPassed
When I search for a connection from the device "device-1" in account "test-acc-1"0 msSkipped
When I search for a connection from the device "device-1" in account "test-acc-1"0 msFixed
When I start the simulator0 msFixed
When I start the simulator0 msSkipped