FailedConsole Output

Started by upstream project "eclipse-glsp/glsp-client/master" build number 81
originally caused by:
 Branch indexing
Running in Durability level: PERFORMANCE_OPTIMIZED
[Pipeline] Start of Pipeline
[Pipeline] podTemplate
[Pipeline] {
[Pipeline] node
Created Pod: glsp/glsp-agent-pod-g2chk-d1n9d
[Normal][glsp/glsp-agent-pod-g2chk-d1n9d][Scheduled] Successfully assigned glsp-agent-pod-g2chk-d1n9d to osnode-19.eclipse.org
[Normal][glsp/glsp-agent-pod-g2chk-d1n9d][SuccessfulMountVolume] MountVolume.SetUp succeeded for volume "workspace-volume" 
[Normal][glsp/glsp-agent-pod-g2chk-d1n9d][SuccessfulMountVolume] MountVolume.SetUp succeeded for volume "jenkins-home" 
[Normal][glsp/glsp-agent-pod-g2chk-d1n9d][SuccessfulMountVolume] MountVolume.SetUp succeeded for volume "yarn-global" 
[Normal][glsp/glsp-agent-pod-g2chk-d1n9d][SuccessfulMountVolume] MountVolume.SetUp succeeded for volume "default-token-nzzpd" 
Still waiting to schedule task
‘glsp-agent-pod-g2chk-d1n9d’ is offline
[Normal][glsp/glsp-agent-pod-g2chk-d1n9d][Pulled] Container image "node:10.20.1" already present on machine
[Normal][glsp/glsp-agent-pod-g2chk-d1n9d][Created] Created container
[Normal][glsp/glsp-agent-pod-g2chk-d1n9d][Started] Started container
[Normal][glsp/glsp-agent-pod-g2chk-d1n9d][Pulled] Container image "docker.io/eclipsecbi/jiro-agent-basic:remoting-4.2.1" already present on machine
[Normal][glsp/glsp-agent-pod-g2chk-d1n9d][Created] Created container
[Normal][glsp/glsp-agent-pod-g2chk-d1n9d][Started] Started container
Agent glsp-agent-pod-g2chk-d1n9d is provisioned from template glsp-agent-pod-g2chk
---
apiVersion: "v1"
kind: "Pod"
metadata:
  annotations:
    buildUrl: "http://jenkins-ui.glsp.svc.cluster.local/glsp/job/deploy-npm-glsp-client/92/"
    runUrl: "job/deploy-npm-glsp-client/92/"
  labels:
    jenkins: "slave"
    jenkins/label: "glsp-agent-pod"
  name: "glsp-agent-pod-g2chk-d1n9d"
spec:
  containers:
  - command:
    - "cat"
    image: "node:10.20.1"
    name: "node"
    resources:
      limits:
        memory: "2Gi"
        cpu: "1"
      requests:
        memory: "2Gi"
        cpu: "1"
    tty: true
    volumeMounts:
    - mountPath: "/home/jenkins"
      name: "jenkins-home"
      readOnly: false
    - mountPath: "/.yarn"
      name: "yarn-global"
      readOnly: false
    - mountPath: "/home/jenkins/agent"
      name: "workspace-volume"
      readOnly: false
  - env:
    - name: "JENKINS_SECRET"
      value: "********"
    - name: "JENKINS_TUNNEL"
      value: "jenkins-discovery.glsp.svc.cluster.local:50000"
    - name: "JENKINS_AGENT_NAME"
      value: "glsp-agent-pod-g2chk-d1n9d"
    - name: "JENKINS_NAME"
      value: "glsp-agent-pod-g2chk-d1n9d"
    - name: "JENKINS_AGENT_WORKDIR"
      value: "/home/jenkins/agent"
    - name: "JENKINS_URL"
      value: "http://jenkins-ui.glsp.svc.cluster.local/glsp/"
    image: "docker.io/eclipsecbi/jiro-agent-basic:remoting-4.2.1"
    name: "jnlp"
    resources:
      requests:
        cpu: "100m"
        memory: "256Mi"
    volumeMounts:
    - mountPath: "/home/jenkins/agent"
      name: "workspace-volume"
      readOnly: false
  nodeSelector:
    beta.kubernetes.io/os: "linux"
  restartPolicy: "Never"
  securityContext: {}
  volumes:
  - emptyDir: {}
    name: "yarn-global"
  - emptyDir: {}
    name: "jenkins-home"
  - emptyDir:
      medium: ""
    name: "workspace-volume"

Running on glsp-agent-pod-g2chk-d1n9d in /home/jenkins/agent/workspace/deploy-npm-glsp-client
[Pipeline] {
[Pipeline] withEnv
[Pipeline] {
[Pipeline] stage
[Pipeline] { (Checkout master)
[Pipeline] git
using credential github-bot
Cloning the remote Git repository
Cloning repository https://github.com/eclipse-glsp/glsp-client.git
 > git init /home/jenkins/agent/workspace/deploy-npm-glsp-client # timeout=10
Fetching upstream changes from https://github.com/eclipse-glsp/glsp-client.git
 > git --version # timeout=10
using GIT_ASKPASS to set credentials GitHub bot
 > git fetch --tags --force --progress -- https://github.com/eclipse-glsp/glsp-client.git +refs/heads/*:refs/remotes/origin/* # timeout=10
 > git config remote.origin.url https://github.com/eclipse-glsp/glsp-client.git # timeout=10
 > git config --add remote.origin.fetch +refs/heads/*:refs/remotes/origin/* # timeout=10
 > git config remote.origin.url https://github.com/eclipse-glsp/glsp-client.git # timeout=10
Fetching upstream changes from https://github.com/eclipse-glsp/glsp-client.git
using GIT_ASKPASS to set credentials GitHub bot
 > git fetch --tags --force --progress -- https://github.com/eclipse-glsp/glsp-client.git +refs/heads/*:refs/remotes/origin/* # timeout=10
 > git rev-parse refs/remotes/origin/master^{commit} # timeout=10
Checking out Revision 1d7df8ac12eb339cc54adb8f3129926b9ae0a26e (refs/remotes/origin/master)
 > git rev-parse refs/remotes/origin/origin/master^{commit} # timeout=10
 > git config core.sparsecheckout # timeout=10
 > git checkout -f 1d7df8ac12eb339cc54adb8f3129926b9ae0a26e # timeout=10
 > git branch -a -v --no-abbrev # timeout=10
 > git checkout -b master 1d7df8ac12eb339cc54adb8f3129926b9ae0a26e # timeout=10
Commit message: "#111 Convert to mono repo and add dev example (#83)"
 > git rev-list --no-walk 461edec40efb1f0487377f68a26378a2d7a2d4a8 # timeout=10
[Pipeline] }
[Pipeline] // stage
[Pipeline] stage
[Pipeline] { (Build & Deploy)
[Pipeline] container
[Pipeline] {
[Pipeline] sh
+ ls
CONTRIBUTING.md
Jenkinsfile
LICENSE
README.md
configs
examples
lerna.json
package.json
packages
tslint.json
yarn.lock
[Pipeline] withCredentials
Masking supported pattern matches of $NPM_AUTH_TOKEN
[Pipeline] {
[Pipeline] sh
+ printf //registry.npmjs.org/:_authToken=****

[Pipeline] }
[Pipeline] // withCredentials
[Pipeline] sh
+ git config user.email eclipse-glsp-bot@eclipse.org
[Pipeline] sh
+ git config user.name eclipse-glsp-bot
[Pipeline] sh
+ yarn install
yarn install v1.22.4
[1/5] Validating package.json...
[2/5] Resolving packages...
[3/5] Fetching packages...
info fsevents@2.1.3: The platform "linux" is incompatible with this module.
info "fsevents@2.1.3" is an optional dependency and failed compatibility check. Excluding it from installation.
info fsevents@1.2.13: The platform "linux" is incompatible with this module.
info "fsevents@1.2.13" is an optional dependency and failed compatibility check. Excluding it from installation.
[4/5] Linking dependencies...
warning "workspace-aggregator-55b2ec35-3d27-4ad9-a693-06ff742fa2c4 > @eclipse-glsp/client > sprotty > snabbdom-virtualize@0.7.0" has incorrect peer dependency "snabbdom@~0.6.6".
[5/5] Building fresh packages...
$ lerna run prepare
lerna info version 2.11.0
@eclipse-glsp/protocol: yarn run v1.22.4
@eclipse-glsp/protocol: $ yarn run clean && yarn run build
@eclipse-glsp/protocol: $ rimraf lib
@eclipse-glsp/protocol: $ tsc && yarn run lint
@eclipse-glsp/protocol: $ tslint -c ../../tslint.json --project ./tsconfig.json
@eclipse-glsp/protocol: Done in 5.50s.
@eclipse-glsp/client: yarn run v1.22.4
@eclipse-glsp/client: $ yarn run clean && yarn run build
@eclipse-glsp/client: $ rimraf lib
@eclipse-glsp/client: $ tsc && yarn run lint
@eclipse-glsp/client: $ tslint -c ../../tslint.json --project ./tsconfig.json
@eclipse-glsp/client: Done in 10.65s.
@eclipse-glsp-examples/workflow-sprotty: yarn run v1.22.4
@eclipse-glsp-examples/workflow-sprotty: $ yarn run clean && yarn run build
@eclipse-glsp-examples/workflow-sprotty: $ rimraf lib
@eclipse-glsp-examples/workflow-sprotty: $ tsc && yarn run lint
@eclipse-glsp-examples/workflow-sprotty: $ tslint -c ../../configs/tslint.json --project ./tsconfig.json
@eclipse-glsp-examples/workflow-sprotty: Done in 5.77s.
workflow-standalone: yarn run v1.22.4
workflow-standalone: $ yarn run clean && yarn build
workflow-standalone: $ rimraf lib app/bundle.js app/bundle.js.map app/css
workflow-standalone: $ tsc && yarn lint && webpack
workflow-standalone: $ tslint -c ../../configs/tslint.json --project ./tsconfig.json
workflow-standalone: (node:521) DeprecationWarning: Tapable.plugin is deprecated. Use new API on `.hooks` instead
workflow-standalone: Hash: 7cc25a6c971e40015680
workflow-standalone: Version: webpack 4.44.1
workflow-standalone: Time: 3775ms
workflow-standalone: Built at: 09/04/2020 2:31:28 PM
workflow-standalone:         Asset      Size  Chunks                   Chunk Names
workflow-standalone:     bundle.js  3.16 MiB    main  [emitted]        main
workflow-standalone: bundle.js.map  3.25 MiB    main  [emitted] [dev]  main
workflow-standalone: Entrypoint main = bundle.js bundle.js.map
workflow-standalone: [0] multi core-js/es6/map core-js/es6/promise core-js/es6/string core-js/es6/symbol ./lib/main 76 bytes {main} [built]
workflow-standalone: [../../node_modules/webpack/buildin/global.js] (webpack)/buildin/global.js 472 bytes {main} [built]
workflow-standalone: [../../packages/client/lib/base/action-dispatcher.js] /home/jenkins/agent/workspace/deploy-npm-glsp-client/packages/client/lib/base/action-dispatcher.js 6.67 KiB {main} [built]
workflow-standalone: [../../packages/client/lib/base/actions/context-actions.js] /home/jenkins/agent/workspace/deploy-npm-glsp-client/packages/client/lib/base/actions/context-actions.js 2.25 KiB {main} [built]
workflow-standalone: [../../packages/client/lib/base/actions/edit-mode-action.js] /home/jenkins/agent/workspace/deploy-npm-glsp-client/packages/client/lib/base/actions/edit-mode-action.js 1.98 KiB {main} [built]
workflow-standalone: [../../packages/client/lib/base/actions/edit-validation-actions.js] /home/jenkins/agent/workspace/deploy-npm-glsp-client/packages/client/lib/base/actions/edit-validation-actions.js 3.77 KiB {main} [built]
workflow-standalone: [../../packages/client/lib/base/actions/protocol-actions.js] /home/jenkins/agent/workspace/deploy-npm-glsp-client/packages/client/lib/base/actions/protocol-actions.js 3.96 KiB {main} [built]
workflow-standalone: [../../packages/client/lib/base/args.js] /home/jenkins/agent/workspace/deploy-npm-glsp-client/packages/client/lib/base/args.js 109 bytes {main} [built]
workflow-standalone: [../../packages/client/lib/base/auto-complete/auto-complete-actions.js] /home/jenkins/agent/workspace/deploy-npm-glsp-client/packages/client/lib/base/auto-complete/auto-complete-actions.js 354 bytes {main} [built]
workflow-standalone: [../../packages/client/lib/base/auto-complete/auto-complete-widget.js] /home/jenkins/agent/workspace/deploy-npm-glsp-client/packages/client/lib/base/auto-complete/auto-complete-widget.js 12 KiB {main} [built]
workflow-standalone: [../../packages/client/lib/base/auto-complete/validation-decorator.js] /home/jenkins/agent/workspace/deploy-npm-glsp-client/packages/client/lib/base/auto-complete/validation-decorator.js 5.8 KiB {main} [built]
workflow-standalone: [../../packages/client/lib/index.js] /home/jenkins/agent/workspace/deploy-npm-glsp-client/packages/client/lib/index.js 9 KiB {main} [built]
workflow-standalone: [../../packages/protocol/lib/index.js] /home/jenkins/agent/workspace/deploy-npm-glsp-client/packages/protocol/lib/index.js 1.58 KiB {main} [built]
workflow-standalone: [./lib/di.config.js] 1.53 KiB {main} [built]
workflow-standalone: [./lib/main.js] 2.68 KiB {main} [built]
workflow-standalone:     + 690 hidden modules
workflow-standalone: Done in 9.75s.
lerna success run Ran npm script 'prepare' in packages:
lerna success - @eclipse-glsp/client
lerna success - @eclipse-glsp/protocol
lerna success - @eclipse-glsp-examples/workflow-sprotty
lerna success - workflow-standalone
Done in 55.53s.
[Pipeline] sh
+ yarn publish:next
yarn run v1.22.4
$ lerna publish --exact --canary=next --npm-tag=next --yes --access public
lerna info version 2.11.0
lerna info canary enabled
lerna info current version 0.7.0
lerna info Checking for updated packages...
lerna info Comparing with 1d7df8ac^..1d7df8ac.
lerna info Checking for prereleased packages...

Changes:
 - @eclipse-glsp/client: 0.7.1 => 0.8.0-next.1d7df8ac
 - @eclipse-glsp/protocol: 0.7.0 => 0.8.0-next.1d7df8ac
 - @eclipse-glsp-examples/workflow-sprotty: 0.7.0 => 0.8.0-next.1d7df8ac
 - workflow-standalone: 0.7.0 => 0.8.0-next.1d7df8ac (private)

lerna info auto-confirmed 
lerna info publish Publishing packages to npm...
lerna ERR! publish Retrying failed publish: @eclipse-glsp/protocol
lerna ERR! publish Retrying failed publish: @eclipse-glsp/protocol
lerna ERR! publish Retrying failed publish: @eclipse-glsp/protocol
lerna ERR! publish Retrying failed publish: @eclipse-glsp/protocol
lerna ERR! publish Ran out of retries while publishing @eclipse-glsp/protocol Error: Command failed: yarn publish --tag next --new-version 0.8.0-next.1d7df8ac
lerna ERR! publish error Couldn't publish package: "https://registry.npmjs.org/@eclipse-glsp%2fprotocol: You must sign up for private packages"
lerna ERR! publish [1/4] Bumping version...
lerna ERR! publish info Current version: 0.8.0-next.1d7df8ac
lerna ERR! publish [2/4] Logging in...
lerna ERR! publish [3/4] Publishing...
lerna ERR! publish $ yarn run clean && yarn run build
lerna ERR! publish $ rimraf lib
lerna ERR! publish $ tsc && yarn run lint
lerna ERR! publish $ tslint -c ../../tslint.json --project ./tsconfig.json
lerna ERR! publish info Visit https://yarnpkg.com/en/docs/cli/publish for documentation about this command.
lerna ERR! publish 
lerna ERR! publish     at Promise.all.then.arr (/home/jenkins/agent/workspace/deploy-npm-glsp-client/node_modules/lerna/node_modules/execa/index.js:236:11)
lerna ERR! publish     at process._tickCallback (internal/process/next_tick.js:68:7)
lerna ERR! execute callback with error
lerna ERR! Error: Command failed: yarn publish --tag next --new-version 0.8.0-next.1d7df8ac
lerna ERR! error Couldn't publish package: "https://registry.npmjs.org/@eclipse-glsp%2fprotocol: You must sign up for private packages"
lerna ERR! [1/4] Bumping version...
lerna ERR! info Current version: 0.8.0-next.1d7df8ac
lerna ERR! [2/4] Logging in...
lerna ERR! [3/4] Publishing...
lerna ERR! $ yarn run clean && yarn run build
lerna ERR! $ rimraf lib
lerna ERR! $ tsc && yarn run lint
lerna ERR! $ tslint -c ../../tslint.json --project ./tsconfig.json
lerna ERR! info Visit https://yarnpkg.com/en/docs/cli/publish for documentation about this command.
lerna ERR! 
lerna ERR!     at Promise.all.then.arr (/home/jenkins/agent/workspace/deploy-npm-glsp-client/node_modules/lerna/node_modules/execa/index.js:236:11)
{ stack:
   'Error: Command failed: yarn publish --tag next --new-version 0.8.0-next.1d7df8ac\nerror Couldn\'t publish package: "https://registry.npmjs.org/@eclipse-glsp%2fprotocol: You must sign up for private packages"\n[1/4] Bumping version...\ninfo Current version: 0.8.0-next.1d7df8ac\n[2/4] Logging in...\n[3/4] Publishing...\n$ yarn run clean && yarn run build\n$ rimraf lib\n$ tsc && yarn run lint\n$ tslint -c ../../tslint.json --project ./tsconfig.json\ninfo Visit https://yarnpkg.com/en/docs/cli/publish for documentation about this command.\n\n    at Promise.all.then.arr (/home/jenkins/agent/workspace/deploy-npm-glsp-client/node_modules/lerna/node_modules/execa/index.js:236:11)\n    at process._tickCallback (internal/process/next_tick.js:68:7)',
  exitCode: 1 }
error Command failed with exit code 1.
info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this command.
[Pipeline] }
[Pipeline] // container
[Pipeline] }
[Pipeline] // stage
[Pipeline] }
[Pipeline] // withEnv
[Pipeline] }
[Pipeline] // node
[Pipeline] }
[Pipeline] // podTemplate
[Pipeline] End of Pipeline
ERROR: script returned exit code 1
Finished: FAILURE