FailedConsole Output

Started by an SCM change
Started by an SCM change
Started by an SCM change
Started by an SCM change
Started by an SCM change
Started by an SCM change
Running as SYSTEM
Agent ui-test-agent-rqdtq is provisioned from template Kubernetes Pod Template
---
apiVersion: "v1"
kind: "Pod"
metadata:
  annotations: {}
  labels:
    jenkins: "slave"
    jenkins/ui-test: "true"
  name: "ui-test-agent-rqdtq"
spec:
  containers:
  - env:
    - name: "JENKINS_SECRET"
      value: "3b2dc632db1466264f916b104b751cd8ef2b31edc030ab38ccafa17ebee35bbe"
    - name: "JENKINS_TUNNEL"
      value: "jenkins-discovery.gendoc.svc.cluster.local:50000"
    - name: "JENKINS_AGENT_NAME"
      value: "ui-test-agent-rqdtq"
    - name: "JENKINS_NAME"
      value: "ui-test-agent-rqdtq"
    - name: "JENKINS_URL"
      value: "http://jenkins-ui.gendoc.svc.cluster.local/gendoc/"
    - name: "HOME"
      value: "/home/jenkins"
    image: "eclipsecbijenkins/ui-test-agent:3.29@sha256:b5f847bd86f2761b7c8487e8b97fc5925d9aba6382c88a68fea1aaa01e12db59"
    imagePullPolicy: "IfNotPresent"
    name: "jnlp"
    resources:
      limits:
        memory: "4096Mi"
        cpu: "2000m"
      requests:
        memory: "4096Mi"
        cpu: "1000m"
    securityContext:
      privileged: false
    tty: true
    volumeMounts:
    - mountPath: "/home/jenkins/.m2/toolchains.xml"
      name: "toolchains-xml"
      readOnly: true
      subPath: "toolchains.xml"
    - mountPath: "/opt/tools"
      name: "volume-0"
      readOnly: false
    - mountPath: "/home/jenkins/.m2/repository"
      name: "volume-2"
      readOnly: false
    - mountPath: "/home/jenkins"
      name: "workspace-volume"
      readOnly: false
    - mountPath: "/home/jenkins/.m2/settings.xml"
      name: "settings-xml"
      readOnly: true
      subPath: "settings.xml"
    - mountPath: "/home/jenkins/.ssh"
      name: "volume-1"
      readOnly: false
    workingDir: "/home/jenkins"
  nodeSelector: {}
  restartPolicy: "Never"
  volumes:
  - name: "volume-0"
    persistentVolumeClaim:
      claimName: "tools-claim-jiro-gendoc"
      readOnly: true
  - configMap:
      items:
      - key: "toolchains.xml"
        path: "toolchains.xml"
      name: "m2-dir"
    name: "toolchains-xml"
  - emptyDir:
      medium: ""
    name: "volume-2"
  - configMap:
      name: "known-hosts"
    name: "volume-1"
  - configMap:
      items:
      - key: "settings.xml"
        path: "settings.xml"
      name: "m2-dir"
    name: "settings-xml"
  - emptyDir:
      medium: ""
    name: "workspace-volume"

Building remotely on ui-test-agent-rqdtq (ui-test) in workspace /home/jenkins/workspace/Gendoc-2018-12
No credentials specified
Cloning the remote Git repository
Cloning repository http://git.eclipse.org/gitroot/gendoc/org.eclipse.gendoc.git
 > /usr/bin/git init /home/jenkins/workspace/Gendoc-2018-12 # timeout=10
Fetching upstream changes from http://git.eclipse.org/gitroot/gendoc/org.eclipse.gendoc.git
 > /usr/bin/git --version # timeout=10
 > /usr/bin/git fetch --tags --force --progress http://git.eclipse.org/gitroot/gendoc/org.eclipse.gendoc.git +refs/heads/*:refs/remotes/origin/*
 > /usr/bin/git config remote.origin.url http://git.eclipse.org/gitroot/gendoc/org.eclipse.gendoc.git # timeout=10
 > /usr/bin/git config --add remote.origin.fetch +refs/heads/*:refs/remotes/origin/* # timeout=10
 > /usr/bin/git config remote.origin.url http://git.eclipse.org/gitroot/gendoc/org.eclipse.gendoc.git # timeout=10
Fetching upstream changes from http://git.eclipse.org/gitroot/gendoc/org.eclipse.gendoc.git
 > /usr/bin/git fetch --tags --force --progress http://git.eclipse.org/gitroot/gendoc/org.eclipse.gendoc.git +refs/heads/*:refs/remotes/origin/*
 > /usr/bin/git rev-parse origin/master^{commit} # timeout=10
Checking out Revision ccb8525794f91bc7c60549d0490ef8903a995059 (origin/master)
 > /usr/bin/git config core.sparsecheckout # timeout=10
 > /usr/bin/git checkout -f ccb8525794f91bc7c60549d0490ef8903a995059
Commit message: "Set latest nightly to 2019-09"
 > /usr/bin/git rev-list --no-walk 552ecbf0eeafd8b9c22649761ed1acfdaa6a08e0 # timeout=10
$ pkill Xvnc
$ pkill Xrealvnc
$ sh -c "rm -f /tmp/.X*-lock /tmp/.X11-unix/X*"
Starting xvnc
[Gendoc-2018-12] $ Xvnc :40 -geometry 1024x768 -depth 24 -ac -SecurityTypes none -noreset
Parsing POMs
_XSERVTransmkdir: ERROR: euid != 0,directory /tmp/.X11-unix will not be created.

Xvnc TigerVNC 1.9.0 - built Sep 25 2018 10:38:14
Copyright (C) 1999-2018 TigerVNC Team and many others (see README.rst)
See http://www.tigervnc.org for information on TigerVNC.
Underlying X server release 12001000, The X.Org Foundation


Tue Sep 24 14:26:28 2019
 vncext:      VNC extension running!
 vncext:      Listening for VNC connections on all interface(s), port 5940
 vncext:      created VNC server for screen 0
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning:          Unsupported high keycode 372 for name <I372> ignored
>                   X11 cannot support keycodes above 255.
>                   This warning only shows for the first high keycode.
Errors from xkbcomp are not fatal to the X server
Established TCP socket on 42741
Copied maven35-agent.jar
Copied maven35-interceptor.jar
Copied maven3-interceptor-commons.jar
[Gendoc-2018-12] $ /opt/tools/java/oracle/jdk-8/latest/bin/java -cp /home/jenkins/maven35-agent.jar:/opt/tools/apache-maven/latest/boot/plexus-classworlds-2.5.2.jar:/opt/tools/apache-maven/latest/conf/logging jenkins.maven3.agent.Maven35Main /opt/tools/apache-maven/latest /usr/share/jenkins/slave.jar /home/jenkins/maven35-interceptor.jar /home/jenkins/maven3-interceptor-commons.jar 42741
Picked up JAVA_TOOL_OPTIONS: -XX:+IgnoreUnrecognizedVMOptions -XX:+UseContainerSupport -XX:+UnlockExperimentalVMOptions -XX:+UseCGroupMemoryLimitForHeap
Picked up _JAVA_OPTIONS: -XX:MaxRAMPercentage=64.0
<===[JENKINS REMOTING CAPACITY]===>channel started
Executing Maven:  -B -f /home/jenkins/workspace/Gendoc-2018-12/pom.xml clean install -P2018-12
[INFO] Scanning for projects...
[INFO] Downloading from Eclipse.org CBI repo: https://repo.eclipse.org/content/groups/cbi/org/eclipse/tycho/tycho-maven-plugin/1.3.0/tycho-maven-plugin-1.3.0.pom
[INFO] Downloading from Eclipse - Acceleo Release: https://repo.eclipse.org/content/repositories/acceleo-releases/org/eclipse/tycho/tycho-maven-plugin/1.3.0/tycho-maven-plugin-1.3.0.pom
[INFO] Downloading from Eclipse - Acceleo Snapshot: https://repo.eclipse.org/content/repositories/acceleo-snapshots/org/eclipse/tycho/tycho-maven-plugin/1.3.0/tycho-maven-plugin-1.3.0.pom
[INFO] Downloading from eclipse.maven.central.mirror: https://repo.eclipse.org/content/repositories/maven_central/org/eclipse/tycho/tycho-maven-plugin/1.3.0/tycho-maven-plugin-1.3.0.pom
[ERROR] [ERROR] Some problems were encountered while processing the POMs:
[ERROR] Unresolveable build extension: Plugin org.eclipse.tycho:tycho-maven-plugin:1.3.0 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.eclipse.tycho:tycho-maven-plugin:jar:1.3.0 @ 
 @ 
[ERROR] The build could not read 1 project -> [Help 1]
[ERROR]   
[ERROR]   The project org.eclipse.gendoc:parent:0.7.2-SNAPSHOT (/home/jenkins/workspace/Gendoc-2018-12/pom.xml) has 1 error
[ERROR]     Unresolveable build extension: Plugin org.eclipse.tycho:tycho-maven-plugin:1.3.0 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.eclipse.tycho:tycho-maven-plugin:jar:1.3.0: Could not transfer artifact org.eclipse.tycho:tycho-maven-plugin:pom:1.3.0 from/to Eclipse.org CBI repo (https://repo.eclipse.org/content/groups/cbi/): repo.eclipse.org: Name or service not known: Unknown host repo.eclipse.org: Name or service not known -> [Help 2]
[ERROR] 
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR] 
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/ProjectBuildingException
[ERROR] [Help 2] http://cwiki.apache.org/confluence/display/MAVEN/PluginManagerException
Terminating xvnc.
channel stopped

Tue Sep 24 14:27:05 2019
 ComparingUpdateTracker: 0 pixels in / 0 pixels out
 ComparingUpdateTracker: (1:-nan ratio)
Archiving artifacts
Not sending mail to unregistered user antonio.campesino.robles@ericsson.com
Sending e-mails to: antonio.campesino.robles@ericsson.com
ERROR: Unknown SMTP host: mail.eclipse.org
javax.mail.MessagingException: Unknown SMTP host: mail.eclipse.org;
  nested exception is:
	java.net.UnknownHostException: mail.eclipse.org
	at com.sun.mail.smtp.SMTPTransport.openServer(SMTPTransport.java:1932)
	at com.sun.mail.smtp.SMTPTransport.protocolConnect(SMTPTransport.java:638)
	at javax.mail.Service.connect(Service.java:295)
	at javax.mail.Service.connect(Service.java:176)
	at javax.mail.Service.connect(Service.java:125)
	at javax.mail.Transport.send0(Transport.java:194)
	at javax.mail.Transport.send(Transport.java:124)
	at hudson.tasks.MailSender.run(MailSender.java:131)
	at hudson.tasks.MailSender.execute(MailSender.java:106)
	at hudson.maven.MavenModuleSetBuild$MavenModuleSetBuildExecution.cleanUp(MavenModuleSetBuild.java:1095)
	at hudson.model.Run.execute(Run.java:1865)
	at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:543)
	at hudson.model.ResourceController.execute(ResourceController.java:97)
	at hudson.model.Executor.run(Executor.java:429)
Caused by: java.net.UnknownHostException: mail.eclipse.org
	at java.net.AbstractPlainSocketImpl.connect(Unknown Source)
	at java.net.SocksSocketImpl.connect(Unknown Source)
	at java.net.Socket.connect(Unknown Source)
	at com.sun.mail.util.SocketFetcher.createSocket(SocketFetcher.java:286)
	at com.sun.mail.util.SocketFetcher.getSocket(SocketFetcher.java:231)
	at com.sun.mail.smtp.SMTPTransport.openServer(SMTPTransport.java:1900)
	... 13 more
Finished: FAILURE