FailedConsole Output

Started by an SCM change
Building in workspace /home/hudson/genie.elogbook/.jenkins/jobs/openKonsequenz-elogbook-frontend (DEVELOP)/workspace
 > /usr/local/bin/git rev-parse --is-inside-work-tree # timeout=10
Fetching changes from the remote Git repository
 > /usr/local/bin/git config remote.origin.url http://git.eclipse.org/gitroot/elogbook/elogbookFE.git # timeout=10
Fetching upstream changes from http://git.eclipse.org/gitroot/elogbook/elogbookFE.git
 > /usr/local/bin/git --version # timeout=10
 > /usr/local/bin/git fetch --tags --progress http://git.eclipse.org/gitroot/elogbook/elogbookFE.git +refs/heads/*:refs/remotes/origin/*
 > /usr/local/bin/git rev-parse origin/DEVELOP_FE^{commit} # timeout=10
Checking out Revision 037439c27a5839c16bb6552b33d6f55ea6f956e3 (origin/DEVELOP_FE)
 > /usr/local/bin/git config core.sparsecheckout # timeout=10
 > /usr/local/bin/git checkout -f 037439c27a5839c16bb6552b33d6f55ea6f956e3
Commit message: "merged css in btb css"
 > /usr/local/bin/git rev-list --no-walk fc5b9e0d7b01db2fd5d673202795362f6bac7cfa # timeout=10
[workspace] $ /bin/sh -xe /tmp/genie.elogbook/jenkins339639328699387925.sh
+ npm install --save-dev @angular/cli@latest
npm WARN @angular/material@2.0.0-beta.2 requires a peer of @angular/core@^2.3.0 but none is installed. You must install peer dependencies yourself.
npm WARN @angular/material@2.0.0-beta.2 requires a peer of @angular/common@^2.3.0 but none is installed. You must install peer dependencies yourself.
npm WARN @angular/material@2.0.0-beta.2 requires a peer of @angular/http@^2.3.0 but none is installed. You must install peer dependencies yourself.
npm WARN ng2-daterangepicker@2.0.12 requires a peer of @types/jquery@^3.2.12 but none is installed. You must install peer dependencies yourself.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.1.3 (node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.1.3: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.4 (node_modules/@schematics/update/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.4: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.4 (node_modules/@angular/cli/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.4: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.4 (node_modules/@angular-devkit/architect/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.4: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})

+ @angular/cli@7.0.2
added 351 packages, removed 5 packages and updated 17 packages in 59.096s
[workspace] $ /bin/sh -xe /tmp/genie.elogbook/jenkins2807067935762584845.sh
+ npm install
npm WARN @angular/material@2.0.0-beta.2 requires a peer of @angular/core@^2.3.0 but none is installed. You must install peer dependencies yourself.
npm WARN @angular/material@2.0.0-beta.2 requires a peer of @angular/common@^2.3.0 but none is installed. You must install peer dependencies yourself.
npm WARN @angular/material@2.0.0-beta.2 requires a peer of @angular/http@^2.3.0 but none is installed. You must install peer dependencies yourself.
npm WARN ng2-daterangepicker@2.0.12 requires a peer of @types/jquery@^3.2.12 but none is installed. You must install peer dependencies yourself.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.4 (node_modules/@angular-devkit/architect/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.4: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.4 (node_modules/@angular/cli/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.4: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.4 (node_modules/@schematics/update/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.4: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.4 (node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.4: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})

added 269 packages in 10.391s
[workspace] $ /bin/sh -xe /tmp/genie.elogbook/jenkins6435209885427923133.sh
+ ng test --single-run
/tmp/genie.elogbook/jenkins6435209885427923133.sh: line 2: ng: command not found
Build step 'Execute shell' marked build as failure
Archiving artifacts
Recording test results
ERROR: Step ‘Publish JUnit test result report’ failed: No test report files were found. Configuration error?
Started calculate disk usage of build
Finished Calculation of disk usage of build in 0 seconds
Started calculate disk usage of workspace
Finished Calculation of disk usage of workspace in 0 seconds
Finished: FAILURE