Failed

org.eclipse.ceylon.compiler.java.test.issues.IssuesTests_7000_7499.bug7416 (from org.eclipse.ceylon.compiler.java.test.ConcurrentTests)

Failing for the past 111 builds (Since #616 )
Took 2.6 sec.

Error Message

Compilation failed
ERROR: backend: 2: Ceylon backend error: bad operand types for binary operator '<'
  first type:  org.eclipse.ceylon.compiler.java.test.issues.bug71xx.Bug7416
  second type: long
WARNING: frontend: 22: You import an earlier JDK (7), which is provided by the current JDK (8) you are running on, but we cannot check that you are not using any of the current JDK-specific classes or methods. Upgrade your import to the current JDK if you depend on the current JDK classes or methods.
WARNING: frontend: 23: You import an earlier JDK (7), which is provided by the current JDK (8) you are running on, but we cannot check that you are not using any of the current JDK-specific classes or methods. Upgrade your import to the current JDK if you depend on the current JDK classes or methods.
WARNING: frontend: 24: You import an earlier JDK (7), which is provided by the current JDK (8) you are running on, but we cannot check that you are not using any of the current JDK-specific classes or methods. Upgrade your import to the current JDK if you depend on the current JDK classes or methods.
NOTE: backend: -1: Created module org.eclipse.ceylon.compiler.java.test.issues/1

Stacktrace

junit.framework.AssertionFailedError: Compilation failed
ERROR: backend: 2: Ceylon backend error: bad operand types for binary operator '<'
  first type:  org.eclipse.ceylon.compiler.java.test.issues.bug71xx.Bug7416
  second type: long
WARNING: frontend: 22: You import an earlier JDK (7), which is provided by the current JDK (8) you are running on, but we cannot check that you are not using any of the current JDK-specific classes or methods. Upgrade your import to the current JDK if you depend on the current JDK classes or methods.
WARNING: frontend: 23: You import an earlier JDK (7), which is provided by the current JDK (8) you are running on, but we cannot check that you are not using any of the current JDK-specific classes or methods. Upgrade your import to the current JDK if you depend on the current JDK classes or methods.
WARNING: frontend: 24: You import an earlier JDK (7), which is provided by the current JDK (8) you are running on, but we cannot check that you are not using any of the current JDK-specific classes or methods. Upgrade your import to the current JDK if you depend on the current JDK classes or methods.
NOTE: backend: -1: Created module org.eclipse.ceylon.compiler.java.test.issues/1
	at org.eclipse.ceylon.compiler.java.test.CompilerTests$CompilationAssertion.onError(CompilerTests.java:607)
	at org.eclipse.ceylon.compiler.java.test.CompilerTests.assertCompiles(CompilerTests.java:635)
	at org.eclipse.ceylon.compiler.java.test.CompilerTests.assertCompilesOk(CompilerTests.java:622)
	at org.eclipse.ceylon.compiler.java.test.CompilerTests.compile(CompilerTests.java:687)
	at org.eclipse.ceylon.compiler.java.test.CompilerTests.compile(CompilerTests.java:696)
	at org.eclipse.ceylon.compiler.java.test.issues.IssuesTests_7000_7499.bug7416(IssuesTests_7000_7499.java:135)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
	at java.lang.Thread.run(Thread.java:748)